Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default Xperia Z1: Lousy Signal after Update

    Hi everyone, new here

    I updated my Xperia Z1 yesterday to 14.2.A.0.290 as it notified as a new update. Since then, I get terrible signal in the office at work and in the room I stay in at night to the point where I have to go outside to make a phonecall, and especially if I want to get any form of decent data coverage.

    Has anyone come across anything like this before, know what I could do to resolve it or even have an idea as to why it's affected it? The pretty unhelpful agent on Sony Chat only told me to do a repair with PC Companion and failing that if I think there's a problem I'll have to send my phone off. I'm furious that the updates they release always seem to make the phone worse, first it was the battery life that took a massive hit a few updates back, and now my signal.

    I don't mess around with ROMs or kernels (don't really understand any of that) so everything is standard. I'm in the UK on the network EE.

    Thanks
    L
    Last edited by NotJustAPhone; 03-11-2014 at 02:10 PM.
  2. #2  

    Default Re: Lousy Signal after Update

    Word of advice. its actually never good to be an early adopter.The issue you have faced is quite common.Nexus 5 users after upgrading to kitkat faced more bugs than features.even Moto G users started getting weak signal after upgrading to kitkat.

    Thats why i always wait at least a month after a update has been annouced
  3. Thread Author  Thread Author    #3  

    Default Re: Xperia Z1: Lousy Signal after Update

    It's not even the kitkat update though, I could expect a few bugs early doors if it was. I don't know, do you think I'm just going to have to put up with a 500 paperweight until they bring out a new update?

Similar Threads

  1. Galaxy S4: Problem with 4.4 update hide app
    By Fabian F in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 11-04-2014, 12:13 PM
  2. Galaxy S4: SD CARD Issue in KITKAT update
    By sunny sharma13 in forum Samsung Galaxy S4
    Replies: 18
    Last Post: 10-14-2014, 09:23 PM
  3. Help: Black screen after bootanimation [water damage]
    By tenjou_89 in forum Moto G (2013)
    Replies: 1
    Last Post: 06-12-2014, 03:13 PM
  4. HTC One Dev Edition update rolling out
    By nts3rd in forum HTC One
    Replies: 3
    Last Post: 03-11-2014, 02:28 PM
  5. Lousy signal after update
    By L6689 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 03-11-2014, 01:58 PM

Posting Permissions