1. marshatherton's Avatar
    My sony xperia z1s is getting laggy. When I hit the home screen, it's taking a good 2 seconds to load.

    Any ideas?

    Posted via Android Central App
    04-13-2014 09:09 PM
  2. Golfdriver97's Avatar
    I have no idea how to, but you can try clearing cache in recovery.
    04-13-2014 09:54 PM
  3. marshatherton's Avatar
    Oh. Anyone?

    Posted via Android Central App
    04-14-2014 06:17 AM
  4. marshatherton's Avatar
    I figured it out. It's better.

    Posted via Android Central App
    04-14-2014 06:55 PM
  5. mookster's Avatar
    Just out of curiosity, what was your solution?

    Sent from my C6916 using Tapatalk
    04-14-2014 08:23 PM
  6. marshatherton's Avatar
    Clearing the cache. Press and hold volume up and power, for three seconds, it resets the phone and cache.

    Posted via Android Central App
    mookster likes this.
    04-14-2014 10:35 PM
  7. mookster's Avatar
    Clearing the cache. Press and hold volume up and power, for three seconds, it resets the phone and cache.

    Posted via Android Central App
    Nifty thing to know, didn't think my phone was slow but it's zippier after doing that. Thanks.

    Sent from my C6916 using Tapatalk
    04-15-2014 09:44 PM

Similar Threads

  1. Samsung Galaxy s3 is laggy?
    By Jerry Reyes1 in forum General Help and How To
    Replies: 0
    Last Post: 04-12-2014, 05:02 PM
  2. SMS and MMS very laggy
    By speedtrip in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 03-07-2014, 06:08 PM
  3. Replies: 14
    Last Post: 02-26-2014, 07:14 PM
  4. Laggy audio on GS3
    By liamzuid in forum Samsung Galaxy SIII I9300
    Replies: 1
    Last Post: 02-08-2014, 04:25 PM
  5. Galaxy S3: laggy music playback
    By hasaan001 in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 02-02-2014, 08:08 AM
LINK TO POST COPIED TO CLIPBOARD