Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. Thread Author  Thread Author    #1  

    Default AT&T LTE?

    So i've had the phone for a few days , went to the store to get it activated. But only getting H and H+?

    Does it work with at&t LTE? I called them up and they said my IMEI cannot be recognized, only other way is to use another android device IMEI... which i don't have.
  2. #2  

    Default Re: At&t LTE?

    Yes, it works with AT&Ts LTE. I had the same problem when I first had mine and I took it to the device support center here in lower Manhattan. Even the tech didn't know what the problem was until he stumbled upon the answer. Since it's a foreign market phone, there's some software that needs to be downloaded to allow the phone to communicate with The U.S AT&T LTE network. As soon as it was installed, I had instant LTE. I wish I could be specific, but I just didn't catch what it was called, but if you ask a tech about it specifically, I'm sure they can help you.
  3. Thread Author  Thread Author    #3  

    Default Re: At&t LTE?

    Quote Originally Posted by RicKaysen View Post
    Yes, it works with AT&Ts LTE. I had the same problem when I first had mine and I took it to the device support center here in lower Manhattan. Even the tech didn't know what the problem was until he stumbled upon the answer. Since it's a foreign market phone, there's some software that needs to be downloaded to allow the phone to communicate with The U.S AT&T LTE network. As soon as it was installed, I had instant LTE. I wish I could be specific, but I just didn't catch what it was called, but if you ask a tech about it specifically, I'm sure they can help you.
    Spoke with 3 att reps but they couldn't help me, said its a foreign phone something something not guaranteed to work with at&t so im stuck with 3g. Damn i wish you remembered what you did
  4. #4  
    ddot196's Avatar

    Posts
    306 Posts
    Global Posts
    327 Global Posts

    Default Re: AT&T LTE?

    Don't speak with any goofy reps. They never know anything. Go to an actual repair center for att and speak with a service tech there. I'm sure they can figure it out.

    Posted via Android Central App
  5. #5  
    gtg465x's Avatar

    Posts
    135 Posts
    Global Posts
    287 Global Posts

    Default

    Lol, I feel ya. AT&T is stupid. Just go into an AT&T store and get the IMEI of any display phone with Android, and then call them up and tell them you purchased whatever type of phone you got it from, give them the IMEI, and voila! I always buy unlocked off contract and have successfully done this several times.

    Only other thing you might or might not have to do is manually enter the correct APN settings for LTE. You can copy the APN settings from a display unit in their store. If they ask if they can help you with anything, tell them that they're too stupid to.
  6. #6  

    Default Re: AT&T LTE?

    All it took was some fiddling in settings....maybe in tools-mobile network settings. I really wish I was paying closer attention, but he was behind the counter. All I know is it was a quick download and he was able to click on AT&T and, done. You're not stuck with 3G.
  7. Thread Author  Thread Author    #7  

    Default Re: AT&T LTE?

    Quote Originally Posted by RicKaysen View Post
    All it took was some fiddling in settings....maybe in tools-mobile network settings. I really wish I was paying closer attention, but he was behind the counter. All I know is it was a quick download and he was able to click on AT&T and, done. You're not stuck with 3G.
    First time i went to get sim, we couldn't even get any connection and they told me well maybe its an unlocked phone you can't get data, left the store and did something similar and downloaded and got H+ speeds but not LTE.
  8. #8  

    Default Re: AT&T LTE?

    You need LTE activated on your account which can only be done from an AT&T IMEI. The easiest way is to get them to configure a sim using one of their display phones and then install that sim in to your Z2. Once it's added to your account you're fine for future phones. Shame AT&T makes this so difficult.
    .
    All new users will need to go to Wireless & Networks -> Internet settings to install the correct network settings as well.
  9. Thread Author  Thread Author    #9  

    Default Re: AT&T LTE?

    Quote Originally Posted by sevans View Post
    You need LTE activated on your account which can only be done from an AT&T IMEI. The easiest way is to get them to configure a sim using one of their display phones and then install that sim in to your Z2. Once it's added to your account you're fine for future phones. Shame AT&T makes this so difficult.
    .
    All new users will need to go to Wireless & Networks -> Internet settings to install the correct network settings as well.
    Will it work with the display phones?, i asked the other time i went in and they said something about it being unique and can't be used for two devices.
  10. #10  

    Default Re: AT&T LTE?

    Yes. I know several people who've had to do it. You just need an AT&T IMEI for the LTE account activation. It isn't used after that. If you can get one of the reps to try their sim in your phone it will get LTE.
  11. #11  

    Default Re: AT&T LTE?

    Quote Originally Posted by RicKaysen View Post
    Yes, it works with AT&Ts LTE. I had the same problem when I first had mine and I took it to the device support center here in lower Manhattan. Even the tech didn't know what the problem was until he stumbled upon the answer. Since it's a foreign market phone, there's some software that needs to be downloaded to allow the phone to communicate with The U.S AT&T LTE network. As soon as it was installed, I had instant LTE. I wish I could be specific, but I just didn't catch what it was called, but if you ask a tech about it specifically, I'm sure they can help you.
    Mine just worked with AT&T LTE from the start.
  12. Thread Author  Thread Author    #12  

    Default Re: AT&T LTE?

    Quote Originally Posted by intrepid359 View Post
    Mine just worked with AT&T LTE from the start.
    You probably had a phone already with LTE before?
  13. Thread Author  Thread Author    #13  

    Default Re: AT&T LTE?

    Quote Originally Posted by sevans View Post
    Yes. I know several people who've had to do it. You just need an AT&T IMEI for the LTE account activation. It isn't used after that. If you can get one of the reps to try their sim in your phone it will get LTE.
    I got it to work with LTE with some random one IMEI and calling them up. I guess you have to tell them its an at&t phone or else they won't bother with you. Will they notice if someone else uses the IMEI? Does att update the imei when you use the sony z2, cause im kind afraid of the random imei not working.
    Last edited by xorua; 04-19-2014 at 03:10 AM.
  14. #14  
    gtg465x's Avatar

    Posts
    135 Posts
    Global Posts
    287 Global Posts

    Default

    Quote Originally Posted by xorua View Post
    I got it to work with LTE with some random one IMEI and calling them up. I guess you have to tell them its an at&t phone or else they won't bother with you. Will they notice if someone else uses the IMEI? Does att update the imei when you use the sony z2, cause im kind afraid of the old imei not working.
    No. Once LTE is active on your account, it won't matter if someone else uses that IMEI. And their system will soon show your phone as unknown, but that's fine too and LTE will continue to work.
  15. Thread Author  Thread Author    #15  

    Default Re: AT&T LTE?

    Quote Originally Posted by gtg465x View Post
    No. Once LTE is active on your account, it won't matter if someone else uses that IMEI. And their system will soon show your phone as unknown, but that's fine too and LTE will continue to work.
    So it updates the IMEI with the z2 but keep LTE? I was happy with LTE speeds!, but then felt like a I made a huge mistake because I might get caught or something.
  16. #16  

    Default Re: AT&T LTE?

    Don't know if this choice is automatically there or something needs to be downloaded first, but..... Settings... Wireless networks.... More..... Internet settings..... "accept"..... Choose AT&T.
  17. #17  
    gtg465x's Avatar

    Posts
    135 Posts
    Global Posts
    287 Global Posts

    Default Re: AT&T LTE?

    Quote Originally Posted by xorua View Post
    So it updates the IMEI with the z2 but keep LTE?
    Yep

    Quote Originally Posted by xorua View Post
    I was happy with LTE speeds!, but then felt like a I made a huge mistake because I might get caught or something.
    You won't get "caught" because you aren't doing anything wrong or against AT&T policies. The only reason you had to lie to them about your IMEI initially is because AT&T doesn't train their employees on how to set up accounts with non-AT&T phones that support LTE, so the employees usually get confused and just refuse to do anything.
  18. #18  

    Default Re: AT&T LTE?

    Just tell the Att rep to activate your account with an s5 and then put that Sim card into your phone. Easiest explanation I can think of

    Sent from my D6503 using Tapatalk
  19. #19  

    Default Re: AT&T LTE?

    I am using my Z2 on ATT Gophone plan and the LTE signal is very strong. I just got a new sim card from ATT store to use ISIS service.
  20. #20  

    Default Re: AT&T LTE?

    Quote Originally Posted by AirSupply View Post
    I am using my Z2 on ATT Gophone plan and the LTE signal is very strong. I just got a new sim card from ATT store to use ISIS service.
    I just wasted an hour in a AT&T store with reps who couldn't get cellular service back on my phone after installing a new SIM. I went in hoping to get in on the ISIS promotion and after finally getting service restored, I get the message that ISIS is not supported on my phone. Were you successful in getting ISIS to work?

Similar Threads

  1. How do you disable the "Listening at high volume..." warning?
    By Gandhi113 in forum Samsung Galaxy S5
    Replies: 10
    Last Post: 06-28-2014, 07:25 PM
  2. Galaxy S5 lag when looking at photo after taking a pic
    By lasercomp in forum Samsung Galaxy S5
    Replies: 9
    Last Post: 05-10-2014, 12:09 AM
  3. Replies: 4
    Last Post: 04-29-2014, 09:30 AM
  4. Galaxy S4: LTE/Data will not connect
    By kristian19 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 04-21-2014, 04:12 PM
  5. Notification sound when connecting to lte
    By durandetto in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-17-2014, 11:31 PM

Posting Permissions