1. BlackHawkA4's Avatar
    I noticed in the running services that googlt talk, maps, and qik are always running. (Even after reboot and the services were never opened and the task manager is empty). Could this be contributing to the poor battery issues people have been having?

    I don't use google talk; is there a way to unistall it? Or at least is there a way to turn off the running service so it doesn't turn on...

    Also, when I turn on slacker and then quit it appears in the running services as slacker widget running. Is ther a way to disable this on exit?
    09-06-2010 07:02 PM
  2. pcguys's Avatar
    As for talk, open it and menu settings and tell it not to log you in.

    Mike

    Sent from my PC36100 using Tapatalk
    09-06-2010 07:28 PM
  3. BlackHawkA4's Avatar
    Did that, still runs on reboot.
    09-06-2010 09:05 PM
  4. antmon1's Avatar
    wth...same here.... it keeps logging in too.... i have unchecked auto log in, disabled from within Services and have tried to sign out...no help...

    while we're at it..... which services can be safely disabled (perm or at least until the next shut down, start up)

    i have:

    IQ Agent Service
    AndroidSprintExtension
    GTalkService
    OmaDrmConfigService
    QikEngineService
    Android Keyboard
    MobileAPService
    SnsService
    CM_Service
    09-06-2010 09:22 PM
  5. BlackHawkA4's Avatar
    When I manually stopped the running services a few minutes later I checked and they were back running. I'm not sure if there is actually a way to stop them from there. Google talk came back, maps came back, and so did qik.

    Really frees up ram when those services your not using aren't running.
    09-06-2010 09:25 PM
  6. jrmitchell72's Avatar
    I am having the same problem here. Add Sprint Hotspot to my list. I now have ATK set to kill all of those apps when my screen shuts off.
    09-07-2010 06:35 AM
  7. seand26's Avatar
    So far ATK is the only thing to combat this?
    09-08-2010 10:47 AM
  8. SBT's Avatar
    I was also wondering which things were okay to "kill" since they all seem to be back up and running even when I have NEVER used them and they don't show in task mgr.
    09-08-2010 07:48 PM
  9. caliskimmer's Avatar
    Not running for me. Strange that this is happening to some, but maybe it's just that I didn't open some of them. However, I did open Google Talk and that's not running for me.
    09-08-2010 08:30 PM
  10. SBT's Avatar
    Did that, still runs on reboot.
    yup i am CONSTANTLY killing it in running services as well, even though I am NEVER starting it up!

    so i would also like to figure out how to stop this... same with sprint tv
    09-09-2010 08:03 PM
  11. Michael82574's Avatar
    For some reason I get a whole list of crap too! One is Amazon mp3, Nav, voice dialer... Its strange! How can you stop it?
    09-09-2010 09:58 PM
  12. BlackHawkA4's Avatar
    For some reason I get a whole list of crap too! One is Amazon mp3, Nav, voice dialer... Its strange! How can you stop it?
    Use ATK. Set up auto kill for those apps. I get the same ones popping up. I left most of the basic phone feature off the list for auto kill. Ex, messaging, email, etc.

    It's the only thing I've found so far to stop it and battery life and performance has increased drastically!
    09-10-2010 07:21 PM
  13. locationman52's Avatar
    Use ATK. Set up auto kill for those apps. I get the same ones popping up. I left most of the basic phone feature off the list for auto kill. Ex, messaging, email, etc.

    It's the only thing I've found so far to stop it and battery life and performance has increased drastically!
    So, email should be placed on the ignore list? If you set ATK to auto kill email, does your mail not update?

    Thanks in advance...I'm trying to remedy my battery issues.
    09-10-2010 07:49 PM
  14. BlackHawkA4's Avatar
    I didn't put it on the ignore list. I just unchecked it. Sometimes I will end manually kill it. You will still get your emails; but, if you turn the screen on to see the notification and turn to screen off to get back to it later the notification is gone.

    Also, if your sending a file that is large and it takes a while to send: if the screen turns off it will kill the email program which needs to run in the background to continue to send the email.

    Deff helps the battery. Today I got 10 hours 37 minutes of texting, email, a quick web browse, and music on the 25 minute car ride off the charger before it went down to 60%.

    The only things I kept unchecked were:
    Sprint Navigation which randomly starts in the background and not the actually application. This hasn't effected the battery so I leave it. I don't want it to turn off when I am using it and the screen goes off.

    Gmail (I don't use the regular email app but it will always reboot after you turn the screen back on. I may just uncheck it so it's not turning on and off constantly)

    Messaging (Which is another application that will need to turn in the background if sending a text that takes a while; and, notifications will disappear.)

    Music (So when I'm playing the music it doesn't turn off when I turn the screen off.)

    Slacker Radio (sometimes starts randomly. I usually kill it. Doesn't do that much).

    Everything else is set to auto kill with the screen and everything else works fine but Facebook. It doesn't update or receive messages/notifications when it's not allowed to run in the background. I'd rather it not though. I'll get them when I check it. Also I believe market won't tell you a program has an update until you open it.

    Pretty much just kill any applications that don't require notifications to be sent (if you want them) or anything that needs to send data in the background to work properly like the list I put up there.
    locationman52 likes this.
    09-10-2010 08:23 PM
  15. Adam Sawyer's Avatar
    You don't want to delete or deactivate Google Talk's service. It works with GMail, and without it, your email will not push.
    09-10-2010 08:29 PM
  16. BlackHawkA4's Avatar
    You don't want to delete or deactivate Google Talk's service. It works with GMail, and without it, your email will not push.
    That explains why it's running. Makes sense.
    09-10-2010 08:34 PM
  17. nmoreman's Avatar
    If you don't use GMail, so don't need push, could you stop it and affect nothing else??
    09-30-2010 08:13 AM
  18. rando991's Avatar
    After much searching, I finally found some folks who may have had an answer to what SNSService is. SNSService doesn't appear to be anything more than a Samsung Facebook/Twitter sync service (therefore not necessary if you aren't using one of those feeds and if you are using them, then you probably aren't experiencing the SNSService restart bug). If since Froyo, you have noticed SNSService in a "restarting" loop under running services and it's drawing your battery down, you can Force stop it and it should stay down until you reboot your phone. If you don't want to root your phone so that you can remove it, here's a possible fix that worked for me. Since I had removed the "Feeds and Updates" widget from one of my homescreens, I didn't notice the problem until I got the OTA Froyo update. I think that after the update it is looking for that widget to update. So I put the widget back on a homescreen, touched the recycle button at the top right corner of the widget and then I noticed that my SNSService stopped restarting. I subsequently removed the widget and now have yet to see the problem recurr.
    03-10-2011 09:55 AM
  19. Skunkape60's Avatar
    ATK... There are several apps this could be...

    Advanced Task Killer by ReChild or
    Automatic Task Killer by S. Tachibana

    They both have 4 stars.
    03-10-2011 12:05 PM
LINK TO POST COPIED TO CLIPBOARD