Results 1 to 22 of 22
  1. Thread Author  Thread Author    #1  

    Default gmail app very slow what do i do for push email?

    The gmail app on my epic seems to be very slow. I work with my pops and we both used to have blackberries (he still does) and we have one email account that we share. His blackbarry used to get email abuot 1 second faster than mine (when he was in a 3g area) because he is on att and i am on sprint, anyhow. The difference is now in minutes, sometimes as much as 10-20 minutes using the gmail app. Is there something that i am doing wrong? Do i need to leave the gmail app open all the time for it to push email? is there an update for it that i have not recieved? i tested it with my desktop and it takes on average about 10 minutes before i get an email pushed to the gmail app. I tried to send 2 pictures using the gmail app and it sat in the outbox for about 40 minutes before i sent it with the samsung email app and it went out in a matter of 2 minutes or less.

    anyone else seeing this?
    Thanked by:
  2. #2  

    Default

    i have my pop server auto forward all email to my gmail account, email is instant.
  3. Thread Author  Thread Author    #3  

    Default

    it should be instant for me as well. yesterday it was not, however today it is working great. i think i know what the problem was and or is. i am in a area with spotty 4g coverage (but good 3g coverage) so my phone is probably trying to switch back and forth between 4g and 3g very often, so the connection is getting interupted too much. Last night i turned 4g off completely and my gmail app seems to be spot on. maybe 1 or 2 seconds after i send the email from my desktop (testing it) i receive it on my epic.

    what i am going to do is go all day with 4g turned off and see how the email performs. Then go all day tomorrow with the 4g turned on and see how it performs.

    anyone else seeing connection failures often because of spotty 4 g coverage in there area?
  4. #4  

    Default

    Checking to see if you resolved this.

    I'm in a 3G only area with an Epic 4G and am having the slow email problem as well.

    My wait times for email is significantly longer though. I have sent email on my Epic from one hotmail account to a gmail account and waited 3 hours before it arrived.

    Even when I attempt to push the email, it generally takes several minutes after I've checked and seen nothing for anything to show up.

    Hard to believe no one else is having this problem.

    When I had my EVO it was lickety split on email. Epic is an awesome phone, but the email wait time sucks!
    When you can snatch the pebble from my hand, then it will be time for you to leave.
  5. Thread Author  Thread Author    #5  

    Default

    I've done nothing, and my problem went away. It also looks like they put a 4g tower in my area :-) as I now have 4g in my house. Maybe you should try a restart.

    epic 4G
  6. #6  

    Default

    Newbie Question, how exactly do I do a restart?

    Will all my info be lost?
    When you can snatch the pebble from my hand, then it will be time for you to leave.
  7. #7  
    dmlee's Avatar

    Posts
    91 Posts
    ROM
    EB13 with Genocide v.2a

    Default

    Quote Originally Posted by Writermind View Post
    Newbie Question, how exactly do I do a restart?

    Will all my info be lost?
    He just means to turn your phone off and then turn it back on. You can do this by holding down the power button until you get the option to shut down. Then wait until all the lights are off on your phone and hold down the power button again to turn it back on.

    You won't lose any information this way.
  8. #8  
    caliskimmer's Avatar
    Retired Moderator

    Posts
    1,891 Posts
    ROM
    N/A

    Default

    I have all my gmail forwarded to another account and didn't want to reverse it. Sadly, I could not come up with a solution K-9 mail was awful, Maildroid (or whatever is called) did not work. Gmail was adequate at best when I changed settings in my gmail. I hope others don't have this problem as it was quite disappointing.
  9. #9  
    Addie_Goodvibes's Avatar

    Posts
    455 Posts
    Global Posts
    957 Global Posts
    ROM
    Froyo DK28

    Default

    I just tested my gmail from my desktop through sbcglobal to the phone.. almost instant over wiFi
    Also tested incoming from desktop sbcglobal mail to phone over 3G took about 1 min. with medium signal strength.

    From Phone to Sbcglobal over 3G
    e-mail sent form Android Epic to sbcglobal received on my dekstop Sbcglobal almost instant over 3G.

    From Phone to Sbcglobal over WiFi
    Similar results, received from Android Epic within 1 minute.
    May be the area you are in. What is your signal strength over 3G
    Please add thanks if I have helped you in anyway. I will always spread the Aloha and reciprocate.
    Samsung Epic; Froyo DK28
    Carrier Sprint since 1998
    Palm Pilot 1997 + Nokia 7650,8200, Palm Treo 700p 2005, Palm Pre June 2009, Sayonara Palm. Android Sept. 2010
  10. Thread Author  Thread Author    #10  

    Default

    my problem seems to be random. Most of the time gmail pushes the email within a few seconds (i am now on 4g in my home, yay me!) but sometimes the imap email program is first to get my new email and i have to manually go into the gmail application and hit refresh to recieve the email there.

    This is annoying, and i bet a lot of others are having the same problem and just dont know, because they have not tested. I believe the problem lies in the
    Gmail app itself, or possibly another app that i may have downloaded that is interfering with it. couple this problem with the battery life issue and i am not sure if i want to keep this phone or not. i wish the evo had a physical keyboard.
  11. #11  

    Default

    It has to do with the 3G connection going dormant. If you look at the 3G icon after its idle for a little bit, you will notice the 3G-D.


    The EVO has an option called "Enable Always On Data" that prevents the connection from going dormant. However, this option was left off of the Epic for some reason.
  12. Thread Author  Thread Author    #12  

    Default

    so there is no way for me to turn this option on at all on the epic?
  13. Thread Author  Thread Author    #13  

    Default

    its acting up again! I am so annoyed with this phone right now.
  14. #14  

    Default

    I've been working on how to enable always on data, but have not been successful yet.
  15. Thread Author  Thread Author    #15  

    Default

    i dont think this is the problem. because i can get email using the imap email app consistantly and reliably, which means the data is coming through. only problem is that it is not push email. so it only pulls email every 5 minutes or so.
  16. Thread Author  Thread Author    #16  

    Default

    well i call sprint i am on hold with them now. The first rep claims its an update that is needed on my phone and transferred me to escalations which i am currently on hold with, allegedly they are going to "push" an update through for my phone. i have a feeling that when someone finally comes to the phone they will tell me something different.
  17. Thread Author  Thread Author    #17  

    Default

    ok they recommended that i do a factory reset. There is no update available like i thought.
  18. #18  

    Default

    Quote Originally Posted by jerseykat1 View Post
    i dont think this is the problem. because i can get email using the imap email app consistantly and reliably, which means the data is coming through. only problem is that it is not push email. so it only pulls email every 5 minutes or so.
    The reason your IMAP comes thru is because it is fetch e-mail. And the device takes the 3g connect out of dormat when checking for e-mail. The push e-mail can not make a connection to the phone until the 3g connection is active again.
  19. Thread Author  Thread Author    #19  

    Default

    Quote Originally Posted by Ajbent86 View Post
    The reason your IMAP comes thru is because it is fetch e-mail. And the device takes the 3g connect out of dormat when checking for e-mail. The push e-mail can not make a connection to the phone until the 3g connection is active again.
    so the problem still points to the gmail app, it should trigger the connection to come out of dormant or sleep (4g must be the same issue) if the email app is smart enough to wake the phone up to fetch my emails shouldn't the gmail app be smart enough to not allow a total lapse in connection?

    Sent from my SPH-D700 using Tapatalk
  20. #20  

    Default

    My gmail used to push to my evo without a problem, now its spotty. I'm not happy about this.
  21. #21  

    Default

    Any updates on this? Mine has recently started doing this as well.
  22. #22  
    icenija's Avatar

    Posts
    154 Posts
    Global Posts
    155 Global Posts

    Default

    Well I had problems with the stock email app on the epic and it drove me nuts but I use Seven now and haven't had any issues. Push works for my hotmail, att, and yahoo emails and usually get the mail before I get it on my pc. Works very well.

Posting Permissions

B