1. xubean's Avatar
    Hey guys,
    I tried to search for this issue in the forums, but didn't find a solution. I see that some of you have seen this as well, but a restart usually fixed it.
    When i turn on my phone, the four capacitive screens are lit up, but the screen itself is blank/dark/off. I've done a warm reset (volume up + power + camera buttons) and hard reset (taking the battery off and putting it back on again) multiple times and still the same issue. this happened randomly after i pressed the home button, though my home button is set up to run one of the app switching applications instead of going directly home (i can't remember the name of the app, and since my phone won't turn on, i can't see what app it was). this has happened to me randomly a couple of times before, but this is the first time a reset didn't fix it. Any help?
    Also, i have pattern lock enabled, which may or may not make things easier, just thought i'd put it out there.

    I'm thinking of going to the sprint store later today, but was hoping to see if anyone could help me out here!

    Thanks in advance guys.
    11-02-2010 01:17 PM
  2. ragnarokx's Avatar
    If it won't boot you can do a factory reset, but you will lose all your data/apps. While the phone is off, hold vol down + camera + power buttons, then do a factory reset/wipe. Hopefully that will save you a trip to the Sprint store.
    11-02-2010 05:30 PM
  3. SFWD1934's Avatar
    I just had to wipe mine yesterday. It did he exact same thing. I was so mad. I would love to know why that happened.

    Jason
    11-02-2010 06:19 PM
  4. funeralplanner's Avatar
    This same thing happened to me today. I usually leave bluetooth off, so as I turned it on it gave me the black screen and I had to pull the battery.
    11-02-2010 06:58 PM
  5. xubean's Avatar
    So I went to the Sprint store, they initially thought that they just had to change the screen, apparently they've seen similar cases like this before. So they told me to come back in a couple of hours, because the tech guys had other phones to work on before mine. When i went back they told me that it wasn't the screen but a bad application, just what i thought. so they had to wipe it! i could've done it at home, but since i was there, i asked them to do it. I was pretty sad, coz i lost all my text messages, and thanks to no froyo yet, i had to reinstall all my apps again! but anyway, it's working now... so guys stay away from this app "Visual Task Switcher". it was useful coz i could see all the apps that were running; coming from WebOS, I'm just so used to that feature, but turns out, it's really bad for your phone! very sad!
    11-03-2010 10:33 AM
  6. Jung Sun Kim's Avatar
    If it won't boot you can do a factory reset, but you will lose all your data/apps. While the phone is off, hold vol down + camera + power buttons, then do a factory reset/wipe. Hopefully that will save you a trip to the Sprint store.
    OMG THANK YOU SOO MUCH!!!!! I dropped my phone in the water for a second and the screen never turned on but when I tried this it worked!!! Thank you soo much)))!!!!
    04-19-2014 02:35 PM
  7. rashmi809's Avatar
    how to remove that application ???
    07-22-2014 07:55 AM
  8. witeopinie's Avatar
    It did he exact same thing. I was so mad. I would love to know why that happened.
    08-15-2014 07:45 AM
LINK TO POST COPIED TO CLIPBOARD