Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  

    Default Lock pattern randomly disabled

    I've noticed that my lock pattern is randomly disabled and I can't figure out why. Rather than requiring the pattern to unlock the phone the screen just turns on. It doesn't even show the drag to unlock dialog.

    I've seen this happen with the drag to unlock as well. I don't have my phone rooted and it happens when plugged in or not. Any ideas?

    Sent from my SPH-D700 using Tapatalk
  2. #2  

    Default

    What is your screen timeout set to? Are you running a custom ROM or stock Eclair (or DK28 FroYo)?

    There's a lock-delay that kicks in when your screen turns off by itself; if you don't hit the power button, and let the backlight time out, it kicks off a counter (I think it's about 5-10 seconds) that allows the screen to be turned back on without the device needing to be unlocked.

    If you can let it sit for longer than 10 seconds without touching the power button and still turn it back on, it may be an application running in the background that's preventing the auto-lock from kicking in after the timeout.
    I am not an atomic playboy. - Admiral W.P. Blandy
  3. #3  

    Default

    Also, I'm on DK28 now, and it appears the auto-lock timeout has been dropped to about 3 seconds. I am rooted but am running stock DK28, so I don't know if this applies to non-rooted phones or ROMs.

    There IS a bug I've seen in which sometimes the home screen will show up for a second or two before the lock screen appears, but I've never been able to power it back on without unlocking it first.
    I am not an atomic playboy. - Admiral W.P. Blandy
  4. #4  
    Smitty_82's Avatar
    Android Addict

    Posts
    1,596 Posts
    Global Posts
    1,597 Global Posts
    ROM
    ICS / Stock

    Default

    Def check your settings for the lock time. At least the first place I would look. By default it is usually set for 20 minutes if I remember right.
  5. #5  

    Default

    Quote Originally Posted by Smitty_82 View Post
    Def check your settings for the lock time. At least the first place I would look. By default it is usually set for 20 minutes if I remember right.
    Stock Eclair, fresh off-the-shelf screen settings default to 1 minute for screen timeout and 30 seconds for keyboard; I don't know how to check or change the auto-lock timeout.
    I am not an atomic playboy. - Admiral W.P. Blandy
  6. #6  
    Smitty_82's Avatar
    Android Addict

    Posts
    1,596 Posts
    Global Posts
    1,597 Global Posts
    ROM
    ICS / Stock

    Default

    Go to settings>Location & Security>Security Lock Timer
  7. Thread Author  Thread Author    #7  

    Default

    I'm still running stock Eclair. The problem just happened when I got home and this is what I was doing.

    I was on a call using the speakerphone. I decided to turn on WiFi so I can send a text. After turning WiFi on I plugged it up using the OEM charger and hung up the call. When I hit the power button to turn the screen off I turned it back on a few mins later but no lock screen.

    I adjusted the screen timeout to 15 secs and let it sit for about a minute and still no lock screen. I even changed the lock pattern and am still experiencing the problem.

    The strangest thing, though, is I can do anything on the phone except hitting the home key as that causes the phone to display the lock screen. Doesn't matter, though, because all I have to do is turn the screen off and on and I'm back to the desktop.

    The only way to fix this seems to be powering the phone off.

    Sent from my SPH-D700
  8. Thread Author  Thread Author    #8  

    Default

    Additional info. I hit the home key to cause the lock screen to show and entered my unlock pattern. I then turned the screen off and back on and the lock screen is displaying as it should.

    Peculiar...

    Sent from my SPH-D700
  9. #9  
    Smitty_82's Avatar
    Android Addict

    Posts
    1,596 Posts
    Global Posts
    1,597 Global Posts
    ROM
    ICS / Stock

    Default

    Any apps that you downloaded that might conflict?
  10. #10  

    Default

    Quote Originally Posted by Smitty_82 View Post
    Go to settings>Location & Security>Security Lock Timer
    Okay, this is missing from DK28 then, or else it's put somewhere that's not intuitive to find. I JUST got it installed (with GPS working!) today, and I never bothered to mess with the security lock settings in Eclair. Unless they're now being managed by my company's Exchange server and I can't change them, but then it would be grayed out and not missing completely, I imagine.
    I am not an atomic playboy. - Admiral W.P. Blandy
  11. #11  

    Default

    Quote Originally Posted by IamDatDude View Post
    The strangest thing, though, is I can do anything on the phone except hitting the home key as that causes the phone to display the lock screen. Doesn't matter, though, because all I have to do is turn the screen off and on and I'm back to the desktop.
    That has happened to me in stock Eclair before. But, the effects never lasted; if I had an application running in the background, sometimes it would turn on to the application instead of the lock screen, and if I hit Home or Back it would lock. But once the application was closed either sanely or forced out of memory, everything returned to normal. I never had to resort to rebooting. I think that was a bug in Eclair, maybe it's just presenting itself in a more unusual way on your phone because of an application you have running in the background and are unaware of.
    I am not an atomic playboy. - Admiral W.P. Blandy
  12. Thread Author  Thread Author    #12  

    Default

    Quote Originally Posted by Smitty_82 View Post
    Any apps that you downloaded that might conflict?
    Not that I'm aware of. I use Beautiful Widgets, which has a toggle available for the lock pattern, but all of my apps are market apps.

    I'm wondering if it has something to do with the phone app as fat as using the speakerphone. I'll try some tests to see if I can recreate it.

    Sent from my SPH-D700
  13. #13  
    hevenz1's Avatar

    Posts
    54 Posts
    Global Posts
    55 Global Posts

    Default

    Quote Originally Posted by Smitty_82 View Post
    Go to settings>Location & Security>Security Lock Timer
    Um I'm not finding this in 2.1 at all.....
  14. #14  
    Skunkape60's Avatar
    Retired Ambassador

    Posts
    4,518 Posts

    Default

    Quote Originally Posted by hevenz View Post
    Um I'm not finding this in 2.1 at all.....
    And you won't...

Posting Permissions

B