1. whippingboy's Avatar
    My wife and I both have the Epic. for the past week- she's had ZERO 3g service. She's never been rooted- and prior to a week ago- her phone's worked like a champ. The 3g data logo never appears. I even downloaded DC Switch to try to toggle the 3g data back on- but it returns an error message insinuating I may have airplane mode active (I do not) 4g works fine- when she has 4g signal.

    My epic in the same room works fine on 3g- any ideas?

    If I have to go to sprint I'm going to go insane. I no longer can tolerate their lies and incompetence. No offense to any employees here-I've just been screwed over way too many times in the past few months.

    My gut is to root her phone, but I haven't been able to convince her yet...so I'm stuck trying to make this work without doing so.
    01-21-2011 04:38 PM
  2. eerongal's Avatar
    my stab-in-the-dark guess would be hardware malfunction with the 3G radio.

    You may wanna try a factory reset, just to make sure it isn't something software related, but if that doesnt work, its likely a hardware issue.
    01-21-2011 04:50 PM
  3. RUSH's Avatar
    ...Before you do any reset - try this: (1) Update data profile. Menu - settings - system updates - data profile. (2) Reboot the device... hold down the power and volume down rocker until bright screen comes on. Follow steps to perform reboot. If problem persists... then you could consider resetting the phone.

    Good luck.
    01-21-2011 05:01 PM
  4. whippingboy's Avatar
    I'm trying to update the profile on MY rooted phone as I've had to reflash Truly Epic now... 3g data is miserably slow and 4g doesn't work on the market... yet when I try to update the profile or PRL it turns off the 3g data logo- and returns an error message - what the heck?
    01-21-2011 06:49 PM
  5. dt126's Avatar
    Your situation sounds very similar to mine (but wife's phone and mine are reversed). I've had a persistant issue with my 3G radio ceasing to work since launch day in August. The tip above is probably a good one, but I'm still baffled by what's going on to me. I've had (2) phones and both had the same problem. It's very odd. When the 3G is not working, I can still use the 4G (when it finds a signal) and Wifi, but the 3G will not come back on by itself. It's rediculous to expect you to reset your entire phone to fix a radio issue and (since I've had two with this problem) I think it's not hardware related.

    To get mine working again, I take the following steps.

    1) Try Doing a PRL Update: About Phone-System Updates-Update PRL. This seems to fix the problem for me maybe 1 in every 6 times it happens. However, the "update PRL" task fails with a "no network" error about 9 out of 10 times, so it's a matter of retry, retry, retry.

    2) The only thing Sprint Tech Support suggested that did work, was to get into the Data Programming menu, ##3282# from the dialer, select restore, then enter my MSL number. Even with this step, it still has to Update PRL and if that fails, it's try again.

    I can literally waste 60-90 minutes just getting my stupid 3G working again, I've called Sprint at least 6 times and no one has any idea why this is happening.
    01-21-2011 09:30 PM
LINK TO POST COPIED TO CLIPBOARD