Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
  1. Thread Author  Thread Author    #1  

    Default text messaging deletes area code

    it only happens with one person. For some reason when he texts me it is fine but when i reply the area code is gone. I can delete the contact, his text, emails, everything and anything yet the area code is gone and i have to manually add it to text back. which is annoying b/c i talk to this person a lot. Thanks
  2. #2  
    dominick's Avatar

    Posts
    53 Posts
    ROM
    Stock 4.4

    Default

    how is the number saved in your contacts? if it's wihout area code, it may pull from contacts

    cheers/dom
  3. #3  

    Default

    I'm having the same issue. I have deleted and re-entered the contact and it works for a while then it will drop the area code. It's frustrating and something I am hating with this droid phone. I swithed from the Palm Pre because I cracked the screen and the insurance couldn't replace it form (offered me a downgraded phone). Ugggggggggg
  4. #4  

    Default Texting Deletes Area Code

    Quote Originally Posted by kgbcapthowdy View Post
    it only happens with one person. For some reason when he texts me it is fine but when i reply the area code is gone. I can delete the contact, his text, emails, everything and anything yet the area code is gone and i have to manually add it to text back. which is annoying b/c i talk to this person a lot. Thanks
    I have the same issue. It only applies to one contact. I have deleted and re-added the contact repeatedly but it still deletes the area code...I have looked through all my contact list and can't find anywhere that the number is in there without the area code...

    Anyone have an idea what the problem is?

    Thanks...
  5. #5  
    Kikoshi's Avatar

    Posts
    252 Posts
    ROM
    AC!

    Default

    Quote Originally Posted by tigrbob View Post
    I have the same issue. It only applies to one contact. I have deleted and re-added the contact repeatedly but it still deletes the area code...I have looked through all my contact list and can't find anywhere that the number is in there without the area code...

    Anyone have an idea what the problem is?

    Thanks...
    What SMS program are you using? the Default?
  6. #6  

    Default

    Yes running stock SMS.

    Husband runs stock Pre+ on Verizon.

    I've removed the facebook import contacts function. Deleted and re-entered contact half a dozen times.

    Help!!!!!!!!!!!!!!!!!!!!
  7. #7  

    Default

    I have more information. It seems to only revert back when his texts are incoming as the first in the conversation. If I start it out it seems to be ok.

    Gosh this is frustrating and I can't believe that no one else has had this issue or has a solution.
  8. #8  

    Default

    Any Answer? I have the same issue on my My Touch. I am texting the hell out of a 626 and not the 646 number I want to text
  9. #9  

    Default

    I'm a tech at a Sprint store and I run across this problem about once every 2 months or so. I have tried everything from. Hard reset, Deprogram reprogram, Data refresh, msid and nai change, blocking sms, removing sms feature then reactivating, even cancelling and reactivating the line... and nothing. I just wind up replacing them til a software patch is pushed.
  10. #10  

    Default

    are you synced to facebook or something else? The person may have their number saved as only a 7 digit on there, and the sync may be overwriting it. Just a thought
    Sprint Galaxy Nexus [stock for now]
    BB 8130, iPhone 4 8g, iPhone 3g 16gb, Toshiba e800, Palm Tungsten T
    [retired]Epic 4g, BB8330, BB 9670, Samsung Intercept, Katana DLX, Sanyo 8400, HTC Wizard, MPX220, and many others...
  11. #11  

    Unhappy known issue

    I spent over an hour trying different work-arounds with sprint rep yesterday. This is a known issue that they are hoping will be fixed with next software upgrade. None of the work-arounds did the trick so we had to do a hard reset on the phone. Problem gone for know but I was warned that it may come back. They had no idea when Samsung will release next software upgrade.
  12. #12  

    Default

    This is a known issue with the epic 4g. I spent over an hour trying different work-arounds with a Sprint rep yesterday. None worked and we had to do a hard reset on the phone. The problem is gone for now but I was warned that it may come back. Sprint and Samsung are working on the problem and hope to have it fixed with next software update. No idea when that will be released.
  13. #13  

    Default Re: text messaging deletes area code

    from samsungepicforum (can't post a link since this is my first post):

    Code drops off for messaging - Samsung Epic 4G

    Here is the fix. I have tested it and it works.

    First the issue is you once texted someone with a 7 digit number. Most likely becuase you stored them in your contacts that way. Even if you update the contact info it will always drop the area code from all future messages to that person. Everyone that was stored correctly will message correctly. Deleting the contact and reinstalling them will not work. Importing the contact again will not work. Deleting the message thread and starting a new thread will not work.

    Here is what you need to do.

    Clear data in the Dialer and Dialer storage.... under manage Applications> All.

    That is Settings - Applications - Choose All to view All choices - then find Dialer and clear the Data. Repeat this for the Dialer Storage as well.

    I personally also deleted the message thread first from the text message window and my log history which is a menu item from your call screen.

    This process will not delete all your contacts.

    The only other fix to this problem is to reset back to factory defaults. I don't suggest this at all.

    Good to go afterwards!...
  14. #14  

    Default Re: text messaging deletes area code

    The problem is with how the contact number is saved. Sometimes with transfers, reformats, and system updates, the phone number formats become incompatible.
    Go to the contact of the person you are having trouble with and delete any special characters or punctuations, especially brackets, and save it again. Some special characters may seem to return after you save, but that is fine. Go to your messenger and press the new message button. Dont continue the old thread, create a new one.
    Good luck!
  15. #15  

    Default Re: text messaging deletes area code

    Here is a solution I found that works for me, to prevent the stock Android messaging app from deleting the area code in a 10 digit phone when creating a new text message.

    In google.com/contacts my cell phone numbers were saved like this +1 (444) 555-1234 changing it to +1 444-555-1234 resolves the issue for me. Removing the (parentheses) worked for me.
  16. #16  

    Default Re: text messaging deletes area code

    I'm declaring jfreon & gates r my heroes.

    I've been having a similar problem recently using a Samsung Intercept on Virgin Mobile. There was some system conversion within the last month where I was affected. I started to receive an error message that a message could not be sent as the area code was omitted or I used an invalid short. My wife and a friend are the two people I text the most and I could not get the area code to stick for those contacts, so I had to enter the 10 digit number manually. (They are also using Virgin Mobile but apparently have not yet been affected by the system conversion.) That was especially annoying if I needed to respond to their response as the area code still did not "stick" when they would respond.

    I tried the editing of another contact where I did not have the problem and that did not fix it (worth a shot).

    Clearing the Dialer and Dialer storage got me half way there. After that, when I then tried to create a new text message from the Contacts list on my phone it was filling in a different contact's information. So I then also turned off sync contacts in the contacts settings, edited how the telephone numbers appeared in my stored online Google contacts (I was removing dashes rather than parentheses, but otherwise same premise as gates_r mentioned), and then turned the sync back on. Now, finally, when I click on the Contacts button to text my wife or friend (or use a direct message shortcut), the area code is included. Hooray! I'm now as well off as I was a month ago. Thanks for the new system, Virgin.
  17. #17  

    Default Re: text messaging deletes area code

    Seems the missed calls I get on my call log are in the format of (562) 492-5555 and when I try to text that number, it exports to SMS as 492-5555. Its prob the ( ) that arent trasnfering over to SMS.. how can this be fixed for phone numbers that arent stored in my phone book!?
  18. #18  

    Default Re: text messaging deletes area code

    For me this only occurs when receive a call/text from a phone in same area code where other phone used 7digit number as my contact info.

    Virgin support says this is a historic thing as networks switch from 7digit to 10digit for all calling (including local).
    They say you need to ask sender to change your contact info to 10digit on their phone, otherwise you'll keep receiving them as 7digit reply number that messes up Android that wants to be 10digit only.

    Interim solution as networks migrate to 10digit would be if Android allowed specifying a default area code to use on 7digit texts, similar to the existing default area code that can be set for 7digit voice calls.
    See: Green Handset Icon --> Menu button --> Call Settings --> Additional settings --> Auto Area Code --> Provide your local area code.
  19. #19  

    Default Re: text messaging deletes area code

    Setting the default area code for voice calls seems to have also fixed issue I had with texts from person with older phone and 7digit numbers for sms replies.

    Voice Call Green Handset Icon --> Menu button --> Call Settings --> Additional settings --> Auto Area Code --> Provide your local area code.

Posting Permissions