Page 1 of 2 12 LastLast
Results 1 to 25 of 31
  1. Thread Author  Thread Author    #1  
    DirkBelig's Avatar

    Posts
    1,267 Posts
    Global Posts
    1,412 Global Posts
    ROM
    Stock

    Default Any Way To Prevent Music Player Autostarting With Bluetooth?

    This was a problem with my EVO, especially with WinAmp and Listen having no option to ignore BT headset controls, so they'd automatically launch and start playing whenever my Sync system was detected. (I DESPISE any app which presumes it knows what's best for me and just does what it wants to be "helpful" w/o given a means to turn it off.)

    Well, I wanted to listen to some podcasts with Pocket Casts and the moment I switched to Bluetooth, it started the Music app and playing ringtones I'd copied over. I can't see anywhere in the app or in the phone's BT settings to disable it. I Googled and found a TWO-YEARS RUNNING thread on the Android Bug Tracking site complaining about this issue on just about every phone. Someone suggested using an app called Headset Blocker, but it appears that when I receive a phone call, it doesn't stop Pocket Casts, so I've got to hunt around for where I'd left off.

    If I wanted my hardware and software to boss how I use my phone around, I would've bought an Apple product. Any ideas on how to stop this. I'm not quite ready to root yet. Thanks.
    "The Nexus 5 is such a big black slab of power that if you dropped it down in the middle of a pack of monkeys, they'd start using weapons." - Dirk Belligerent.
    Devices: 32GB Nexus 5, 16GB Nexus 7 (2013), 16GB Nexus 7, 16GB Nexus 4, ASUS Transformer TF101, Kindle Fire, HP TouchPad (CM7), Samsung Galaxy S II Epic 4G Touch Long Name Phone, HTC EVO 4G, Palm Pre, 64GB 1st gen iPad WiFi
  2. #2  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    +1 for this question. Looking for the answer to this too. Whenever I connect my A2DP headset to epic, default music player fires up and starts playing. Really hate having to go to task manager every time and exit it.
  3. #3  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I ran into the same problem when syncing with a Bluetooth car once (rental, mine doesn't have it) and it would start my music player every time I would end a call. Very annoying, hopefully ICS will fix this finally.
  4. #4  
    rlanza1054's Avatar
    Samsung - SPH-D710

    Posts
    265 Posts
    Global Posts
    2,089 Global Posts

    Default

    Ok this is coming from a, newbie, do check it out first.

    I found 2 settings, one in Podcast under settings. There is a check off box labeled 'respond to headset'.

    Then there is a setting in the phones settings under 'Voice Input & Output' go to 'Voice Recognition settings' then there are 2 settings to try. One is 'Listen over Bluetooth' the next which is below that called ' Auto Start Listening'.

    Also look under the text to speech settings.

    Rob

    Sent from my SPH-D710 using Tapatalk
    [SIZE="2"]Robert L Astoria Queens, N.Y.C

    - Samsung Galaxy S II Epic 4G Touch! (SPH-D7110)
    - Asus TF300T
    - Nexus 7
    - Smartstick
    - MK808B

    - Previously WebOS Palm Pre (Sprint)
  5. #5  
    ZATZAi's Avatar

    Posts
    9 Posts
    Global Posts
    32 Global Posts

    Default

    I have the same problem with PlayerPro, except it has an option to NOT start auto playing when a BT headset is connected. I have ot set to off but it still starts playing anyway. I am still messing with the settings to see if I can preevent this. However I see a lot of complaining about this problem on the official SyncMyRide forums about this, even with the latest Sync update. Problems not juat with Androids but iPhones as well...

    It worked fine on my old Pre- but then on WebOS you had to be actively using the music app for BT commands to do anything. With Android and iOS it seems, it takes commands whether the music app is running or not, launching the app as needed.

    I still have to test it with my Sony BT headphones but I am beginning to fear it may be a problem not with the phone but with Sync itself. Specifically that Sync is connecting to the phone automatically, like it's supposed to, but then also sending a "play" command after connecting.

    I still plan to do more testing though, but if anyone figures it out please say so...
  6. #6  
    wburbage's Avatar

    Posts
    75 Posts
    Global Posts
    76 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I'm having the same problem but it's only recently started to do that. A couple thoughts... in Sync there's a setting for autoplay. I don't recall where it is exactly but I know it's there somewhere. The second one is rooting the phone and uninstalling the preinstalled music app. I do like that one since it has a lockscreen widget but I'd be willing to give that up and not deal with the bluetooth issue.
  7. #7  
    louie2701's Avatar

    Posts
    37 Posts
    Global Posts
    76 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I have PowerAmp and it has the option to not autostart when bluetooth is connected.
  8. #8  
    wburbage's Avatar

    Posts
    75 Posts
    Global Posts
    76 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Quote Originally Posted by wburbage View Post
    I'm having the same problem but it's only recently started to do that. A couple thoughts... in Sync there's a setting for autoplay. I don't recall where it is exactly but I know it's there somewhere. The second one is rooting the phone and uninstalling the preinstalled music app. I do like that one since it has a lockscreen widget but I'd be willing to give that up and not deal with the bluetooth issue.
    I turned off the Autoplay feature in sync and it still automatically starts the Music app. If there's ever a reason to root my phone this may be it.
  9. #9  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    This is a pain in the *** with my Ford Focus Sync system. I'm getting sick and tired of getting out of the car and having my phone start playing music, then only to have to kill the player because there is no stop button, because it doesn't think you ever hit play.
  10. #10  
    wotan's Avatar

    Posts
    14 Posts
    Global Posts
    71 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I think this is a combination android and sync issue.

    I use a 3rd party bluetooth adapter in my car and it does not autoplay music when it connects.

    In fact, I use tasker to make it autostart playing a BeyondPod feed when it connects and it works great. Except... As soon as I push the play/pause button on my bluetooth controls it stops the podcast and starts playing music (whether the music app is open or not). VERY annoying!! Maybe if we just remove the music app and add a 3rd party one it will solve the problem. Is it possible to uninstall this?
  11. #11  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Not sure if it's possible to remove or not. I may have to try that. I have noticed that since my ipod has been connected to sync, it is no longer searching for bluetooth audio and auto connecting and turning on the music on phone. I guess until my ipod dies, I'm not all that concerned.
  12. #12  
    wburbage's Avatar

    Posts
    75 Posts
    Global Posts
    76 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Has anyone figured this out? Not only is this happening when I start the car or press the control buttons but now I notice it happening when I hit the button to end calls. It was originally happening with the stock Sammy music app but now it's also happening with Google Music, which I actually use.

    Aside from Tasker are there any other apps that will limit what apps can use bluetooth? That way I can select Doggcatcher and Google Music. Oh wait, Google music is one of the apps that pops up when I don't want it. THIS IS SO ANNOYING!
  13. #13  
    Meltedwire's Avatar

    Posts
    6 Posts
    Global Posts
    10 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Yes, this happens all the time on both my Nexus S 4G (2.3.7), and my Transformer (3.2.1). I use a Plantronics Voyager Pro+, a Backbeat and a Moto S305. So this occurs on Gingerbread's latest, and Honeycomb's latest, Asus, and Samsung, with three different headsets. It is the worst with the Pro+ because it supports 2 devices. Does anyone know how to at least uninstall the music app?
  14. #14  
    dj2big's Avatar

    Posts
    207 Posts
    Global Posts
    570 Global Posts

    Default

    It's a very bad glitch I have as well

    Sent from my SPH-D710 using Tapatalk
    Juan Too Big Perez
    DJ2BIG.COM
  15. #15  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Found this on another thread:


    1. Go to Settings -> Wireless & Networks -> Bluetooth Settings
    2. Hold your finger over the bluetooth device that's causing the issue for a couple of seconds
    3. Hit options in the pop-up menu
    4. De-select the Media checkbox.
  16. Thread Author  Thread Author    #16  
    DirkBelig's Avatar

    Posts
    1,267 Posts
    Global Posts
    1,412 Global Posts
    ROM
    Stock

    Default

    They must've added that with ICS. Nice!
    "The Nexus 5 is such a big black slab of power that if you dropped it down in the middle of a pack of monkeys, they'd start using weapons." - Dirk Belligerent.
    Devices: 32GB Nexus 5, 16GB Nexus 7 (2013), 16GB Nexus 7, 16GB Nexus 4, ASUS Transformer TF101, Kindle Fire, HP TouchPad (CM7), Samsung Galaxy S II Epic 4G Touch Long Name Phone, HTC EVO 4G, Palm Pre, 64GB 1st gen iPad WiFi
  17. #17  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Would turning off media in order to prevent music autoplay also turn off audiobooks? I don't want autoplay anything but want to listen to books. My current routine is turn on bt listening, wait for music to start, pause it, open audible, tap play for current book. Inevitably the listening volume for books in way louder than music so BLAST of autoplay music, always the same song -- I have to manually forward the selection just to break up the monotony of the audio assault!
  18. #18  
    mrtim63's Avatar

    Posts
    3 Posts
    ROM
    2.6.32.9-perf

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Quote Originally Posted by Lummox_ICT View Post
    Found this on another thread:


    1. Go to Settings -> Wireless & Networks -> Bluetooth Settings
    2. Hold your finger over the bluetooth device that's causing the issue for a couple of seconds
    3. Hit options in the pop-up menu
    4. De-select the Media checkbox.
    That's great if you no longer want to listen to other apps like Audible, iHeartRadio, ect. I want to use media on bluetooth just not everytime I enter and exit my car. And I almost never want the stock music player starting up.
  19. #19  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Ditto here! I use BeyondPod to listen to podcasts and NEVER want it to automatically start playing music (least of all when I hit the button to stop the podcast)

    I currently have a Galaxy S3 and just got a Motorola BT speaker for the car and it works great except for this (stupid, imo) problem
  20. #20  
    marcm's Avatar

    Posts
    8 Posts
    Global Posts
    13 Global Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Add me to this list. I have a Galaxy S3 and it auto starts my music player every time I start my truck (2013 Tacoma). Very annoying. Also, none of the info data from the podcast players (e.g. Doggcatcher, Pocket Casts) show up on my truck's audio display. While listening to a podcast, it either shows "No data" or it will show song from Play Music.
  21. #21  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I have the same problem with Galaxy Note.

    I notice that with bluetooth handsfree that i use. The handsfree connects to phone for 2 services: phone and a2dp (audio).
    My car player MVH-350BT connects also to my phone and uses the two services (phone&audio).
    But only the car player autostarts the default player resuming the music from where it was interrupted last time. So there are 2 device connecting to the sane function (not in the sane time) and that behave differently. I'm thinking to study carrefully the manual of the car player to see it it has the option not no autoplay...
  22. #22  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Is there any fix for this? This thread is quite old, and it seems nothing has happened on this front, and Google should be aware. right...?
    For me, this problem happens on my phone every time I connect my bluetooth headset. It's not that annoying for me, because when i connect my headset, it's because I'm going to listen to music. Can really see this being a big problem for car users tho...
    Hopeful for a fix, or some suggestions!
  23. #23  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    No fix for me and my Evo4G. Really annoying for car users. I'll occasionally listen to music off my phone in my car, but typically the radio is good. My Palm Pre did this too, and it worked perfectly because when I wasn't using the music app I would flick it away (yes that easy to close an app) and then it was actually gone. If I had the app up, it would start when I got in the car and stop when I got out. But with Android, the app is always running and always starts when I get in the car. I don't hear it (not tuned to Bluetooth), but its draining system resources and my patience when I need to open the app and stop it.

    Moral of the story is, Android needs to work on multitasking. Yes, sometimes I want an app open in the background. But not always, and I should be able to easily end it when I don't want it.
  24. #24  
    Yirg's Avatar

    Posts
    1 Posts

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    Quote Originally Posted by Devilsbane View Post
    Moral of the story is, Android needs to work on multitasking. Yes, sometimes I want an app open in the background. But not always, and I should be able to easily end it when I don't want it.
    I don't believe this is an issue with Android, but rather one with Ford SYNC (and possibly other similar systems) voluntarily sending a "Play" message to the phone without me asking for it.

    I'd be very happy to hear about a solution, even one which involves Tasker. So far nothing I've tried seem to work.
  25. #25  

    Default Re: Any Way To Prevent Music Player Autostarting With Bluetooth?

    I have the same problem with the Galaxy S3 and 2012 Hyundai Sonata. Once the BT is connected, Google Play Music autostarts. I have clear the default and cache. It still comes on automatically although no music is playing because I clear the cache. Any fix for this??? It's very annoying.
Page 1 of 2 12 LastLast

Posting Permissions

B