1. stephanie85's Avatar
    What settings all need to be turned on for gmail to push through the stock / native gmail app ...I am not sure but I thought I could remember my old epic 4g was able to push gmail without background data checked and without auto sync checked ...ofcourse I always had either a wifi connection or 3g connection on.
    10-12-2011 11:12 AM
  2. graffix31's Avatar
    i just noticed that mine doesnt seem to be pushing anymore. anyone else getting this now?
    10-12-2011 06:01 PM
  3. tdTSGordon's Avatar
    Same problem. I've had mine since launch and every 2 or 3 days after a reset I no longer receive e-mail updates. I reset and i'm good to go again for a couple days but i'm trying to figure out if I need to do a trade in or if this is just a bug that hasn't been squashed yet.
    10-16-2011 01:07 AM
  4. JDAustin's Avatar
    Same here....
    10-16-2011 01:37 AM
  5. Night Train's Avatar
    Cold comfort to realize that I'm not the only one experiencing this inconvenience.

    I found that once I reboot the phone, the emails do get sent. So, there's your answer. Supposedly the greatest phone on the market today and you have to reboot to get it to send your email. I'm really hoping that there is an update being prepared right now that solves this irritating problem.
    10-16-2011 02:27 AM
  6. Rockser2g#AC's Avatar
    I had the same problem. Gmail wouldn't push, and things like the weather widget wouldn't update. It had been going on since I got the phone on launch day. I finally broke down last Monday and did a hard reset. It has completely fixed the problem. It's a pain in the a@#, but maybe it will work for you too.
    10-16-2011 09:34 AM
  7. Night Train's Avatar
    I finally broke down last Monday and did a hard reset. It has completely fixed the problem. It's a pain in the a@#, but maybe it will work for you too.
    You mean a factory reset as in all of my info/apps/ everything wiped clean?

    Is it still working for you? Are your emails all going out now? How long has it been?
    10-16-2011 02:10 PM
  8. Rockser2g#AC's Avatar
    You mean a factory reset as in all of my info/apps/ everything wiped clean?

    Is it still working for you? Are your emails all going out now? How long has it been?

    Yeah, that's the one. It is annoying to lose your apps text messages, and what not. But it's been almost a week and I haven't had a problem. It only took about a half hour to restore all my apps. All emails go out and sync, and everything updates regularly. Good luck, Hope this helps.
    10-16-2011 03:00 PM
  9. BRIVERS73's Avatar
    Try clearing the data in the Gmail app via "manage applications" instead of a factory reset. You will have redo all of your Gmail settings after doing so, however.
    10-16-2011 04:44 PM
  10. tdTSGordon's Avatar
    Just cleared all Gmail data. Hopefully this works, i'll give an update in a few days after which it typically would go kaput. Fingers crossed.
    10-17-2011 07:57 PM
  11. tdTSGordon's Avatar
    It took a couple more days but the push updates stopped coming today, Looks like flashing to stock is the next step. Anybody else find any less drastic fixes for this yet? Or anyone flash but still have this problem after a few days?
    10-22-2011 11:47 PM
LINK TO POST COPIED TO CLIPBOARD