12-27-2011 06:29 AM
27 12
tools
  1. DuStU's Avatar
    I have tried everything from resetting the phone to reinstalling maps. Sprint even sent me a new phone. I can't freaking get a lock anymore even with full signal just a big circle and in navigation is says "Searchign for GPS....". Anyway to fix this. Please help
    12-15-2011 07:03 PM
  2. BMIC50's Avatar
    If you go into the 'Location and Security, setting, I would try enabling the "Use Wireless Networks" option. I think that helps get a lock on faster.
    Biggnaa20 and ladyc0524 like this.
    12-15-2011 07:46 PM
  3. boxta's Avatar
    I have the same issue, some day it would lock on in seconds, some day (especially when I need it). Would lock on like never. I got gps status application, and it helps when I clear a-gps history, but not always. But definitely frustrating enough that I am starting to not like the phone
    12-15-2011 08:21 PM
  4. DuStU's Avatar
    None of the above works for me. What gives? It used to work perfectly now when I drive the same place it is just searching and searching.... even spent 40 min on the phone with sprint and they had no idea how to fix.
    12-16-2011 12:36 AM
  5. 2ndaccord's Avatar
    Mine does the same thing. I did reset the agps though an app and that helps sometimes buy not always.

    Sent from my SPH-D710 using Tapatalk
    12-16-2011 08:55 AM
  6. bringdownthesky's Avatar
    Have you guys gotten the latest update from Sprint? The one that brings you up to Android 2.3.6 ? I had the same exact issue and it was infuriating. I was about to go into a Sprint store and demand a new phone but the day I got the update, my GPS works marvelously. Lock in 5-6 seconds. And now, when I'm in my apartment, as long as I'm near a window, it will lock on WITHOUT wifi.

    Before, it would never EVER find me when I was indoors. I hope this helps.
    12-17-2011 09:40 PM
  7. 2ndaccord's Avatar
    I haven't tried GPS after i updated. Maybe i should see if it works now.
    Sent from my SPH-D710 using Tapatalk
    12-17-2011 11:27 PM
  8. wynand32's Avatar
    Have you guys gotten the latest update from Sprint? The one that brings you up to Android 2.3.6 ? I had the same exact issue and it was infuriating. I was about to go into a Sprint store and demand a new phone but the day I got the update, my GPS works marvelously. Lock in 5-6 seconds. And now, when I'm in my apartment, as long as I'm near a window, it will lock on WITHOUT wifi.

    Before, it would never EVER find me when I was indoors. I hope this helps.
    Mine's the opposite. Worked perfectly before EK02, so much so that I was in the process of forgiving Samsung for months of frustration with GPS on my Epic 4G. After EK02, however, and it takes forever to lock when it actually will lock, and then this morning it wouldn't lock at all. Rebooting didin't help. Only thing that did was to load up GPS Status and refresh the GPS cache.

    Why Samsung can't make a reliable GPS is beyond me. Truly it is.
    12-18-2011 02:58 PM
  9. Knoidea513's Avatar
    since the update my gps has failed me. .used it for the first time since the update and it couldn find my starting point correctly, had me lost and i was late for a rehearsal.. i tried rebooting and everything
    12-19-2011 06:00 AM
  10. Unibrow's Avatar
    My GPS has been hit or miss but for the most part it locks on immediately. The times where it doesn't is when it requires a restart but generally a restart fixes the issue. One thing I did, and someone in this thread I'm sure already mentioned this, is turn off "use sensor aiding" and since I've done that I've gotten an immediate lock every single time I've used it thus far.
    12-19-2011 06:33 AM
  11. wynand32's Avatar
    My GPS has been hit or miss but for the most part it locks on immediately. The times where it doesn't is when it requires a restart but generally a restart fixes the issue. One thing I did, and someone in this thread I'm sure already mentioned this, is turn off "use sensor aiding" and since I've done that I've gotten an immediate lock every single time I've used it thus far.
    Okay, thanks, I'll give that "use sensor aiding" thing a try. Anybody know exactly what that does? What are we losing by turning it off?
    12-19-2011 11:57 AM
  12. Unibrow's Avatar
    I messed around with mine today and yesterday while going places and was able to get a GPS lock immediately. The only strange thing that happened was while using Google Nav it thought I was on the service road instead of the Expressway which runs adjacent to it. TeleNav was able to get a proper lock, however. I'll continue to test this over the next few days while I go out and about and see if I have a problem and will report back regardless.
    12-19-2011 08:10 PM
  13. Ogre840's Avatar
    Before the update I was getting great GPS signal, now if I'm using Gmaps it wont connect, and Telenav either wont lock on quick, or I have to drive a good distance before it goes from "Too weak" to a connection.
    12-19-2011 09:17 PM
  14. 2ndaccord's Avatar
    I used my GPS and it locked on without a hitch today. Usually i have issues. Maybe the update might have helped.

    Sent from my SPH-D710 using Tapatalk
    12-22-2011 12:38 AM
  15. repinphilly247's Avatar
    Mine's the opposite. Worked perfectly before EK02, so much so that I was in the process of forgiving Samsung for months of frustration with GPS on my Epic 4G. After EK02, however, and it takes forever to lock when it actually will lock, and then this morning it wouldn't lock at all. Rebooting didin't help. Only thing that did was to load up GPS Status and refresh the GPS cache.

    Why Samsung can't make a reliable GPS is beyond me. Truly it is.
    Have the exact same problem. Got it to work great before the update (as long as I wasn't indoors). After the update, the phone sees the satellites (up to 10 of them, using GPS test), but it won't lock onto them. I think part of the problem may be that it's not using wireless networks correctly to get an initial position as my phone often has me not close to where I am but where I was like 20 minutes prior if i moved.

    Extremely frustrating
    12-22-2011 09:16 AM
  16. handsomeprince#AC's Avatar
    LISTEN people...there's no two or more ways to SLICE it...SAMSUNG hardware is KNOWN for having GPS locking ISSUES...the Epic 4G Touch INCLUDED
    12-22-2011 09:41 AM
  17. Slingbox's Avatar
    Weatherbug Elite fixes my ET gps ,I have gps forecast update interval set at 4 hour.
    Its refreshing agps clearing cache so when I start telanav , Gmaps etc solid 7-9 sat lock occurs within seconds
    12-22-2011 01:50 PM
  18. Chuck Shine's Avatar
    After the update, my GPS works great so long as I turn on "Use sensor aiding" under "Location and security" in "Settings."
    12-22-2011 02:55 PM
  19. Slingbox's Avatar
    After the update, my GPS works great so long as I turn on "Use sensor aiding" under "Location and security" in "Settings."
    yeah disabling sensor helps lots but doesn't fix pathetic gps drivers Samsung has on board.
    Your GPS may seem great but if cache isn't cleared your more then likely not getting 7-9 satellite loc a majority of the time
    12-22-2011 03:16 PM
  20. Kikoshi's Avatar
    yeah disabling sensor helps lots but doesn't fix pathetic gps drivers Samsung has on board.
    Your GPS may seem great but if cache isn't cleared your more then likely not getting 7-9 satellite loc a majority of the time
    Disabled or Enabled?

    Only thing i use the GPS Location down to its street Level option but it is sad, that you can't use the phone when there isn't any Data available due to having to clear it's cache to be used. :/, which defeats clearing it,being that it has to be downloaded.
    12-22-2011 05:09 PM
  21. michaeljc70's Avatar
    Okay, thanks, I'll give that "use sensor aiding" thing a try. Anybody know exactly what that does? What are we losing by turning it off?
    It uses the non-gps sensors to figure out where you are. For example, if you enter a tunnel and GPS is lost, it will try to use the compass and gyroscope to figure out where you are by taking the last GPS location and extraopolating using sensor data. If you have an accurate GPS signal, I don't believe it does anything.
    12-23-2011 04:24 PM
  22. handsomeprince#AC's Avatar
    WHAT...THE...HELL!!! The GPS locking on this thing sucks...I keep getting a looping and circling "Waiting for location" message while in the notification bar just see that crosshair symbol looking icon for GPS with a constant blinking dot...but NO LOCK on gps. What gives?? This is so frustrating...is it related to the recent update??
    12-23-2011 07:42 PM
  23. luigidk's Avatar
    I do think it is an issue with the E4GT in general. I sent my original one back - thinking it was faulty due to lack of GPS lock. However my replacement phone behaves pretty much the same way. I am on EL13 but not sure I see an improvement.

    I will run GPS Fix from time to time...

    However - after reading these forums - what seems to help the best is a reboot from time to time...

    Also - have noticed it does better if I use my wifi to help.

    Hopefully some firmware update will help correct this at some point.
    12-23-2011 11:36 PM
  24. michaeljc70's Avatar
    I do think it is an issue with the E4GT in general. I sent my original one back - thinking it was faulty due to lack of GPS lock. However my replacement phone behaves pretty much the same way. I am on EL13 but not sure I see an improvement.

    I will run GPS Fix from time to time...

    However - after reading these forums - what seems to help the best is a reboot from time to time...

    Also - have noticed it does better if I use my wifi to help.

    Hopefully some firmware update will help correct this at some point.
    I have a topic on here...I was in Europe for 12 days and couldn't get a GPS lock once. Without Wifi or carrier service, you are really screwed.
    12-24-2011 09:49 PM
  25. handsomeprince#AC's Avatar
    I do think it is an issue with the E4GT in general. I sent my original one back - thinking it was faulty due to lack of GPS lock. However my replacement phone behaves pretty much the same way. I am on EL13 but not sure I see an improvement.

    I will run GPS Fix from time to time...

    However - after reading these forums - what seems to help the best is a reboot from time to time...

    Also - have noticed it does better if I use my wifi to help.

    Hopefully some firmware update will help correct this at some point.
    I think its safe to say that the GPS locking issue is for real across the board with the majority of these units. For those that say they havent experienced such issues with their device; I'm envious. Another thing ive noticed is that if an 'update PRL' is done...it greatly helps in getting a lock.

    I have a topic on here...I was in Europe for 12 days and couldn't get a GPS lock once. Without Wifi or carrier service, you are really screwed.
    I remember reading you saying that; that sucks. Without GPS working; seeing as how so many of us are dependent on it...it can be an unnerving thing.
    12-25-2011 04:49 PM
27 12
LINK TO POST COPIED TO CLIPBOARD