1. Drummerboy1975's Avatar
    This is getting real old. After I delete emails they pop back up in my inbox a few days later. Its done this once or twice before but stopped. Now its doing it again.
    02-13-2012 05:17 PM
  2. dt81's Avatar
    Me too!!! It pisses me off!!
    02-13-2012 06:34 PM
  3. sonnydays's Avatar
    Me too. I thought that I had it fixed but their back. Nothing like getting an alert for an email every ten to fifteen minutes. Especially for ones that I have already read.
    03-02-2012 10:07 PM
  4. dubfish34's Avatar
    This happens for both deleted and filed emails. Something to do with the syncing out of the inbox. Frustrates me to no end, seeing that I love the stock app.
    03-05-2012 09:10 AM
  5. madkaw's Avatar
    Make sure on the incoming server options you change it to
    When I delete from inbox, the default is Never, so when you delete it off the phone next time it check email it sees it again if this option is not changed.
    03-05-2012 03:25 PM
  6. perelandra's Avatar
    Looks like the "change it to" solution in the previous post was either cut off or deleted by an Admin for some reason? Can you please repost that answer? Also, my phone is somewhat new and after looking around, I cannot find where to access the "incoming server settings."

    Thanks!
    05-15-2012 01:47 PM
  7. tom789's Avatar
    two different mail accounts (2 computers) and when I delete messages (inbox) they go to trash and then I delete these messages from trash and they reappear inm my inbox.
    What is going on >>> I have a ASUS TF tablet stock email program! About ready to send it back. Tried different input & output ports nothing seems to work> I have ICS OS. Answers???
    05-28-2012 12:40 PM
  8. elmapandy's Avatar
    I had this problem. After deleting emails from laptop problem was solved
    02-22-2013 05:45 AM
  9. sonicbluemustang's Avatar
    LOL have yall seen the campaign by microshift caled "Scroogled" Google it
    02-22-2013 05:59 AM
  10. flugeleboneman's Avatar
    email deleted keep returning to tablet
    08-16-2013 05:22 PM
  11. monkeyron's Avatar
    I too have this same problem with my S3 and my Wife's G Note. I never had this happen with my S2. I have left my PC settings to leave read emails or deleted on the server for 5 days. I did this because of a Crash and many important Business emails were lost so now they will delete after 5 days if they are read from my desktop. But the phones I have used in the past never brought back deleted emails from the phone. So far I had not seen a fix posted for this. Maybe a bad update to the email Client? I have 6 Mailboxes on various servers to follow. Gmail is not the issue. Any good ideas?
    08-23-2013 02:11 PM
  12. MysteryMaven's Avatar
    If you go into Settings/General Settings the second option is a check box called Swipe to Archive in conversation list. If you check that box you'll find that a right swipe will move the message to its designated folder. Note this is the case for Gmail on a Google Nexus tablet running Android 4.3. I assume this would work on any Android device but I can't verify that it will.
    08-26-2013 06:49 PM
  13. G Mak's Avatar
    For deleted emails that keep reappearing in your inbox, you should make sure they are archived or deleted permanently on the server. As for read emails that reappear as unread, I.e. showing you a notification of a new email, you simply have to increase your 'number of emails to load' to 'total' in email settins>more settings. Hope this helps!
    09-12-2013 01:16 AM
  14. brass_hat's Avatar
    I made sure they were marked as read before deleting. After that had no returning old e-mails.
    10-16-2013 12:03 PM
  15. dave1216's Avatar
    So I have done some research on this topic and I am amazed that the number one selling android phone has this problem. In reading all posts for about a half hour I have seen no direct solution other that to set the phone setting to delete after deleting from inbox which may prevent the emails from reaching your PC. My wife and I both just got S4s. I have the primary Comcast email account and do not have this problem. She has the secondary and does. I have not read that there is a link between this problem and the primary or secondary accounts. We both have the same settings including the POP server.
    02-19-2014 08:12 PM
  16. Freond's Avatar
    I have the same problem I think the problem is that it works this way.
    1. Your phone has some settings about how many emails to load. I can set it to 25 to 200.
    2. Emails are loaded from a primary server, in this case www dot comcast.dot net. You can log in there to see your emails. Once they are deleted from THERE, they will no longer appear on your phone.
    3. Emails loaded to your PC are generally downloaded and will be permanently stored there, until manually deleted. My primary email client is on my PC. It's set to delete emails from the server when they are cleared out of the deleted folder in Outlook. On my phone, it's set to leave them on the server. So when I delete it from the phone it's still on the server, and can come back when the phone email client resyncs. I don't quite know why it's not smart enough to see them in the phone's deleted folder so that it keeps reloading them. But key thing is they aren't permanently gone until deleted off the server. You should figure out when that happens for you.
    07-15-2014 12:11 AM
  17. Reg Varney's Avatar
    I had the same problem the way I finally got rid of them was going into my ISP( in my case virginmedia ) and deleting every email there and then going to trash and deleting everything there and the same in gmail, there were six that just would not delete, and that sorted it, I hope this helps
    03-23-2015 02:01 AM
  18. Dick Diggler's Avatar
    I am new this posting thing, and also new to the android system. I am becoming not a fan of it. I have read some of the other posts and everyone seems to having the same issue that I am having. I delete emails and within 24 hours they are back in my inbox. I have gone through the settings to find where I could straighten this out and that is about as helpful as a hemorrhoid...like that android system. If there is someone out there that could help me out that would be great.
    05-23-2015 08:12 AM
  19. bl34's Avatar
    I found out that on my new Note 5 and Im sure its the same with other phones, that the email was set up incorrectly by the auto setup. I use an imap server and it was set up as a pop3 email. It also set up different ports and smtp addresses. delete your email account and reset up using manual settings. go to your email provider for the recommended settings.

    open email go to settings and click on the email account you want to remove, click REMOVE.

    then go to email> settings and click add account.

    hope this helps.

    bl34
    09-17-2015 01:09 PM
LINK TO POST COPIED TO CLIPBOARD