1. sayhy2mark33's Avatar
    Hi all. I ride the bus here in the DC area every morning. During the commute, I lose 4g a couple times, which I understand to be normal as I am moving through towers. However, once 4g is lost, it takes quite awhile to reconnect. I will often be in an area where I know there's great 4g coverage and I'll have to turn off 4g and turn it back on for it to connect again. It's like it isn't constantly scanning for a new signal and picking it up as soon as it becomes available; it waits for me to reconnect manually.

    Is this a common theme with these phones, and if it is, is there some type of app or fix that aids in the reconnection of 4g without manual intervention? I still can exchange the phone for another, if this is not common behavior. Thanks all.
    03-20-2012 11:22 AM
  2. joshrocker's Avatar
    Sorry, I don't have an answer for you but I have noticed the same issue. It takes a long time for my phone to connect to 4G after its lost the signal. If I turn 4G off and back on again I can get it to connect right away.
    03-20-2012 01:46 PM
  3. rraman3110's Avatar
    Are you running any custom roms or are you on stock out the box gingerbread?
    03-20-2012 01:58 PM
  4. Sn1per 117's Avatar
    If it was constantly scanning for a new connection that would just eat up battery quickly. If you root I believe you can change the scanning frequency for it.

    Sent from my SPH-D710 using Tapatalk
    03-20-2012 02:13 PM
  5. IAmSixNine's Avatar
    The early 4G phones had issues with constant scanning and depleting the battery. After a lot of complaints the device will go into a hibernation mode and wont re-scan for several minutes, at one point i think it was set to 5 minutes. But that may vary by device.
    So technically theres nothing wrong with the device. ONce it looses signal and cant re-establish right away it goes into a sleep mode then will re-scan at longer intervals to save battery.
    Swithing off and back on will make it scan immediately.

    There are also some threads here and on XDA that tell you how to change the re-scan time for Wimax. You will need your MSL code as well for this.
    03-20-2012 05:03 PM
  6. sayhy2mark33's Avatar
    Still on stock gingerbread. Good info here. Thanks guys.
    03-20-2012 10:04 PM
  7. CuriousNoob's Avatar
    Isn't it because its WIMAX? My friend has same phone, stock, and it disconnects alot too

    Sent from my LG-VM670 using Tapatalk
    03-20-2012 10:20 PM
  8. IAmSixNine's Avatar
    There are several mods you can do to prevent that.
    One of them is to reduce the lower signal strenght at which it disconnects.
    One is to enable faster scan rate once a disconnect happens.

    I have done the mods to my device and i can go half a day with out loosing a 4G connection.
    03-21-2012 03:00 PM
  9. sayhy2mark33's Avatar
    There are several mods you can do to prevent that.
    One of them is to reduce the lower signal strenght at which it disconnects.
    One is to enable faster scan rate once a disconnect happens.

    I have done the mods to my device and i can go half a day with out loosing a 4G connection.
    I couldn't find threads about using a faster scan rate. My phone is not rooted. Do you know where any of those threads are?
    03-21-2012 03:15 PM
  10. IAmSixNine's Avatar
    03-21-2012 04:19 PM
LINK TO POST COPIED TO CLIPBOARD