Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  
    Phenom's Avatar

    Posts
    144 Posts
    Global Posts
    263 Global Posts

    Default Power button stopped working

    The power button on my SGSII E4GT has stopped working all of a sudden. It seems to be some type of software issue, as the button will still turn the phone on, but will not dim the screen, power the phone off, work for screenshots or any other function.

    Does anyone have an idea of what could be the problem, or more importantly, the solution? If all else fails, I'll just wipe out the phone and restore it to factory settings to see if that does the trick. But I'd like to think there are some other troubleshooting methods I can try before getting there.

    Any suggestions?

    Just some further information:

    I've already removed & reinserted the battery
    I run the stock version, but I do have GoLauncher installed.
    No other major customizations
  2. #2  

    Default Re: Power button stopped working

    Hello,

    Just to be clear are you rooted or stock?

    If you are rooted this could be the result of a bug in the ROM even if its a "stock" build custom ROM.

    Otherwise if your stock, un rooted then this is a bit of a mystery... Does it work to end phone calls if you have the option enabled under Accessibility?

    Otherwise if you have exhausted all other possibilities (even uninstalling GoLauncher) then I would try the factory reset and see what happens.
    Paul
    Moderator Team Leader @ Android Central

    I am the Tegra Champ. What this means is that from time to time NVIDIA might send me new products to try out. This will not affect my thoughts, ideas, or opinions about any product that are discussed in the forums. Those are still my own.
  3. Thread Author  Thread Author    #3  
    Phenom's Avatar

    Posts
    144 Posts
    Global Posts
    263 Global Posts

    Default Re: Power button stopped working

    I am not rooted. Just stock. Seems as if I've got it working now. I deleted any apps that we're downloaded within the past week and pulled the battery for 10 minutes. Not sure which one worked but my power button is now fully functional again.
  4. #4  

    Default Re: Power button stopped working

    Is it weird that today this happened to me too? I've been only lightly touching my side button & it turns on or off. When I actually press the button the pop up screen for airplane mode appears. That's weird right? I don't know if while I was sleeping there was an update or not. What should we both do? All I did was take out the battery & it's not as sensitive but it still is.

Posting Permissions