Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 21 of 21
Like Tree1Likes
  • 1 Post By rushter
  1. Thread Author  Thread Author    #1  

    Default Google contacts not syncing

    This is the same problem I've been having for some time now. On two different phones. It always states can't sync with servers try again later. Is there a fix it's really starting to bother me and they can't fix it at sprint. Thanks

    Sent from my SPH-D710 using Android Central Forums
  2. #2  

    Default Re: Google contacts not syncing

    Go into the app and clear data or un install and install again. Go into settings and look at the sync options to make sure what you want is on then go into the actual app and go to settings and make sure sync is all on and whatever time interval you want it to sync for. What build are you on?

    Sent from my Sprint Galaxy S2 using Tapatalk 2
  3. Thread Author  Thread Author    #3  

    Default Re: Google contacts not syncing

    Stock..4.04 what app do I go in? The tech at sprint said he did that and it worked for an hour and quit.

    Sent from my SPH-D710 using Android Central Forums
  4. #4  
    rushter's Avatar

    Posts
    1 Posts
    ROM
    CM10 JB 4.1.2

    Thumbs up Re: Google contacts not syncing

    I had the same issue. I have a newer ROM but it appears that the Contacts and Contacts Storage apps have not really changed much, or if at all.
    I am rooted so understand that. I doubt it will make a difference.
    So here goes - there are actually two apps you need to clear the data from...
    Go to settings-apps. Then Contacts-force stop-ok-clear data. Then go to Contacts Storage-force stop-ok-clear data. Then go to Accounts-click on your gmail account and then uncheck Contacts and recheck it. This will restart sync. After this, you should be good to go.
    Thanked by 3:
    Kani_Kaninson likes this.
  5. Thread Author  Thread Author    #5  

    Default Re: Google contacts not syncing

    I will try thanks

    Sent from my SPH-D710 using Android Central Forums
  6. Thread Author  Thread Author    #6  

    Default Re: Google contacts not syncing

    Worked **** do I have to keep doing that?

    Sent from my SPH-D710 using Android Central Forums
  7. Thread Author  Thread Author    #7  

    Default Re: Google contacts not syncing

    Also how can I get the contacts I saved to phone to my gmail?

    Sent from my SPH-D710 using Android Central Forums
  8. #8  

    Default Re: Google contacts not syncing

    Quote Originally Posted by JBray0072 View Post
    Also how can I get the contacts I saved to phone to my gmail?
    AFAIK, you can't, unless you delete the phone one and then create a new one as a Google contact.
    Oh Yeah?! Well, my mom thinks I'm cool!
  9. Thread Author  Thread Author    #9  

    Default Re: Google contacts not syncing

    Doesn't matter just added a new contact to gmail and it went back to freezing up again..this sucks.

    Sent from my SPH-D710 using Android Central Forums
  10. #10  

    Default Re: Google contacts not syncing

    Go into your contacts app and press menu. Now click merge with google

    sent from MY BAD A$$ ET4G
  11. Thread Author  Thread Author    #11  

    Default Re: Google contacts not syncing

    I'll try thanks

    Sent from my SPH-D710 using Android Central Forums
  12. #12  

    Default Re: Google contacts not syncing

    Quote Originally Posted by rushter View Post
    I had the same issue. I have a newer ROM but it appears that the Contacts and Contacts Storage apps have not really changed much, or if at all.
    I am rooted so understand that. I doubt it will make a difference.
    So here goes - there are actually two apps you need to clear the data from...
    Go to settings-apps. Then Contacts-force stop-ok-clear data. Then go to Contacts Storage-force stop-ok-clear data. Then go to Accounts-click on your gmail account and then uncheck Contacts and recheck it. This will restart sync. After this, you should be good to go.
    Thanks for the good info. My sync got stuck (contacts had disappeared on my phone in the process which was odd) and your tips cleared it and got it going. Thanks!
  13. #13  

    Default Re: Google contacts not syncing

    I followed the instructions on how to set up a cardDAV account from the google website http://support.google.com/mail/bin/a...&answer=275307. Everything went fine, except when I try to create a new contact. I have 281 contacts on my iCloud account, and when i switch to google it say i have 290. When i check mark both accounts i have 298.
    So my first question is, when I set up carddav, why do i have extra contacts on Google if carDAV works smoothly with iOS?

    If I modify anything in iCloud, it gets sync'd to google. However if I try to add a new contact in Apple Contacts it doesn't show up in google anymore; the reverse is also true.
    With my old contacts i see on each entry an iCloud and cardDAV (Linked Contacts). On new entries there is no such link.

    In my Apple Contacts preferences, I left the default account as iCloud. If I change it to google per the instructions, then new contacts are added to google, but not added to Apple Contacts.

    This new cardDAV approach seems very close, but not exactly what I need. Gmail is my primary email, but Apple Contacts is my primary address book. My devices are all Apple: Macbook, iPad and iPhone 5. iCloud works perfectly between the devices. I want to add google as a "device" to this arrangement, because I got a Nexus 4 that Im trying out, and want to sync back and forth between the two device. Is there any way to accomplish what I am trying to do?

    Thanks in advance for the help.
  14. #14  

    Default Re: Google contacts not syncing

    i have to keep repeating the steps.. it always sync once and the next time the error is up again. and whenever i clear data.. contacts not synced will be deleted
  15. #15  

    Wink Re: Google contacts not syncing

    You *ROCK*
  16. #16  

    Default Re: Google contacts not syncing

    thank you very much for ur post ur solution worked a treat for me as my contacts had been shown in triplicate and when I erased them I found that i could not restore from the google server until I tried ur fix
  17. #17  

    Default Re: Google contacts not syncing

    Thanks a lot buddy. This fixed my contact, internet and calendar sync problem on my rooted Galaxy S3. It was weird as it wouldn't sync and it said try back shortly, so I thought it was an issue with google servers or something, but then i added a second gmail account that I had and that one synced just fine, so I figured it's something to do with my phone and I started searching for a solution and when I tried yours it worked like a charm. So thank you very much for the great tip. ...respect.
  18. #18  

    Default Re: Google contacts not syncing

    All of the Google sync services are atrocious. It's the one thing I absolutely can't stand on Android. I used to sync to iCloud. When I added something on my phone, it instantly appeared online. Google never syncs right and I usually just add them manually anyway. It's true for contacts and photos. Instant upload is about as bad as contacts. I'm looking to find a way to seamlessly sync photos, contacts, calendar and mail with iCloud.

    Even Youmail syncs better than Google.
  19. #19  

    Default Re: Google contacts not syncing

    Hunh. I never have a problem with Google Sync photos, contacts, calendar, etc. working promptly.
  20. #20  

    Default Re: Google contacts not syncing

    I'm having the exact same problem on my Nexus 4, ever since 4.1 (now running 4.3). Whenever I add a new contact on my phone, I save it under my gmail account (not phone memory) but the sync just freezes up. It will not sync from phone to gmail, and gmail to phone is sketchy once it freezes up.

    I hate how Android is full of features but incomplete. It feels half cooked and still in Beta.


    *Edit

    After a couple hours of playing around, it appears Go Contacts was creating the problem. If I created a new contact with Go Contacts, it would break the sync. If I use the stock android app, it works. Guess I'll have to switch back to stock for the time being. Unfortunate since the Go App looks much better
    Last edited by Akria181; 08-18-2013 at 11:07 PM.
  21. #21  

    Default Re: Google contacts not syncing

    Apparently, synching between Google contacts and "PEOPLE" on your android device can only be done manually IF you have multiple accounts linked to your gmail account (e.g. Facebook, Skype etc.)..

    Open PEOPLE on your android device, and you will see your contacts displayed. Press the menu icon and chose ACCOUNTS. Taping an an account will display options for synching, agenda, tasks, contacts etc.

    If you delete ALL accounts except your gmail account, pressing the menu icon will display an option to automatically synch the data (agenda, contacts, calendar).

    Gordon

Similar Threads

  1. Google Contacts not syncing
    By alex737 in forum HTC Hero
    Replies: 27
    Last Post: 07-02-2012, 08:33 AM
  2. Google contacts not syncing on INC.
    By rickap7 in forum General Help and How To
    Replies: 3
    Last Post: 04-27-2011, 08:17 AM
  3. Refurb phone - Google contacts not syncing
    By shelnbay in forum Motorola Droid
    Replies: 1
    Last Post: 09-29-2010, 08:05 PM
  4. Google Contacts not syncing
    By CricTic in forum General Help and How To
    Replies: 1
    Last Post: 09-26-2010, 02:53 PM
  5. Google Contacts Not Syncing
    By Noven in forum Verizon Droid Incredible
    Replies: 4
    Last Post: 09-02-2010, 06:01 AM

Posting Permissions