Have a rooted, CWM recovery installed, otherwise stock Sprint GS2. But not the most recent update(s), FL20something? Rooted, it would download, but not install. I was ok with that, phone worked well enough for me.

Was attempting to view a youtube video in an app description in the Play store late last night when the phone froze. Rebooted, or attempted to, and have been rebooting ever since. What the heck happened? More importantly, how do I fix it?

More info/details:

I can get into "Safe Mode" and the phone does work, albeit without the 100 or so apps that I of course feel I have to have.

I can get into CWM recovery. Tried wipe cache and dalvik cache and fix permissions. No help.

The phone will often boot, and get stuck at the stock lock screen (I use Widget Locker, but it never gets that far.) I attempt to 'swipe screen to unlock', which it senses (the lock and the circle show up), but it freezes there. Reboot, here we go again.

Have read some of the recent problems with the update - could this be it? Back to my important question - what to do?

Any guideance from the Elders is greatly appreciated. Thanks in advance.