1. PersonalJournals's Avatar
    Hey all, I attempted to start up my phone one day and the blue light flashed (as it does), the logo appeared, but then the logo disappeared and the blue light flashed again while the phone turned itself off. I can't turn the phone on at all. Highly frustrating. (I typed that up a month ago.) A month later, now it turns on, but it restarts or shuts off once every two or so minutes and sometimes what I mentioned above still occurs. I have tried everything. If anyone can help, I would appreciate it more than greatly. Phone is basically useless and impossible to use.
    01-11-2014 09:48 PM
  2. aseke's Avatar
    Hello.
    Go to service center. Re install OS in your device. Or Search Youtube How to Re install OS in your Device. I prefer to go service center.
    01-11-2014 10:02 PM
  3. aseke's Avatar
    Hello.
    Go to service center. Re install OS in your device. Or Search Youtube How to Re install OS in your Device. I prefer to go service center.
    01-11-2014 10:03 PM
  4. srkmagnus's Avatar
    Hey all, I attempted to start up my phone one day and the blue light flashed (as it does), the logo appeared, but then the logo disappeared and the blue light flashed again while the phone turned itself off. I can't turn the phone on at all. Highly frustrating. (I typed that up a month ago.) A month later, now it turns on, but it restarts or shuts off once every two or so minutes and sometimes what I mentioned above still occurs. I have tried everything. If anyone can help, I would appreciate it more than greatly. Phone is basically useless and impossible to use.
    Remove the battery for a few hours then reinsert it. Let it charge for a while then try rebooting and see if that fixes your issue. Also, consider a battery replacement.
    01-12-2014 03:05 PM

Similar Threads

  1. Replies: 2
    Last Post: 01-12-2014, 04:25 PM
  2. My Samsung S3 isn't in a reboot loop and I need files
    By James Seedorf in forum General Help and How To
    Replies: 5
    Last Post: 01-12-2014, 09:19 AM
  3. Problem with smart screen
    By AndroiderG2 in forum Verizon LG G2
    Replies: 1
    Last Post: 01-11-2014, 09:32 PM
  4. Issue with transferring photos/videos to SD card
    By Joe-Warrior in forum Sony Xperia Z1
    Replies: 2
    Last Post: 01-11-2014, 07:21 PM
  5. Replies: 1
    Last Post: 01-11-2014, 06:56 PM
LINK TO POST COPIED TO CLIPBOARD