Hello everyone,

I've been attempting to install CM 11 onto my Samsung galaxy S3. It is rooted. Every time I run it, it fails on the assertion which checks the Basband version. I believe the problem is that I am on Virgin Mobile, so I have a different baseband version. I was thinking I have found some threads elsewhere about this happening, and the fix was simply to edit updater-script to either bypass the assertion or to edit it to include the right baseband version. I tried to do this, but I edited it using notepad and was only able to save it as a .txt file. I tried running it again, and it did not work, this time it gave no error message. I believe the problem is format, or something with the file extension, so when it looks for the file, it cannot be found because it is looking for the wrong format. Before I edited the file, it did not seem to specify a file extension. In windows explorer it simply stated that the file type was "file". I think if I was able to edit it and maintain the file extension, it would work. Is there a way to do this? Or is there a simpler solution which I have not tried? Thank you for any help.

The model number is: SPH-L710
The Baseband version is: L710VPAMG2
Android version: 4.1.2