1. msoprano13's Avatar
    I get it especially when I'm on the train that I lost data connectivity. Is there a way to shut this off?
    07-27-2012 07:52 AM
  2. mc_gusto's Avatar
    Under more wireless settings. Roaming guard

    Sent from my SPH-L710 using Android Central Forums
    07-27-2012 08:20 AM
  3. smooches680's Avatar
    I get that notification as well and I am in my house.

    Sent from my White, Sexy S3.
    07-27-2012 10:04 AM
  4. RhinoDoc's Avatar
    Under more wireless settings. Roaming guard

    Sent from my SPH-L710 using Android Central Forums
    I have all domestic warnings off and I still get it at home, too. I assume I connect occasionally and then disconnect again because when I clear the warning, it reappears 15 minutes later.
    07-27-2012 12:01 PM
  5. purotj's Avatar
    Im getting the roaming notification everywhere too! I called sprint they told they had some outage problem in my area ( san diego ) and it will be fix by 8/01/12 and they gave me 20 dlls credit

    Sent from my Nexus 7 using Android Central Forums
    07-27-2012 08:32 PM
  6. anon(848791)'s Avatar
    Im getting the roaming notification everywhere too! I called sprint they told they had some outage problem in my area ( san diego ) and it will be fix by 8/01/12 and they gave me 20 dlls credit

    Sent from my Nexus 7 using Android Central Forums
    Aholes don't give me anything when I call and complain about the reception in San Diego.
    07-27-2012 09:47 PM
  7. etnpnys's Avatar
    Sorry to kick a dead horse in the face, but what needs to be changed in the Roaming Guard settings? Check them all or UNcheck them all?
    10-03-2012 09:45 AM
  8. walterwood44's Avatar
    Sorry to kick a dead horse in the face, but what needs to be changed in the Roaming Guard settings? Check them all or UNcheck them all?
    Both my wife and I have GS3s and get the roaming warning. I have tried the settings both unchecked and checked and seen no difference in getting warnings. Must be a bug.
    10-05-2012 05:57 AM
  9. etnpnys's Avatar
    Both my wife and I have GS3s and get the roaming warning. I have tried the settings both unchecked and checked and seen no difference in getting warnings. Must be a bug.
    Thanx for the reply. I work in QA, and you gotta understand that it's only a "bug" if it's not doing what they wanted it to do...

    My guess is that those checkboxes are changing something else. I don't have the phone in front of me right now, but IIRC the name of that area is pretty ambiguous.
    10-05-2012 08:35 AM
  10. jimatssf's Avatar
    I got there warnings too.i think the phone antenna sucks.
    10-05-2012 08:42 AM
  11. sakhari8's Avatar
    I got there warnings too.i think the phone antenna sucks.
    i second this. this is the first phone that i roam when at home.
    10-05-2012 11:17 AM
  12. msoprano13's Avatar
    i second this. this is the first phone that i roam when at home.
    Same here. my phone always shows terrible reception and i feel it is slow.
    10-05-2012 11:41 AM
  13. mobdad's Avatar
    I get it especially when I'm on the train that I lost data connectivity. Is there a way to shut this off?
    I was also getting this warning messages while playing poker in a location with plenty of Sprint towers. I spoke with Sprint about this and they told me to go to Settings/More Settings//Roaming/Roaming Guard and uncheck the box for domestic data because we all have unlimited domestic data. If you have unlimited domestic voice, you can uncheck that also. Roaming guard is the option to give you warnings. This should stop the messages.
    10-05-2012 12:59 PM
  14. Almeuit's Avatar
    Try going to system settings > phone update > and update your PRL and profile to see if this helps your roaming issue.

    I was also getting this warning messages while playing poker in a location with plenty of Sprint towers. I spoke with Sprint about this and they told me to go to Settings/More Settings//Roaming/Roaming Guard and uncheck the box for domestic data because we all have unlimited domestic data. If you have unlimited domestic voice, you can uncheck that also. Roaming guard is the option to give you warnings. This should stop the messages.
    Please be careful when doing this... You have unlimited data on sprints network. They do let you have.. "unlimited" roaming data but there is a catch with roaming data. If your roaming monthly data usage is more than 50% of your entire data usage for that month you can be terminated from service. Just check the TOS agreement on that. So if your roaming a ton be careful.. Remember unlimited on sprint... Some-what unlimited for roaming with that one catch.

    Sent from my Sprint S3 using AC fourms
    10-05-2012 01:37 PM
  15. windstrings's Avatar
    I was told by verizon tech support "after updating to version 4.11" that when your in a fringe area it prompts you to give you the opportunity to reestablish connection.
    If You simply leave it on global mode "allow access for all trips", it won't prompt you and you will not be charged if you don't have or subscribe to a global data plan.
    For verizon customers its best to put the "network mode" option to LTE/CDMA/EVDO

    However before you go out of country call Verizon to discuss your options or leave it on airplane mode during the trip.
    12-27-2012 05:54 PM
  16. Safan Honest's Avatar
    why note supportern data roaming
    12-25-2014 03:59 AM
  17. JohansBill's Avatar
    It depends on what kind of phone you use, but for android: go to SIM management---->Browse down to General Settings->click Roaming--->click Show Roaming reminder-->click "Never".
    04-05-2016 03:08 AM
  18. JohansBill's Avatar
    On data connectivity, on roaming settings: Click "Data Roaming"---> Check the tick of your Network provider--->prompt:"When you allow data roaming, you may incur significant roaming charges!"----->If you don't care click OK.
    04-05-2016 03:10 AM
LINK TO POST COPIED TO CLIPBOARD