Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
Like Tree2Likes
  • 2 Post By dad2noah
  1. Thread Author  Thread Author    #1  
    Bret69's Avatar

    Posts
    10 Posts
    Global Posts
    46 Global Posts

    Default My new S3 only shows 3G

    Why does my new S3 only show 3G and not 4G? My S2 show 4G in the same location, so my location shouldn't be the issue. The S3 doesn't even have a "4G on/off" setting in the settings menu - that I've found.
  2. #2  
    s14tat's Avatar

    Posts
    434 Posts
    ROM
    AOKP ICS build 38

    Default Re: My new S3 only shows 3G

    Your 4G on your Galaxy S2 is based on Wimax technology. That is now a legacy technology because they are switching to LTE. So where your area was a Wimax area, sprint has not rolled out 4g LTE yet.

    Don't worry though, when LTE is up, you will not miss wimax at all. Wimax speeds are typically 5-9 megs per second. On my Verizon LTE I get as much as 31 megs per second in NYC. People out in the sticks gets as high as 60+ megs per second. Its is not even close to be honest with you.
  3. #3  

    Default Re: My new S3 only shows 3G

    Settings
    More settings
    Mobile Network
    Network Mode
    By default, it's set to 3G. You can turn on 4G, but that will be useless if you're not in a 4G area.
    If you turn on 4G, and you're not in a 4G, it will show 3G, but if you slip into an area with 4G, it will automatically pick up the4G signal and display it.
    I have mine set to 4G for the hell of it, and there is no noticeable battery drain, although some people have said otherwise.
    Thanked by:
    BMIC50 
    Ntchwaidumela and Hatren like this.

Posting Permissions