1. Ron_Who's Avatar
    Hey all,

    First off, I'd like to say that I absolutely LOVE my S3! I bought it about a week ago, and haven't put it down since. However, I've run into a couple of issues which I hope someone may be able to help me out with:

    1) As of yesterday, I noticed that my battery indicator does not match the percentage of the battery life itself. I did a restart, pulled the battery out for about 10 minutes, powered it on, and still the same. Odd much:



    2) After I charge my phone to 100% each night, I take it off the charger, turn SYNC and MOBILE DATA off, and only leave Wifi on. That's no big deal right? Anyways, I wake up the next day to find this:



    I did further research, and discovered that Picasa was the typical reason. Cool...but I disabled Picasa the same day I bought the phone (the snapshot above is from this morning). Could Dropbox be responsible?
    11-17-2012 06:53 PM
  2. trunkmonkey1972's Avatar
    Where did you disable Picasa? I've heard that Google Plus can be part of the issue try turning off instant upload.

    S3 on Sprint - 16gb pebble blue + 64
    11-18-2012 05:25 PM
  3. Ron_Who's Avatar
    I went to Accounts and disabled under Google - I don't have Google +.
    11-18-2012 11:02 PM
  4. trunkmonkey1972's Avatar
    Have you rebooted? Take a deep dive into every google app you have and check settings. I was amazed at 1)how much is going on behind the scenes in these apps and 2) how much control the settings give you. i e google maps logs everywhere you go in a huge list and tries to share this with your friends when they look you up via Google. Who knew...

    S3 on Sprint - 16gb pebble blue + 64
    11-20-2012 02:33 AM
  5. trunkmonkey1972's Avatar
    Also google+ isn't uninstall able so check app drawer and settings.

    S3 on Sprint - 16gb pebble blue + 64
    11-20-2012 02:35 AM
  6. Vladabeast's Avatar
    For the gallery thing and picasa go to gallery in the apps and clear data. That's how I fixed my gallery taking up battery problem

    Sent from my MZ604 using Android Central Forums
    11-23-2012 05:04 PM

Similar Threads

  1. Two issues: ring/vibrate and flashing LED
    By djrakowski in forum Verizon Droid Incredible 2
    Replies: 34
    Last Post: 07-19-2012, 12:28 PM
  2. Charging Issues. Battery Drains, and screen goes crazy
    By Hypochondriac in forum LG Optimus S
    Replies: 4
    Last Post: 07-06-2012, 04:17 PM
  3. Replies: 10
    Last Post: 08-05-2010, 09:10 AM
  4. Car Dock - Two Issues (BT and Calling)
    By Fletchand in forum Droid X Accessories
    Replies: 4
    Last Post: 08-03-2010, 08:20 PM
  5. 3G Indicator and other issues...
    By plarpco in forum Verizon Droid Incredible
    Replies: 14
    Last Post: 07-15-2010, 10:46 AM
LINK TO POST COPIED TO CLIPBOARD