Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Strange behavior when turned on and charging [SOLVED]

    Hi, Everyone.

    I just got my Galaxy S3 yesterday. Hopefully this will be an easy question to answer.

    I have an external battery pack (from Anker) so I hooked it up to the USB cable that came with the phone. The lock screen says it's charging the phone, and I have no reason to doubt it, really, but the red indicator light doesn't come on. If I turn the phone off, and then start charging it, the red light comes on while it charges like I assume it's supposed to do.

    Is this normal? Is the light not supposed to come on when the phone is on?
    Last edited by bhartman36; 01-19-2013 at 07:26 AM.
  2. #2  
    Joe113's Avatar
    Banned

    Posts
    781 Posts
    Global Posts
    833 Global Posts
    ROM
    Liquid Smooth [4.2.2]

    Default Re: Strange behavior when turned on and charging

    Settings--->Display--->LED Indicator--->Charging (make sure it's checked)
  3. #3  

    Default Re: Strange behavior when turned on and charging

    You'll learn to hate that little led ... they need to make it "dimmable" its crazy bright at night while trying to sleep.

    Sent from my Samsung Galaxy S3
  4. #4  

    Default Re: Strange behavior when turned on and charging

    With the JB 4.1 update, they set it up to dim when there is no light on the sensor, and it's bright as hell when you put a light on it.. Back to the OP, It may be something with the external power source, have you tried taking it off and plugging in your phone directly?
  5. Thread Author  Thread Author    #5  

    Default Re: Strange behavior when turned on and charging

    Thanks, everyone.

    I think it was an app I was running. When I changed a setting in Light Manager having to do with charging (disabling it, I think) that seems to have done the trick. Once it goes to sleep, the charge light goes on, whether it's charging from the battery pack or the wall.
  6. #6  
    rando991's Avatar

    Posts
    550 Posts
    ROM
    Stock/Rooted

    Default Re: Strange behavior when turned on and charging

    The Lite Flow App will also mess things up. Just turning it off won't help, you have to actually uninstall it. A few other things Lite Flow does for me I don't like: Talkback comes on when off, and tells me a folder is open or a folder is closed, and T-9 trace (even though i like Swype better) doesn't work. the LED control is buggy at best too. Don't always get the results I'd expect. I'm really hoping this can be fixed someday soon.
  7. #7  

    Default Re: Strange behavior when turned on and charging [SOLVED]

    Quote Originally Posted by stevedub View Post
    You'll learn to hate that little led ... they need to make it "dimmable" its crazy bright at night while trying to sleep.

    Sent from my Samsung Galaxy S3
    Glad most custom ROMs allow you to disable it

    Sent from yo moms house son!😎😎Using my SPH - L710 running AOKP Rom 4.1.2, now initiating Swagger
    Android is a tune up sports car with custom interior, sound system, and IOS is a stock model benz

    I use Android, because unlike IOS, i keep my apps in app drawers, and not infinitely cluttered homescreens

Similar Threads

  1. HELP! my S3 just died and wont turn on or charge
    By MrsSquirty in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 12-24-2012, 10:34 AM
  2. Replies: 3
    Last Post: 12-05-2012, 04:37 PM
  3. Replies: 0
    Last Post: 10-31-2012, 11:01 PM
  4. camera makes click sound when turned on
    By jonathanlc2005 in forum HTC EVO 4G
    Replies: 14
    Last Post: 07-07-2010, 09:32 PM
  5. Turn on and off Hotspot Feature?
    By asuman1179 in forum HTC EVO 4G
    Replies: 9
    Last Post: 05-28-2010, 09:25 PM

Posting Permissions

B