Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Is it just my phone with all these startup logos...?

    I noticed since the jellybean update my phone takes quite a while to start up. I get 5 different screens before the home screen shows up. The black screen with the white Samsung logo, then the Samsung Galaxy S3 screen, followed by a Samsung oval logo with animation, then the Sprint Lte screen and finally the black screen with the white logo comes up again at the end. I dont remember it taking this long to start up with ICS. Is that normal or did I download an unofficial zip file.
  2. #2  

    Default Re: Is it just my phone with all these startup logos...?

    It's normal. It's annoying and the animations do make the phone take longer to start but nothing you can do except root and put a different ROM on the phone and that would get rid of them.

    Sent from my Sprint S3 using AC forums.

Similar Threads

  1. Is it just my bad luck, or do Samsung phones have issues?
    By aznhomieboi1689 in forum T-Mobile Galaxy S II
    Replies: 21
    Last Post: 02-23-2014, 12:51 PM
  2. Is it just my phone...
    By PanickedAshley in forum General Help and How To
    Replies: 2
    Last Post: 08-16-2012, 08:05 AM
  3. Is it just my battery life that sucks?
    By Andr3w in forum Sprint Galaxy Nexus
    Replies: 54
    Last Post: 08-01-2012, 10:31 AM
  4. OK is it just my area?
    By piizzadude in forum Verizon Droid Charge
    Replies: 6
    Last Post: 07-25-2011, 01:06 PM
  5. Replies: 9
    Last Post: 06-29-2010, 04:51 AM

Posting Permissions

B