1. droid_4_life's Avatar
    I'm very frustrated with my GS3. Since the upgrade to 4.1 a few months ago I have been having way too many dropped calls. It's to the point that I'm thinking of switching phones or carriers. The problem is that some times I can be in the middle of a call and then all of a sudden everything goes silent as if the phone has been muted. When I look at the display the timer is still ticking and it appears the call is still connected but I can't hear the other person nor can they hear me. It does not matter if I initiate the call or someone calls me. I took it to Sprint but of course they don't want to look at it because I don't pay for the insurance. I just wanted to know if anybody else has noticed this problem? Please share any comments or suggestions.
    Almeuit likes this.
    02-03-2013 12:18 PM
  2. meyerweb#CB's Avatar
    This obviously isn't a common problem with 4.1, or the forum would be full of posts like this.

    As is stated in every thread about problem post the JB OTA: a factory reset almost always fixes problems that began as a result of the upgrade.
    02-03-2013 07:51 PM
  3. Almeuit's Avatar
    I'm very frustrated with my GS3. Since the upgrade to 4.1 a few months ago I have been having way too many dropped calls. It's to the point that I'm thinking of switching phones or carriers. The problem is that some times I can be in the middle of a call and then all of a sudden everything goes silent as if the phone has been muted. When I look at the display the timer is still ticking and it appears the call is still connected but I can't hear the other person nor can they hear me. It does not matter if I initiate the call or someone calls me. I took it to Sprint but of course they don't want to look at it because I don't pay for the insurance. I just wanted to know if anybody else has noticed this problem? Please share any comments or suggestions.
    This obviously isn't a common problem with 4.1, or the forum would be full of posts like this.

    As is stated in every thread about problem post the JB OTA: a factory reset almost always fixes problems that began as a result of the upgrade.
    Didn't mean to thank the post.. Oh well.

    Pretty much what meyerweb said is true. I used to have the same problem as you DROID.. But it stopped after awhile. This is a Sprint issue not a update issue. Is network vision going on in your area?

    Sent from my Sprint S3 using AC forums.
    02-04-2013 01:39 AM
  4. droid_4_life's Avatar
    Yes, network vision is going on in my area. Starting to see 4G LTE in some areas of my town. I will try the factory reset and see if that works. Thanks for your comments.
    02-05-2013 05:31 PM
  5. Buddlespit's Avatar
    and maybe do a prl/profile update
    Ntchwaidumela likes this.
    02-05-2013 06:54 PM
  6. Almeuit's Avatar
    Yes, network vision is going on in my area. Starting to see 4G LTE in some areas of my town. I will try the factory reset and see if that works. Thanks for your comments.
    I've already done this. I believe it's a network issue. Mine was horrible for about 2 weeks but now my phone is working like normal. Calls are fine and also people can hear me.

    Sent from my Sprint S3 using AC forums.
    Ntchwaidumela likes this.
    02-05-2013 09:05 PM

Similar Threads

  1. Sprint GS3 flicker after return to home
    By joeydownsouth in forum Sprint Galaxy S III
    Replies: 11
    Last Post: 09-11-2012, 11:10 PM
  2. Will the Sprint GS3 be worth an upgrade?
    By dcraig in forum Sprint Galaxy S III
    Replies: 12
    Last Post: 05-24-2012, 03:53 PM
  3. Will the Sprint GS3 be worth an upgrade?
    By dcraig in forum Samsung Galaxy S3
    Replies: 12
    Last Post: 05-24-2012, 03:53 PM
  4. dropped incoming calls after 2.3.4 upgrade
    By eahyland in forum AT&T Captivate Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 09-30-2011, 11:56 AM
  5. Evo keeps dropping calls after exactly 30 minutes?
    By Devilicus in forum HTC EVO 4G
    Replies: 4
    Last Post: 07-27-2011, 02:14 PM
LINK TO POST COPIED TO CLIPBOARD