1. TextMeMaybe's Avatar
    I've been getting that message when updating some of my apps. Has anyone else got that message? Is it my phone? Or the app?
    08-08-2013 09:42 AM
  2. SpookDroid's Avatar
    It could be both and then one more thing.

    1) Your phone, for some reason, lost its marbles and damaged the downloaded file beyond recognition. This, of course, would be the worst case scenario and it's quite unlikely. But I like to scare people beforehand :P hehe

    2) The most likely reason is you had some intermittent connection during the download and the file got corrupted. Now, this has happened more often since the last two or three Play Store updates, so I'm guessing it's a bad handling on their side, but it happens.

    3) It happens sometimes that developers upload bad files and sometimes they don't work at all or don't work for some models (and here's where I cry 'FRAGMENTATION' and wait for those that claim that's not really a problem anymore to fight back).
    08-08-2013 09:49 AM
  3. hydrogen3's Avatar
    I'm Having this same issue on my optimus G, hard resets, factore resets clear data cash etc nothing works. I'm stick with a phone I can't use...
    08-08-2013 09:54 AM
  4. nduchene#AC's Avatar
    It could be both and then one more thing.

    1) Your phone, for some reason, lost its marbles and damaged the downloaded file beyond recognition. This, of course, would be the worst case scenario and it's quite unlikely. But I like to scare people beforehand :P hehe

    2) The most likely reason is you had some intermittent connection during the download and the file got corrupted. Now, this has happened more often since the last two or three Play Store updates, so I'm guessing it's a bad handling on their side, but it happens.

    3) It happens sometimes that developers upload bad files and sometimes they don't work at all or don't work for some models (and here's where I cry 'FRAGMENTATION' and wait for those that claim that's not really a problem anymore to fight back).
    The issue seems widespread across a bunch of apps. My guess: #2 is exactly the problem. I've had the same problem across 2 different phones today, one was right out of the box. I'm having more luck over wifi than 4g today, which makes me think it's a connectivity issue and probably an insensitivity by Google to those without a super fast/reliable connection.
    08-08-2013 01:47 PM
  5. SpookDroid's Avatar
    It wasn't like that all the time. I KNOW that I used to download files with intermittent connections before without issues. The issue is recent.
    08-08-2013 02:19 PM
  6. android_legend's Avatar
    I have a T-Mobile GS3 and had been having the package is invalid error the past few days. Don't know what caused it. It's hit and miss. Few apps installed/updated fine, others took this error. I've gotten a few updates pushed by Google: PlayStore 4.3.10, Android Device Manager. I've tried everything including wiping the phone, deleting/adding accounts, nothing worked..... And today, out of the blue, everything installed fine including those that took the error. Maybe disabling Android Device Manager did the trick, but I did that before... Google owes Android communities some explanation.. grrrr..

    Posted via Android Central App
    08-09-2013 11:29 PM
  7. MooBohmke's Avatar
    Been getting that error with my Samsung G3 and a Google Nexus tablet that last few days.

    Sent from my Samsung Galaxy s3 using Tapatalk 4
    08-11-2013 11:08 PM
  8. diana skiles's Avatar
    After trying the suggestions to clear cache and data and uninstall updates from Google Play and Download Mananger - with no success - I turned off my WiFi and tried downloading the app with 4G connection. That worked fine.
    08-12-2013 03:46 PM
  9. slave's Avatar
    I get this on 4G, 3G and wifi. I did every fix listed on the internet, none of which worked. This must be a google server issue.
    08-12-2013 10:42 PM
  10. Jbenz2014's Avatar
    Ive had this problem too but more apps are getting the error i cant even use some of apps that were already installed on my phone using 4g doesnt work nor does wifi really pissing me off
    08-13-2013 09:43 AM
  11. skrpionz's Avatar
    I had the same problem: package file is invalid.
    I just went to the app store > settings > my apps and updated them from there n they updated fine.. try that idk if it'll work for you but it did for me
    08-13-2013 12:41 PM

Similar Threads

  1. Galaxy S3 - it says that memory is full while it isn't
    By arwa13 in forum General Help and How To
    Replies: 53
    Last Post: 01-13-2016, 08:27 PM
  2. USB cable not recognised when tablet is on
    By BlueGunners in forum Samsung Galaxy Tab 2
    Replies: 5
    Last Post: 08-22-2013, 08:55 AM
  3. looking for simple file app
    By kaschiro in forum Samsung Galaxy Tab 2 10.1
    Replies: 3
    Last Post: 08-08-2013, 11:34 AM
  4. Getting package invalid for app updates
    By jpriest007 in forum Google Play Store
    Replies: 1
    Last Post: 08-08-2013, 08:32 AM
  5. Replies: 0
    Last Post: 08-08-2013, 05:36 AM
LINK TO POST COPIED TO CLIPBOARD