1. shoez's Avatar
    Hello everyone, and thank you in advance!

    I have had this phone for a little over a 2 years now and it has always worked great. However recently it has had issues loading from cold start. It was having a little bit of trouble, but now it will no longer boot. I am uncertain of the reason, but hopeful that someone here might know.

    Here is a video of the issue. The phone is unresponsive to the procedure to factory reset.


    Thank You!
    04-18-2014 09:51 PM
  2. dad2noah's Avatar
    Volume up, home, power at the same time?
    04-21-2014 07:15 AM
  3. GSDer's Avatar
    Welcome to the forums!
    Here is a video of the issue.
    Any time the phone powers on merely by inserting the battery the Power switch/button is suspect. Tapping it isn't necessarily a fix.

    You probably want to start by carefully removing the Power button (the little plastic piece that we press on - there are two legs that keep it in place).

    If that doesn't help then it's time to open the phone up until you can get to the actual Power switch on the mainboard. You can try compressed air or electronic contact cleaner (be sure the battery is out) and see if that corrects the issue.

    If not then it's time to remove the actual switch from the mainboard and replace it.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-21-2014 12:03 PM

Similar Threads

  1. Replies: 21
    Last Post: 11-20-2016, 09:24 PM
  2. Can I send my Nexus 7 to Google for repair, and how much will it cost?
    By ShakeSpee in forum Google Nexus 7 Tablet (2012)
    Replies: 13
    Last Post: 02-27-2016, 04:44 PM
  3. HTC M7 WiFI not turning on
    By Kylellwood in forum AT&T HTC One
    Replies: 7
    Last Post: 02-21-2015, 09:24 AM
  4. Strange ring on glass
    By splmonster in forum Moto X (2013)
    Replies: 1
    Last Post: 04-18-2014, 09:25 PM
LINK TO POST COPIED TO CLIPBOARD