Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
Like Tree3Likes
  • 1 Post By jmdeng
  • 2 Post By davidtm
  1. Thread Author  Thread Author    #1  

    Default wifi won't turn off with KitKat?

    With the 4.4.2 update, I noticed something odd today.

    Normally, I have wifi turned on. I was within range of a wifi network that requires sign in (clicking through a web page). The phone naturally found it and connected. I didn't want to connect as I was happy on my 3G (heh) connection and so I tried to turn off wifi by clicking on the wifi icon in the pull down menu.

    The wifi icon started to pulse, then turned off. Then a second later, it turned back on. Surprised, I tried to turn it off again. Same graphics. Pulse off, pulse back on. I even tried to click on the Wifi settings (the lower bar of the icon) and then click the ON switch to OFF, but again, it only went off briefly before turning back on again.

    Eventually, I gave up and just clicked on "Forget" for the network in question and after that I wasn't bothered (but I don't recall if wifi stayed on or not).

    I later tested this on my home network. However, when I turned of the wifi network, all I got was the pulse to off, but no rebirth. The only theory I have is this is isolated to networks that have a sign in requirement. My home one is just key protected.

    Has anyone else experienced this since the update?

    Thanks
    shadowmere813 likes this.
  2. #2  

    Default Re: wifi won't turn off with KitKat?

    Kinda pi$$ing me off too. Mine turns off normally but as soon as I don't have a 3g signal it auto turns on WiFi again. This also has an adverse effect on my battery life.

    My Evo lte Filling the shoes of my HTC One
    Owner of a replacement Htc One... Till something better comes along
    LG G3
    Ambassador
  3. #3  
    davidtm's Avatar

    Posts
    113 Posts
    Global Posts
    677 Global Posts

    Default Re: wifi won't turn off with KitKat?

    Sprint's 4.4.2 update included a connections optimizer app which "helpfully" turns on Wi-Fi periodically to find an available network to decrease your data usage. I happened to find it (though I cannot now) to turn it off, as I didn't want it to burn up any battery trying to connect to any network it might find.

    UPDATE: I found it, thanks to the following link. It's in Settings > Mobile data > Automatic Connections

    This link provides some good pro/con info:
    http://www.pocketables.com/2013/02/s...nd-or-foe.html
    Thanked by 4:
    BigDinCA and kct1975 like this.
  4. #4  

    Default Re: wifi won't turn off with KitKat?

    THANK YOU!

    Sent from my HTCONE using AC Forums mobile app
    Owner of a replacement Htc One... Till something better comes along
    LG G3
    Ambassador
  5. #5  
    davidtm's Avatar

    Posts
    113 Posts
    Global Posts
    677 Global Posts

    Default Re: wifi won't turn off with KitKat?

    Glad to help

    Sent from my cm_tenderloin using Tapatalk
  6. #6  

    Default Re: wifi won't turn off with KitKat?

    Quote Originally Posted by davidtm View Post
    Sprint's 4.4.2 update included a connections optimizer app which "helpfully" turns on Wi-Fi periodically to find an available network to decrease your data usage. I happened to find it (though I cannot now) to turn it off, as I didn't want it to burn up any battery trying to connect to any network it might find.

    UPDATE: I found it, thanks to the following link. It's in Settings > Mobile data > Automatic Connections

    This link provides some good pro/con info:
    http://www.pocketables.com/2013/02/s...nd-or-foe.html
    Ya...I noticed the Connections Optimizer downloaded during the installation of Kit-Kat on my phone. I remember it from my HTC EVO and I disliked it then. I gave this version a couple of days, and found that I hated it too. I quickly got a friend at work to help me to disable it.

    Sent from my RCT6378W2
  7. #7  

    Default Re: wifi won't turn off with KitKat?

    Bingo this works !!!!!
    Too bad I went to Sprint b4 I read this
    They reset my HTC One....big mistake
    And it still didn't solve the problem
    Thank you
    Thanked by:
  8. #8  

    Default Re: wifi won't turn off with KitKat?

    Holy **** thank goodness for this, very helpful!

    Sent from my HTCONE using Tapatalk
    Thanked by:
  9. #9  

    Default Re: wifi won't turn off with KitKat?

    I have a unlocked AT&T HTC One that suddenly started this nonsense with the automatically turning on wifi. I dont see a optimizer on this model but if anyone knows how to make it stop that would be great. I have the HTC One M7 model not the M8. I'm pretty sure it does not have the kit kat update on it if that helps. Thanks
  10. #10  
    Belhade's Avatar

    Posts
    54 Posts
    Global Posts
    103 Global Posts

    Default Re: wifi won't turn off with KitKat?

    Whoa...this looks like my problem, too. I drive around a lot and any time I hit an open network (I have Optimum Online's wifi) it will connect, even if I drive out of range within a minute or two. Hopefully this will help, though I question its wording; it says "Automatically connect to best network" but I hope it will switch to 4G when it can...
  11. #11  

    Default Re: wifi won't turn off with KitKat?

    For the Sprint HTC one variant go to settings-apps- then swipe to the left and pass system running apps- all apps ,scroll down to Sprint connections optimizer and then click (DISABLE) ----- PROBLEM SOLVED, TRUST AND BELIEVE THIS WILL save YOUR BATTERY ...ANY QUESTIONS HMU IM HAPPY TO HELP IN ANY WAY I CAN

    Posted via MY HTC ONE!!
    Thanked by:
  12. #12  

    Default Re: wifi won't turn off with KitKat?

    Quote Originally Posted by Jason Wanye View Post
    For the Sprint HTC one variant go to settings-apps- then swipe to the left and pass system running apps- all apps ,scroll down to Sprint connections optimizer and then click (DISABLE) ----- PROBLEM SOLVED, TRUST AND BELIEVE THIS WILL save YOUR BATTERY ...ANY QUESTIONS HMU IM HAPPY TO HELP IN ANY WAY I CAN

    Posted via MY HTC ONE!!
    With the M8 that I got in April, I had to have TiBu freeze the Sprint Connections app...because when I disabled it, the way you've suggested it, it simply re-enabled itself.

Similar Threads

  1. Galaxy Note 3: Need help with unlock
    By Chi Tieu in forum Samsung Galaxy Note 3 in Canada (Bell/Rogers/Telus)
    Replies: 4
    Last Post: 02-19-2014, 01:03 PM
  2. Replies: 15
    Last Post: 02-14-2014, 05:45 PM
  3. Unable to turn off vibrate for sms with android 4.2
    By squirlee_t in forum HTC One X
    Replies: 2
    Last Post: 02-13-2014, 08:50 PM
  4. Replies: 0
    Last Post: 02-13-2014, 05:35 PM
  5. Replies: 1
    Last Post: 02-13-2014, 01:59 PM

Posting Permissions