Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    My HTC One automatically detects a wi-fi signal it thinks is open, and it turns on WiFi. Only MOST of the "open" wifi actually require a log-in. So if I enter an area with a corporate or other log-in required Wifi (really almost ALL public wifi requires login) myphone is just dead to the internet. I have to go in, turn OFF wifi, then it reverts to 4G.

    I would rather have it default always to 4G and let me turn it on when I need it. Any way to have it do that?
  2. #2  

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    I am not sure. I have gotten to the point where I just turn off wifi as I am leaving the house. If I go somewhere that has wifi and I want to use it I will then turn it back on and log in. Otherwise I just use the 4g without the annoying wifi message popping up every time I want to use the phone.
  3. #3  
    benny3's Avatar
    Flashoholic!!

    Posts
    2,224 Posts

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Go into the advance wifi settings and turn off the notifications
    ram1220 likes this.
  4. Thread Author  Thread Author    #4  

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    ram1220, I do turn it off. But when it's in a location where there's an "open" (not really the right term imho) wifi it turns on and tries to connect. I only notice sometimes because no data is moving, and I look and see the wifi indicator is on but no data is moving.

    Benny3, Notifications is turned off. In fact, everything in the Advanced WiFi panel is turned off except for WiFi Optimization.
  5. Thread Author  Thread Author    #5  

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Still trying to find this out. Every day at the gym, when I get there with wifi off, it turns wifi on automatically within the first few minutes. And of course, their wifi requires I stop, go to settings, turn off wifi again, and get back to what was working FINE under 4g already! Totally a nuisance. And if that weren't enough, sometime in the ensuing few minutes, it will AGAIN turn on wifi, and of course no data flows because I haven't logged in, so then I have to do it all over again. This is junk design on someone's part, not to let you override wifi totally. And the idea that "if it's not a protected wifi then it's OPEN and you can connect to it" isn't true either; some places I don't have access to the wifi it's "open" with a password login.
  6. #6  
    benny3's Avatar
    Flashoholic!!

    Posts
    2,224 Posts

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Quote Originally Posted by spthomas View Post
    Still trying to find this out. Every day at the gym, when I get there with wifi off, it turns wifi on automatically within the first few minutes. And of course, their wifi requires I stop, go to settings, turn off wifi again, and get back to what was working FINE under 4g already! Totally a nuisance. And if that weren't enough, sometime in the ensuing few minutes, it will AGAIN turn on wifi, and of course no data flows because I haven't logged in, so then I have to do it all over again. This is junk design on someone's part, not to let you override wifi totally. And the idea that "if it's not a protected wifi then it's OPEN and you can connect to it" isn't true either; some places I don't have access to the wifi it's "open" with a password login.
    You said in your first post that WiFi Optimization is on , turn it off that can cause what you are seeing, its what the app is intended to do
  7. Thread Author  Thread Author    #7  

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Well, that didn't work either. I turned off WiFi Optimization, turned off wifi, and about 10 minutes later all data stopped because WiFi had turned itself on, and was waiting for me to go to a browser, go to Starbucks sign in page, and sign in, then go back to my music streaming app where I was happily streaming music over 4G!!
  8. Thread Author  Thread Author    #8  

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Problem solved!!
    It was the Android Location service. If you set it to High Accuracy or Battery Saver mode, it will turn on WiFi. If you select Device Only, it does not turn on the wifi.
  9. #9  
    Miner's Avatar

    Posts
    22 Posts
    Global Posts
    178 Global Posts

    Default Re: stop Wi-Fi from coming on HTC One M7, Kitkat 4.4.2

    Quote Originally Posted by spthomas View Post
    Problem solved!!
    It was the Android Location service. If you set it to High Accuracy or Battery Saver mode, it will turn on WiFi. If you select Device Only, it does not turn on the wifi.
    Thanks. Good tip, I was experiencing the same thing you describe.

Similar Threads

  1. Does the S5 have a limit on the size of Notes in Contacts?
    By tiggrev in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 07-12-2016, 04:11 PM
  2. New OEM batteries on ebay, real or not?
    By 3rdpig in forum Samsung Galaxy S5 Accessories
    Replies: 3
    Last Post: 07-08-2014, 01:39 AM
  3. Replies: 15
    Last Post: 05-11-2014, 09:17 PM
  4. can you use pebble smartwatch on ICS devices?
    By ahawkua in forum General News & Discussion
    Replies: 1
    Last Post: 05-06-2014, 10:10 PM
  5. how do I turn pebble smart watch on
    By ahawkua in forum General News & Discussion
    Replies: 1
    Last Post: 05-06-2014, 08:55 PM

Posting Permissions