12-04-2013 11:43 PM
43 12
tools
  1. Joseph M's Avatar
    So i got my G2 yesterday in a corporate store and i am truly in love with it. coming from and Evo 3D. It was a HUGE upgrade. My problem is the freaking LTE connectivity. The phone only gets a few seconds of LTE and then it just switches back to 3G and stays there. I have literally tried EVERYTHING. updated profile, PRL, set it from global to LTE/CDMA, turn off Connection Optimizer, restarted it. Literally everything and nothing. Every time i do something, LTE turns on and a few moments later 3G. I live in NYC where their LTE towers are ON so i am VERY mad at this. You would think that their first SPARK device would at least receive the original 1900 MHz 4G LTE signal until the "Spark" update. SMH!
    11-09-2013 12:15 PM
  2. Golfdriver97's Avatar
    Have you contacted the store about it yet?
    11-09-2013 12:24 PM
  3. UJ95x's Avatar
    So i got my G2 yesterday in a corporate store and i am truly in love with it. coming from and Evo 3D. It was a HUGE upgrade. My problem is the freaking LTE connectivity. The phone only gets a few seconds of LTE and then it just switches back to 3G and stays there. I have literally tried EVERYTHING. updated profile, PRL, set it from global to LTE/CDMA, turn off Connection Optimizer, restarted it. Literally everything and nothing. Every time i do something, LTE turns on and a few moments later 3G. I live in NYC where their LTE towers are ON so i am VERY mad at this. You would think that their first SPARK device would at least receive the original 1900 MHz 4G LTE signal until the "Spark" update. SMH!
    How strong is the LTE? If it's weak I wouldn't expect it to hold onto it as it wastes more battery than only using 3G.
    11-09-2013 12:25 PM
  4. Joseph M's Avatar
    I haven't contacted the store yet since they are usually no help. Only thing they could help on is if its a hardware problem, which i doubt. The signal is pretty strong. I have done test.
    I turn Airplane mode ON and OFF to make the phone find the LTE signal. Once i get it, i immediately run a speed test. I get 50-70 pin, 15-25 Down and 4-7 UP. Sometimes the speedtest cant even finish because it switches right back to 3G.
    11-09-2013 12:41 PM
  5. mostlywords's Avatar
    Yeah I'm having the same problem. My S3 was able to hold onto an LTE signal pretty well, but the G2 can't for some reason. I've also tried everything you've tried, and am getting the same result: LTE for a few seconds, then back to 3G

    Sent from my LG-LS980 using Tapatalk
    11-09-2013 12:47 PM
  6. UJ95x's Avatar
    I haven't contacted the store yet since they are usually no help. Only thing they could help on is if its a hardware problem, which i doubt. The signal is pretty strong. I have done test.
    I turn Airplane mode ON and OFF to make the phone find the LTE signal. Once i get it, i immediately run a speed test. I get 50-70 pin, 15-25 Down and 4-7 UP. Sometimes the speedtest cant even finish because it switches right back to 3G.
    This does sound like a hardware problem. If it"s good signal strength it shouldn't be losing it
    11-09-2013 12:49 PM
  7. Joseph M's Avatar
    The thing is, if it would had been any other LTE phone thats out. I would had immediately thought it was the Hardware, but this is a new phone that came out and the first Tri band phone. So my first thoughts was that something might be conflicting with the 3 LTE frequencies, even though sprint hasn't sent an update for them. But you never know, it could had been a bad batch of phones.
    11-09-2013 01:04 PM
  8. darryjr's Avatar
    The thing is, if it would had been any other LTE phone thats out. I would had immediately thought it was the Hardware, but this is a new phone that came out and the first Tri band phone. So my first thoughts was that something might be conflicting with the 3 LTE frequencies, even though sprint hasn't sent an update for them. But you never know, it could had been a bad batch of phones.
    Its not a bad batch of phones, look through all the forums for sprint. Unfortunately it seems to be a widespread issue at moment. I actually have had mine for two weeks same thing. CSR are useless
    11-09-2013 01:11 PM
  9. UJ95x's Avatar
    Its not a bad batch of phones, look through all the forums for sprint. Unfortunately it seems to be a widespread issue at moment. I actually have had mine for two weeks same thing. CSR are useless
    Wow
    Sprint fails to deliver again
    11-09-2013 01:19 PM
  10. Joseph M's Avatar
    I guess well just have to wait for a dam update -___-
    11-09-2013 01:44 PM
  11. darryjr's Avatar
    I guess well just have todam update -___-
    I also have static during a call, weird thing is if I roam, call is normal, when not roaming, static and popping. Went to corporate store and they had no idea what to do. I did not get phone from sprint or bb I actually picked it up in new Hampshire pre release and live in NY. As far as the static, I also read that is common on Verizon, haven't seen it with sprint, except mine at this point. Hopefully they update soon.
    11-09-2013 02:08 PM
  12. moonoverparma00's Avatar
    I'm having the same issue. This really pisses me off. I come back to sprint and this is what happens.

    Posted via Android Central App
    11-09-2013 03:53 PM
  13. darryjr's Avatar
    I'm having the same issue. This really pisses me off. I come back to sprint and this is what happens.

    Posted via Android Central App
    Are you having the lte issue or the static and pop in call that I spoke about?
    11-09-2013 04:04 PM
  14. KingT33's Avatar
    Make sure that under Mobile Networks your network mode is on LTE/CDMA and connections optimizer is unchecked. It fixed the problem i was having.
    11-09-2013 04:23 PM
  15. moonoverparma00's Avatar
    Are you having the lte issue or the static and pop in call that I spoke about?
    The LTE issue. I have CDMA/LTE selected and connections optimizer turned off and still have the problem

    Posted via Android Central App
    11-09-2013 05:26 PM
  16. jfenton's Avatar
    I had the problem but disabled the optimizer, switched from Global to CDMA / LTE and updated the profile and now it seems to work like a charm
    11-09-2013 05:43 PM
  17. moonoverparma00's Avatar
    I had the problem but disabled the optimizer, switched from Global to CDMA / LTE and updated the profile and now it seems to work like a charm
    I'll give that a try.

    Posted via Android Central App
    11-09-2013 07:30 PM
  18. headbuzz's Avatar
    I have global enabled..no issues with LTE so far. Even the switch from 3g to LTE is almost immediate.

    Sent from my LG-LS980 using AC Forums mobile app
    11-10-2013 09:26 AM
  19. moonoverparma00's Avatar
    Mine will not connect to LTE at all while on global. When I switch to CDMA/LTE, it will connect only for a few seconds and then drop out. I have to force it to connect again but will still drop out after a few seconds.

    Posted via Android Central App
    11-10-2013 11:52 AM
  20. mount.zed's Avatar
    you are probably in an area where the towers are compatible with the device. I suspect if you took your phone to the same location moonverparma00 is you would have the same issue as he is having

    I have global enabled..no issues with LTE so far. Even the switch from 3g to LTE is almost immediate.

    Sent from my LG-LS980 using AC Forums mobile app
    11-10-2013 12:13 PM
  21. Joseph M's Avatar
    My question is. Will they have a fix for the NV towers and the legacy towers conflicting with each other and not being compatible with the phone?, or is this something that you just luck out if you live in the wrong place? This seems like a serious problem so i would like to know. I only have 14 day to return the phone and cancel this JOKE of a service.
    11-10-2013 12:41 PM
  22. moonoverparma00's Avatar
    Sprint better come up with an answer fast because if I can't take advantage of the LTE in my area, I want to return this phone within my 14 days.

    Posted via Android Central App
    11-10-2013 05:17 PM
  23. Dan Oldham's Avatar
    Just got my LG G2 and having the same issue connecting to 4G/LTE. My wife got a Galaxy S4 about two weeks ago and she hasn't had any issues getting 4G/LTE to connect.

    I tried the suggestion of switching the Mobile Network setting and it hasn't made any difference, I'm still just hitting 3G. It's flashed to 4G/LTE a few times but it's been for maybe a second or two at a time. I've pretty much had nothing but problems since getting the phone three days ago.

    - Can't get it to connect to my MacBook

    - Can't get 4G/LTE

    - Wasn't receiving text messages from anyone with iPhones

    I love this phone but I'm becoming annoyed with it very quickly. I'm half tempted to return it for a Galaxy S4. My wife hasn't had ANY of these problems with her phone.
    11-12-2013 07:51 AM
  24. eptiger's Avatar
    I assume this is the problem:

    Nexus 5 and LG G2 experience temporary Sprint LTE connectivity issues due to Circuit Switched Fallback technology - Sprint 4G Rollout Updates

    So there's no toggle between 3G and LTE if I want to turn on one or the other? It just autodetects? I'd rather be able to control that myself. I'm not able to find the toggle for it, at least. I have my mobile networks set to global. What's the difference between global and cdma/lte?

    Elton
    Jawbox likes this.
    11-12-2013 01:02 PM
  25. Dan Oldham's Avatar
    I assume this is the problem:

    Nexus 5 and LG G2 experience temporary Sprint LTE connectivity issues due to Circuit Switched Fallback technology - Sprint 4G Rollout Updates

    So there's no toggle between 3G and LTE if I want to turn on one or the other? It just autodetects? I'd rather be able to control that myself. I'm not able to find the toggle for it, at least. I have my mobile networks set to global. What's the difference between global and cdma/lte?

    Elton
    No, Elton, there is no toggle to choose between the 3G and 4G/LTE. It's very frustrating to have a new phone that won't even pick up a 4G network. One of the reasons I chose to upgrade was because my iPhone 4S was only capable of picking up 3G. Now, I've spent $200 to upgrade to yet another phone that will not pick up a 4G network. None of the file transfer programs work with this phone, and 4G doesn't work with this phone. I will probably have enough of it by the end of the week, return it, and spring for a Galaxy S4. It's a real disappointment, I'd really been looking forward to the LG G2...all for nothing.
    11-12-2013 04:56 PM
43 12

Similar Threads

  1. Help to delete multiple sms / text messages at one time
    By dpoverlord in forum Samsung Galaxy Note 3
    Replies: 20
    Last Post: 10-09-2015, 09:33 AM
  2. S4 Verizon all of my contacts don't show up in sms list
    By brianmac1 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 11-27-2013, 01:32 PM
  3. Just ordered a few questions....
    By prissysox in forum Moto X (2013)
    Replies: 11
    Last Post: 11-15-2013, 05:01 PM
  4. Replies: 20
    Last Post: 11-10-2013, 10:39 AM
  5. 4.3 Update for Wifi-Only Galaxy Note 8.0?
    By rkeenan in forum Samsung Galaxy Note 8.0
    Replies: 1
    Last Post: 11-09-2013, 11:03 AM
LINK TO POST COPIED TO CLIPBOARD