1. systemind's Avatar
    Does anyone have problems with the phone switching from a 3G area to LTE? my phone almost always stays in 3G and to grab the LTE signal Ive to turn airplane mode off and on. My wife's iPhone 5s also in Sprint switches automatically my network mode is in LTE/CMDA
    03-18-2014 10:54 AM
  2. lizardking13's Avatar
    Does anyone have problems with the phone switching from a 3G area to LTE? my phone almost always stays in 3G and to grab the LTE signal Ive to turn airplane mode off and on. My wife's iPhone 5s also in Sprint switches automatically my network mode is in LTE/CMDA
    You can force your phone to stay in 3G if you'd like. Change the network mode to CDMA only. Then you won't get the switching. What I do is keep my phone in CDMA mode while I'm at home(because of wifi) and whenever I leave, I switch it back to LTE/CDMA and I generally get 4G coverage.

    If 4G coverage in your area is sparse, then you will get the constant switching and there isn't much that can be done about it aside from being patient and hoping sprint improves your area sooner rather than later. Also, 4G still struggles in a lot of buildings, so if you're outdoors you shouldn't get the switching quite as often.
    Marcus Mcgee likes this.
    03-18-2014 11:00 AM
  3. cwise2222's Avatar
    It's bit of a known issue with the G2 since the Spark update. My phone never connected to LTE after the Spark update. I got a PRL update a little over a week ago and it started to connect better but I still can't get LTE in all the places I could before I got the Spark update. Hopefully KitKat will fix the issue since that is likely why its taking so long to get it out.
    Jimmy Gillentine likes this.
    03-18-2014 03:54 PM
  4. qz0xr3's Avatar
    Live in the DFW metroplex and bought three G2s a couple of weeks ago and initially everything was great. Now, two of the phones are experiencing issues where you can't receive a call if the network selected is anything other than CDMA. The third phone works fine on the Global network setting. Irritating that I can't access LTE or Spark on two of the three phones. Seriously thinking of switching carriers.
    03-21-2014 01:45 PM
  5. DWR_31's Avatar
    Factory data reset will clear the problem right up. The third day I had my G2 I had the same issue.
    Use the LG backup app first.

    Sent from my SPARK enabled Sprint LG G2. K00949438Yd FRAMILY!
    qz0xr3 likes this.
    03-21-2014 01:59 PM
  6. qz0xr3's Avatar
    Factory data reset will clear the problem right up. The third day I had my G2 I had the same issue.
    Use the LG backup app first.

    Sent from my SPARK enabled Sprint LG G2. K00949438Yd FRAMILY!
    Good looking out. I'll give that a shot.
    03-21-2014 07:38 PM
  7. shawnvb's Avatar
    My issue is a little different, but I'll post it here anyways as to not make a new thread.

    In the last couple days, my phone has had a really bad signal and also bad 3g connection even when I am just sitting at home, where I used to get fine service. Has anyone else been experiencing issues with this? None of my family members are having this problem (they also have different phones, though)
    03-23-2014 08:07 PM
  8. DWR_31's Avatar
    My issue is a little different, but I'll post it here anyways as to not make a new thread.

    In the last couple days, my phone has had a really bad signal and also bad 3g connection even when I am just sitting at home, where I used to get fine service. Has anyone else been experiencing issues with this? None of my family members are having this problem (they also have different phones, though)
    Settings >System Update >Update PRL.

    Then update Profile.

    Sent from my SPARK enabled Sprint LG G2. K00949438Yd FRAMILY!
    03-27-2014 02:54 PM
  9. dr_occam's Avatar
    Settings >System Update >Update PRL.

    Then update Profile.

    Sent from my SPARK enabled Sprint LG G2. K00949438Yd FRAMILY!
    I've had the same issue since the spark update. Sprint rep told me to do this even though I had already done it and had me reboot the phone but it didn't fix anything.

    Sent from my LG G2 using Tapatalk
    03-27-2014 03:34 PM
  10. DWR_31's Avatar
    I've had the same issue since the spark update. Sprint rep told me to do this even though I had already done it and had me reboot the phone but it didn't fix anything.

    Sent from my LG G2 using Tapatalk
    Hold tight. They're enabling multiple towers in your area. I have experience with good, bad, good LTE signal.

    Posted via my SPARK enabled Sprint LG G2, K00949438Yd FRAMILY!
    03-27-2014 04:01 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-29-2014, 12:52 PM
  2. AT&T Note 3: Ready to buy! Just a bit nervous.
    By billmunson in forum AT&T Samsung Galaxy Note 3
    Replies: 24
    Last Post: 03-27-2014, 04:26 PM
  3. Moving from iPhone to Galaxy S4
    By o2bnclemson in forum Samsung Galaxy S4
    Replies: 7
    Last Post: 03-24-2014, 05:10 PM
  4. Can't connect to google account from phone
    By OG_Swifty in forum General Help and How To
    Replies: 5
    Last Post: 03-18-2014, 01:19 PM
  5. 8hr after factory reset, all user files are back? from where?
    By WilfulTravesty in forum AT&T Galaxy S II
    Replies: 2
    Last Post: 03-18-2014, 10:19 AM
LINK TO POST COPIED TO CLIPBOARD