1. Mayem007's Avatar
    My Nexus S 4G's power button does not work. It acts as if its being pressed all of the time. For example when i turn off my phone it turns back on instantly as if the power button is being pressed. I have clockworkmod installed with Beezy's ICS Port and i can't even navigate clockworkmod with and unresponsive power button.

    How can i fix this?
    11-24-2011 10:35 PM
  2. opteron7's Avatar
    It sounds like you have a stuck po button.

    Sent from my Nexus S 4G using Tapatalk
    11-25-2011 12:18 PM
  3. Mayem007's Avatar
    I took apart my nexus and made sure there was nothing physically wrong with the switch. It seems as if there was a short somewhere? However, i kind of have a feeling its software based because of how randomly it happened.
    11-25-2011 03:01 PM
  4. iBowToAndroid's Avatar
    I took apart my nexus and made sure there was nothing physically wrong with the switch. It seems as if there was a short somewhere? However, i kind of have a feeling its software based because of how randomly it happened.
    Only 1 way to know - go back to stock and see if it still happens. You'll need to be stock anyways if it has to be replaced.
    11-27-2011 11:09 PM
  5. Mayem007's Avatar
    I cant flash back to stock because i need the power button to navigate clockworkmod.
    11-27-2011 11:10 PM
  6. iBowToAndroid's Avatar
    I cant flash back to stock because i need the power button to navigate clockworkmod.
    le sigh. n00b. Lol jk.

    You can fastboot flash everything you need through the bootloader.
    11-27-2011 11:14 PM
LINK TO POST COPIED TO CLIPBOARD