1. j_grouchy's Avatar
    Nearly every time I click a link in an app or tap a command that calls for a browser action, I get the pop-up for selecting which browser I want to use. Every single time, I check the box saying "use this as a default". It doesn't happen every time. It seems to remember my default for a little while...but then after some unknown limit (time or instances, perhaps), the pop-up returns. I can't seem to make my default selection "stick". Anyone else get this? Aside from checking the box, is there anything I can do?

    (and no, I'm not rooted)
    01-03-2012 12:38 PM
  2. Paul627g's Avatar
    If you have a second browser installed go into manage apps and find your second browser and make sure you have the clear defaults selected...



    Sent from my Nexus S 4G using Tapatalk
    01-03-2012 01:34 PM
  3. MacGuyInNC's Avatar
    Nearly every time I click a link in an app or tap a command that calls for a browser action, I get the pop-up for selecting which browser I want to use. Every single time, I check the box saying "use this as a default". It doesn't happen every time. It seems to remember my default for a little while...but then after some unknown limit (time or instances, perhaps), the pop-up returns. I can't seem to make my default selection "stick". Anyone else get this? Aside from checking the box, is there anything I can do?

    (and no, I'm not rooted)
    I'm going to take a guess and say that whatever browser you're using has received an update just before this happens.

    The simplest that I can explain it is that anytime you update an app, the OS no longer knows that the updated app is still the same as the old one. It replaces that app with the newer version.

    So when you click on a link (say, in a text message or in an email), it once again needs to know which app should be the default.

    That's one of the annoying things about Android.
    01-03-2012 07:46 PM
  4. skinneejay's Avatar
    Mine does this all the time. ( Still on Gingerbread) I think it has something to do with the software.
    Doesn't matter how many times I hit it it doesn't stick. It pisses me off. lol
    01-03-2012 07:55 PM
  5. j_grouchy's Avatar
    I'm going to take a guess and say that whatever browser you're using has received an update just before this happens.

    The simplest that I can explain it is that anytime you update an app, the OS no longer knows that the updated app is still the same as the old one. It replaces that app with the newer version.

    So when you click on a link (say, in a text message or in an email), it once again needs to know which app should be the default.

    That's one of the annoying things about Android.
    Nah...this is a daily occurrence. The updates don't come that often.
    01-05-2012 12:29 PM
  6. MacGuyInNC's Avatar
    Nah...this is a daily occurrence. The updates don't come that often.
    Hmm... Well, then you might want to clear out your defaults. Go into Settings, then Applications, then Manage Applications, then find the application you're looking for. After clicking on it, find where it says "Launch by default."

    Does that button show up? Can you press it? If so, please do and let us know how that works out for you.
    01-05-2012 01:51 PM
  7. j_grouchy's Avatar
    been there, done that.
    01-05-2012 03:08 PM
  8. skinneejay's Avatar
    Question for you grouchy. I haven't tried this yet but I'm wondering if this is the problem. For the app you are trying to make default. Is it located on the "card memory" or the internal memory? I know some apps widgets won't work if its not installed on the phone.
    01-06-2012 08:56 AM
  9. Lanny84's Avatar
    Nearly every time I click a link in an app or tap a command that calls for a browser action, I get the pop-up for selecting which browser I want to use. Every single time, I check the box saying "use this as a default". It doesn't happen every time. It seems to remember my default for a little while...but then after some unknown limit (time or instances, perhaps), the pop-up returns. I can't seem to make my default selection "stick". Anyone else get this? Aside from checking the box, is there anything I can do?

    (and no, I'm not rooted)
    I have the same issue. I use Dolphin browser. The default will stick properly when I select it, until I restart the phone. It must be a glitch in software (perhaps on the developer's end).

    Which browser are you trying to use as a default?
    01-06-2012 09:08 AM
  10. j_grouchy's Avatar
    I have the same issue. I use Dolphin browser. The default will stick properly when I select it, until I restart the phone. It must be a glitch in software (perhaps on the developer's end).

    Which browser are you trying to use as a default?
    Opera
    01-06-2012 09:10 AM
  11. ijames#AC's Avatar
    Tags: "default browser popup" "default browser selector" "default browser chooser" "samsung epic 4g" "epic 4g default browser"

    Is there no solution for this? This is NOT a simple or obvious problem. It requires somebody with deep knowledge of how the default is set and probably fixing some messed up permissions?

    I have the original browser, dolphin, and firefox, and "Phone 2 Chrome" which sometimes acts like a browser...

    So, if I'm on Facebook and I click a link, sometimes I'll get the browser chooser menu four or five times as the all the redirect links from link trackers and advertisers hit. FOUR OR FIVE TIMES!!! I am continuously hitting this box.

    This happens whether I clear the defaults through Settings > Applications > "clear defaults", or if I specify a default via the checkbox.

    But sometimes rarely, it doesn't happen.

    Something is definitely needing to be reset at a deep level, or there is some sort of permission problem preventing this from working right!

    This has been happening since I received a replacement Epic 4g from Sprint.

    Firmware 2.3.6
    Kernel 2.6.35.7
    GINGERBREAD.EL30
    Hardware D700.0.5

    Any solutions????

    Thanks mucho!!!
    03-17-2012 12:09 PM
LINK TO POST COPIED TO CLIPBOARD