Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
Like Tree1Likes
  • 1 Post By DavidABurton
  1. Thread Author  Thread Author    #1  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default How come contacts on my phone don't show up in gmail?

    I bought a new Photon 4g and had the store transfer my old Palm Pre contacts (189 contacts). That worked fine other than some formatting problems and lost notes. But when I added my gmail account to the Photon all hell broke loose.

    Most, but not all of my contacts were doubled on my phone to 349 total. But even the doubles didn't make sense. Some were identical doubles and some were partial contacts. My gmail contacts were unchanged at 189, there was no problem there. I had no choice but to go through every contact on my phone and manually delete/correct them.

    When I was done I was left with the original 189 contacts on my phone. I thought everything was fine until I got on my computer to send a few emails. I found out most of my contacts had been completely and totally deleted in gmail! I now have 189 contacts in perfect condition on my phone, but only 56 contacts in gmail. WTF!!!!!

    So I've searched all the threads pertaining to this problem on Android Central and have had no luck finding out how to fix this. It appears all my settings are correct and I've manually sync'd several times with no luck.

    I'm at the point were my only solution seems to be that I have to manually type 133 contacts back into gmail by hand. That would really suck.

    Am I missing something? Is there an easier way? And why do my phone contacts refuse to appear in gmail? I'm afraid if I make any changes to contacts on my phone they won't change in gmail and I'll have to remember to enter the changes manually in gmail too.

    Any help would be greatly appreciated. Thanks!
  2. #2  
    statdoc's Avatar

    Posts
    115 Posts
    Global Posts
    118 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Contacts/Settings/Contact Storage. Make sure Google is selected as the place to store new contacts.
  3. Thread Author  Thread Author    #3  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by statdoc View Post
    Contacts/Settings/Contact Storage. Make sure Google is selected as the place to store new contacts.
    It's been set that way from the start with no luck. Thanks for the suggestion though.
  4. #4  

    Default Re: How come contacts on my phone don't show up in gmail?

    on your phone: go to contacts and hit menu > export contacts. Copy the CSV file created from the sd card onto computer.

    on your computer: Log into gmail in browser. Select the word "mail" with drop down arrow (above compose). Select contacts. Select import. Import CSV file from above.
    [CENTER][URL="https://plus.google.com/u/0/+KPSmith/posts"]Follow me on Google +
  5. #5  

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by k1dude View Post
    I bought a new Photon 4g and had the store transfer my old Palm Pre contacts (189 contacts). That worked fine other than some formatting problems and lost notes. But when I added my gmail account to the Photon all hell broke loose.

    Most, but not all of my contacts were doubled on my phone to 349 total. But even the doubles didn't make sense. Some were identical doubles and some were partial contacts. My gmail contacts were unchanged at 189, there was no problem there. I had no choice but to go through every contact on my phone and manually delete/correct them.

    When I was done I was left with the original 189 contacts on my phone. I thought everything was fine until I got on my computer to send a few emails. I found out most of my contacts had been completely and totally deleted in gmail! I now have 189 contacts in perfect condition on my phone, but only 56 contacts in gmail. WTF!!!!!

    So I've searched all the threads pertaining to this problem on Android Central and have had no luck finding out how to fix this. It appears all my settings are correct and I've manually sync'd several times with no luck.

    I'm at the point were my only solution seems to be that I have to manually type 133 contacts back into gmail by hand. That would really suck.

    Am I missing something? Is there an easier way? And why do my phone contacts refuse to appear in gmail? I'm afraid if I make any changes to contacts on my phone they won't change in gmail and I'll have to remember to enter the changes manually in gmail too.

    Any help would be greatly appreciated. Thanks!
    I feel your pain
    I have and had the same problem.
    If you take your Pre to Sprint they will move all you contacts and numbers over but that still does not explain why gmail does not save them. If you look at your contacts you will see that your missing 133 are now motorola contacts
  6. Thread Author  Thread Author    #6  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by KSmithInNY View Post
    on your phone: go to contacts and hit menu > export contacts. Copy the CSV file created from the sd card onto computer.

    on your computer: Log into gmail in browser. Select the word "mail" with drop down arrow (above compose). Select contacts. Select import. Import CSV file from above.
    Thanks for the suggestions, but it turned out to be a disaster.

    I moved all my phone contacts to gmail contacts. That worked. But, it turns out that it moved all "Other Contacts" into "My Contacts". I now have 234 total contacts on gmail. I thought no big deal, I can handle that. Then, I looked at my phone and it DOUBLED my contacts AGAIN!!! Some were even TRIPLED!!! And others that were there before are now missing. WTF!!! I now have 356 phone contacts.

    Now I'm afraid if I delete the doubles and triples out of my phone, it'll wipe out most of the contacts again in gmail. It's a vicious circle that keeps getting worse with each solution I try.
  7. Thread Author  Thread Author    #7  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by ronald600 View Post
    I feel your pain
    I have and had the same problem.
    If you take your Pre to Sprint they will move all you contacts and numbers over but that still does not explain why gmail does not save them. If you look at your contacts you will see that your missing 133 are now motorola contacts
    What has been your solution to this point? It appears the only solution is to add, delete, and change contacts ONLY in gmail. What good is that if you aren't near a computer when someone gives you a change or new contact? Not only do you have to make the change in your phone, but you now have to remember to make the same change on a computer the next time you're in front of one. That's ridiculous.
  8. #8  
    kusanagi-sama's Avatar

    Posts
    76 Posts
    ROM
    Stock 2.3.4 Android ROM

    Default Re: How come contacts on my phone don't show up in gmail?

    I learned to ONLY use Google to store and sync contacts and never export to/import from a file. Also, I make sure all types of contacts are shown.
  9. #9  
    Dreamliner330's Avatar

    Posts
    1,032 Posts
    Global Posts
    1,038 Global Posts
    ROM
    100% AOSP/AOKP wanted.

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by KSmithInNY View Post
    on your computer: Log into gmail in browser. Select the word "mail" with drop down arrow (above compose). Select contacts.
    I seriously couldn't find the contacts link the other day...so confusing!

    Quote Originally Posted by kusanagi-sama View Post
    I learned to ONLY use Google to store and sync contacts and never export to/import from a file. Also, I make sure all types of contacts are shown.
    +1.

    Always use Google, NEVER 'phone' or anything else. Solves MANY problems.
  10. #10  
    mk3
    mk3 is offline
    mk3's Avatar

    Posts
    47 Posts
    Global Posts
    622 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Sucks man. I had a similar situation. I had three contact sources: Palm Pre contacts, gmail and exchange work account. Everything work fine on my Palm Pre, never had a single issue with contacts getting mixed up or confused. Then I "upgraded" to the Photon. From day one I started having issues where it seemed confusing to me what the heck the phone was doing with the contacts and how to tell each account apart. One big problem was whne I would edit or create a contact on the phone it would not sync them back up to my exchange acount. WFT? SO somewhere here on A.C. (not this thread) I read to back up my contacts to a csv file and import them. HUGE MISTAKE! I chose to import the new contacts I created (I think they were considered Motorola contacts) to my exchange acount from the phone. I did this on a Friday afternoon and by Monday morning when I logged into Outlook I noticed I had over 10,000 contacts. Originally I had about 300 or so. As I observed it kept multipling my contacts every so often adding an additional 300 to the exchange acount. I called my company IT support and was told there are known Motorola to exchange defects/bugs especially in the area of contacts and that I should have gotten "anything other than a Motorola phone." I called Motorola support and got the run around with a level-1 suppoort guy for an hour trying this and that until I gave up.

    End outcome? I manage all my contacts from Outlook on my computer and sync them down to my "smartphone." What a PITA! Last and only Motorola phone for me.
    "Abracadabra Holmes"
    -Cal Naughton, Jr.
  11. #11  
    Wayne173's Avatar

    Posts
    67 Posts
    Global Posts
    329 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Have you tried joining the contacts. It was a little tricky to find how to do it but once you find it then the contacts can befire joined together regardlesas the source...ie msn, yahoo, aol. Choose the default main contact number. Then sync it with google and all is sync. I do still have issues with outlook contacts and facebook. Those issues are that since Android doesn't narratively sync with these types of accounts that any changes made through outlook or facebook dont transfer over and vise versa. The only way ive found to fix or get the updated info is to split the contact....ie facebook info. Then it will update.....then rejoin it. Yes PITA but once done its all in gmail contacts.
  12. Thread Author  Thread Author    #12  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by Wayne173 View Post
    Have you tried joining the contacts. It was a little tricky to find how to do it but once you find it then the contacts can befire joined together regardlesas the source...ie msn, yahoo, aol. Choose the default main contact number. Then sync it with google and all is sync. I do still have issues with outlook contacts and facebook. Those issues are that since Android doesn't narratively sync with these types of accounts that any changes made through outlook or facebook dont transfer over and vise versa. The only way ive found to fix or get the updated info is to split the contact....ie facebook info. Then it will update.....then rejoin it. Yes PITA but once done its all in gmail contacts.
    There's no way that I know of "joining" or 'merging' the contacts in the Photon. My contacts aren't duplicated currently in Gmail because I've already merged them. There are only duplicates on my phone.

    And I'm fearful of deleting the duplicates in my phone because the last time I did that they also deleted the same contacts from Gmail.
  13. #13  
    statdoc's Avatar

    Posts
    115 Posts
    Global Posts
    118 Global Posts

    Default

    http://forums.androidcentral.com/sho....php?p=1192132

    Try this.


    Sent from my phone on Tapatalk. Please excuse typos!
    Thanked by:
    k1dude 
  14. #14  
    Wayne173's Avatar

    Posts
    67 Posts
    Global Posts
    329 Global Posts

    Default

    Quote Originally Posted by k1dude View Post
    There's no way that I know of "joining" or 'merging' the contacts in the Photon. My contacts aren't duplicated currently in Gmail because I've already merged them. There are only duplicates on my phone.

    And I'm fearful of deleting the duplicates in my phone because the last time I did that they also deleted the same contacts from Gmail.

    While in contacts tap and hold the contact. Menu will pop up ....tap edit. Once there ....tap the menu button (capacitive button bottom left ). You will see a symbol that says join. Tap it.....it will give you what it thinks you want. If those choices are what you dont need tap in all contacts and scroll through to desired contact. Tap it an hit save.....done. Also a hint.....when joining the contacts the one you choose first to join will carry the contact name. For example .....if you have two contacts ...one Fred Jones and the other Fred Man Jones .....which are the same people. If you tap and hold on Fred Jones first and join the Fred Man Jones the contact will be labeled Fred Jones.
    Thanked by:
    k1dude 
  15. Thread Author  Thread Author    #15  
    k1dude's Avatar

    Posts
    16 Posts
    Global Posts
    74 Global Posts

    Default Re: How come contacts on my phone don't show up in gmail?

    Thanks Statdoc and Wayne173.

    I decided to use Wayne173's suggestion even though it's far more time consuming. If it didn't work, I was going to use Statdoc's nuclear option. But since Wayne173's technique worked, I just stuck to doing each entry by hand. It was a pain, but it worked.

    Thank you both!
  16. #16  
    kusanagi-sama's Avatar

    Posts
    76 Posts
    ROM
    Stock 2.3.4 Android ROM

    Default Re: How come contacts on my phone don't show up in gmail?

    Here's something similar. If you have an android phone, you have a Google account. Go here: https://www.google.com/contacts_v2/#contacts You can add, remove and edit contacts here. Have your phone sync your contacts with your Google account and nothing else, do not try to import contacts from a file (My LG Optimus S had the same problem with multiple contacts trying to sync from a file)

    Also: https://www.google.com/dashboard/ (basically every account you have on Google in one convenient place)
  17. #17  

    Default Re: How come contacts on my phone don't show up in gmail?

    statdoc said, "Contacts/Settings/Contact Storage. Make sure Google is selected as the place to store new contacts."

    There's no "Contact Storage" setting on my phone (Moto Defy XT557D, Republic Wireless Android 2.3.7). Settings has only six options:

    [Search] [New Contact] [Display Options]
    [Accounts] [Import/Export] [Delete contacts]

    Under [Accounts] there's only one account, shown as my gmail address. It also says "Sync is ON."

    It is VERY annoying that it seems to pick some contacts at random, and put them in phone-only storage, and there's apparently no way to move them back to the normal, sync'd storage! I don't want ANYTHING in "phone-only storage." The whole point of sync-ing with gmail contacts is so that ALL of the same contacts are in both places.

    I've done the export-to-SD and re-import trick, and it seems to have increased the number of contacts, but I still find some contacts in "phone only storage." Those contacts are NOT visible on the gmail contacts page.

    HOW can I get this stupid thing to work?
    Aija Elmere likes this.
  18. #18  

    Default Re: How come contacts on my phone don't show up in gmail?

    Wayne173 says, "You will see a symbol that says join. Tap it.....it will give you what it thinks you want. If those choices are what you dont need tap in all contacts and scroll through to desired contact. ..."

    Unfortunately, that usually doesn't work, for either of two reasons:

    1. The stupid Contacts manager hides most of my contacts. You can't scroll to them because they don't appear in the contact list. The only way to find them is to search for them and then when they aren't found touch "Search for all contacts" -- and that option isn't available for "join."

    2. "Join" only makes sense if there's already another contact for the same person. I might not want to "join" this "phone-only" contact with some other contact, I might just want it to show up in gmail contacts.

    Of course, "search for all contacts" doesn't really mean "search for all contacts," it means "search through all contacts" for the name that I just entered.

    It's amazing to me how buggy this stuff is, with millions of people using it!

    I just want ALL my contacts to appear in the contacts list, on both the phone and on gmail contacts. That shouldn't be hard!
  19. #19  

    Default Re: How come contacts on my phone don't show up in gmail?

    Quote Originally Posted by DavidABurton View Post
    statdoc said, "Contacts/Settings/Contact Storage. Make sure Google is selected as the place to store new contacts."

    There's no "Contact Storage" setting on my phone (Moto Defy XT557D, Republic Wireless Android 2.3.7). Settings has only six options:

    [Search] [New Contact] [Display Options]
    [Accounts] [Import/Export] [Delete contacts]

    Under [Accounts] there's only one account, shown as my gmail address. It also says "Sync is ON."

    It is VERY annoying that it seems to pick some contacts at random, and put them in phone-only storage, and there's apparently no way to move them back to the normal, sync'd storage! I don't want ANYTHING in "phone-only storage." The whole point of sync-ing with gmail contacts is so that ALL of the same contacts are in both places.

    I've done the export-to-SD and re-import trick, and it seems to have increased the number of contacts, but I still find some contacts in "phone only storage." Those contacts are NOT visible on the gmail contacts page.

    HOW can I get this stupid thing to work?
    I completely agree with this post and seem to have exactly the same situation (the phone is LG-P500 Android 2.3.3).

    Is there no way to move a contact to gmail from phone storage at least manually?

    P.S. OK, I got the manual export/import way. I went to the Settings -> Display Options and unchecked the Google contacts to be displayed leaving only phone and SIM contacts. Then I opened the contacts list, Settings -> Import/Export -> Export to SD card, again settings, select all contacts and export. Then I went back to Settings -> Display Options and unchecked phone and SIM contacts and checked Google contacts (probably unnecessary, just telling what I did). And then Settings -> Import and chose Google contacts to import to. Now I'm thinking maybe to delete the Phone contacts completely.

    In order to create a new contact in the Google phonebook, when creating a new contact, at the very top (above name and surname fields) you must select the type of contact, which by default is Phone (even if I've disabled Phone and SIM in the display settings).

Posting Permissions