Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By mobdad
  1. Thread Author  Thread Author    #1  

    Default Sprint Galaxy Note 3 - 3G speeds not what they should be

    Hello, today I turned on my Note3 from sprint, and I noticed it took 40secs-1minute to display 3g service in an area where i usually always have 3g. I shrugged that off and ran a speedtest and it was absolutely horrid. My ping was 600-900 throughout the tests and .05-.3mbps download where usually I'm getting .8-1.2 here.. I have restarted my phone, took the battery out, tried airplane mode and nothing seemed to help. Does anyone have any thoughts/fixes to this problem? Any advice would be greatly appreciated. Thank you
  2. #2  
    Golfdriver97's Avatar

    Posts
    13,547 Posts
    Global Posts
    13,822 Global Posts
    ROM
    Stock Moto X

    Default Re: 3G speeds not what they should be

    Quote Originally Posted by Logan Leffeler View Post
    Hello, today I turned on my Note3 from sprint, and I noticed it took 40secs-1minute to display 3g service in an area where i usually always have 3g. I shrugged that off and ran a speedtest and it was absolutely horrid. My ping was 600-900 throughout the tests and .05-.3mbps download where usually I'm getting .8-1.2 here.. I have restarted my phone, took the battery out, tried airplane mode and nothing seemed to help. Does anyone have any thoughts/fixes to this problem? Any advice would be greatly appreciated. Thank you
    Welcome to the forums.
    In Settings>Update device do you have an option for update PRL and Profile? Try those and see if it helps.

    Devices: Current: Nexus 5, Moto X, Galaxy Tab 2 (7.0); Retired: Galaxy S2 (Epic 4G Touch); Traded: Galaxy S3
    When I let go of what I am, I become what I might be - Lao Tzu
    Community Guidelines and also here
  3. #3  
    mobdad's Avatar

    Posts
    235 Posts
    ROM
    LIH Jelly Bean Leak

    Default Re: 3G speeds not what they should be

    Quote Originally Posted by Logan Leffeler View Post
    Hello, today I turned on my Note3 from sprint, and I noticed it took 40secs-1minute to display 3g service in an area where i usually always have 3g. I shrugged that off and ran a speedtest and it was absolutely horrid. My ping was 600-900 throughout the tests and .05-.3mbps download where usually I'm getting .8-1.2 here.. I have restarted my phone, took the battery out, tried airplane mode and nothing seemed to help. Does anyone have any thoughts/fixes to this problem? Any advice would be greatly appreciated. Thank you
    I agree with the previous poster about updating the PRL. Also, sometimes Sprint is doing work on a tower which could cause poor 3G or LTE performance temporarily. You might find the problem gone soon. Fortunately for me, I am usually in an area where Wifi is available. Of course always use Wifi when available. Good luck.
    HTC Touch2 -> Palm Pre -> HTC Evo4G -> Samsung Epic 4G Touch -> Samsung Galaxy S3 -> Samsung Galaxy Note 3
    Golfdriver97 likes this.

Posting Permissions

B