Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  

    Default S4 won't let me play videos...

    Say I'm on facebook or twitter and try to watch a video someone posts, it will bring up a black screen with a circle which looks like it's loading but then after about 20 seconds of "loading," it'll say "Can't play this video." Anybody else having this problem or know how to fix it?
  2. #2  

    Default Re: S4 won't let me play videos...

    Clear your cache and cookies and try again
  3. #3  

    Default Re: S4 won't let me play videos...

    Try mx player

    Sent from my VS980 4G using Tapatalk 2
  4. Thread Author  Thread Author    #4  

    Default Re: S4 won't let me play videos...

    Is this an app? I should have specified. It's whenever I'm going into the sites on the apps like the Facebook app and Tweetcaster...
  5. #5  

    Default Re: S4 won't let me play videos...

    Quote Originally Posted by kcarolina View Post
    Is this an app? I should have specified. It's whenever I'm going into the sites on the apps like the Facebook app and Tweetcaster...
    MX player is an app. I've found that videos that aren't playable (like from fb sometimes) can be played when played through MX. There's a free one :-)

    Sent from my VS980 4G using Tapatalk 2
  6. #6  

    Default Re: S4 won't let me play videos...

    Your phone needs un update
    Settings, more, update all in the list.
    Enjoy.
  7. #7  

    Default Re: S4 won't let me play videos...

    Quote Originally Posted by kcarolina View Post
    Say I'm on facebook or twitter and try to watch a video someone posts, it will bring up a black screen with a circle which looks like it's loading but then after about 20 seconds of "loading," it'll say "Can't play this video." Anybody else having this problem or know how to fix it?
    I had the same problem it is fixed by updating your software. In home screen go to
    Settings, more, updates
    And update all in the list.

    If it works send me a buck by pay pal
    Lol
    Eddie
  8. #8  

    Default Re: S4 won't let me play videos...

    I'm having the same problem. I tried going to settings then more, but I can't find an update all. Any suggestions?
  9. #9  
    lasercomp's Avatar

    Posts
    23 Posts
    Global Posts
    89 Global Posts

    Default Re: S4 won't let me play videos...

    I'm having same issue. Someone mentioned to clear cache and cookies. Please explain how to do that. I need to restart my phone for videos to work again. I'm still on 4.3. Thank you

    Posted via Android Central App
  10. #10  

    Default Re: S4 won't let me play videos...

    To clear the case turn the phone off and then turn it on holding the power key, home button, and volume up button. You should see the in the top left corner recovery booting in blue. Once you see this let go of the power key. Use the volume up and volume down keys to scroll To Wipe cache partition. after this reboot the phone. This will not delete any of your personal data.

Similar Threads

  1. Chromecast / Google Play Movies / DD 5.1
    By s4ndst0rm in forum Google Chromecast
    Replies: 4
    Last Post: 12-03-2013, 09:36 AM
  2. S4 low storage after Play Edition install
    By barrygoddard in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 09-25-2013, 08:36 PM
  3. Galaxy s4 Music Lockscreen Sound Glitch!
    By loganixon in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-25-2013, 06:56 AM
  4. Galaxy S4 security update.
    By Lee Brady in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-25-2013, 04:24 AM
  5. andriod 4.3 on galaxy s4
    By cachun402 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-25-2013, 04:22 AM

Posting Permissions