Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default wifi tether no longer works post 4.5.141 update (after re-root)

    had root w/wifi tether prior to running 4.5.141. Ran it under "HTC Desire (GSM)" profile with "WEXT (ad-hoc)" as the setup method. Well then i ran update accidentally (got click happy) lost root and thus wifi tether. Re-rooted and it seems to be working well. Wifi tether launches and broadcasts the signal. However, i can't get my asus transformer or any of several PC's to connect to the wifi signal.

    Anyone got any bright ideas how to get wifi tether to work accordingly again?
  2. #2  

    Default Re: wifi tether no longer works post 4.5.141 update (after re-roo

    Try this method, works for me:

    [MOD] Enable Tethering on 4.5.91 [Archive] - xda-developers

    9th July 2011, 01:50 AM
    Been Busy building, but thought id quickly help those of us that can not live with out mobile hotspot and decided to upgrade to 4.5.91. Here is the easiest way....

    * prerequisites*
    1. Root
    2. SQlite editor from market


    1. open SQlite editor and scroll to Settings Storage (com.motorola.android.provider.settings
    2. click settings.db
    3. click settings
    4. go to Line 156 labled Entitlement Check with a value of 1 *EDIT* People are reporting different line numbers based off build etc, JUST Find "entitlement check"
    5. Change value from 1 to "disabled" (without quotes)
    6. reboot
    7. enjoy
    DocToddMartin likes this.
  3. Thread Author  Thread Author    #3  

    Default Re: wifi tether no longer works post 4.5.141 update (after re-roo

    Well, the good news is that i got it back up and running by updating the app to 3.11 beta (not sure if it was necessary) then had to clean the app2sd cache. I think the cache cleaning is what really did the job.

    It now works fine for my PC laptops. However, my newly ICS updated transformer no longer can connect. So i think my original problem was actually two (one on the phone and one on the transformer). However, now it just seems to be an ICS issue. I've found some reports of similar issues when their ICS transformer can't wifi tether due to ad-hoc / IBSS no longer working for ICS devices.

    TF101 ICS adhoc phone tethering? - Page 4

    In this thread someone recommended setting the wifi tether app to the epic 4g profile and it worked for them. I had partial success here. My tablet now sees the wifi tether as a normal access point, not ad-hoc. It can connet to it too. However, my phone then tries to authorize me via att for USB tether (which i don't have on my account).
  4. #4  
    devito80's Avatar

    39 Posts


    May be the ad hoc setting screwing you up. Try running it Open to see if they pick it up, then run it as WPA & set a password, etc.
    May even try uninstalling the app then reinstall.
  5. #5  

    Default Re: wifi tether no longer works post 4.5.141 update (after re-roo

    best $2 spent for SQlite editor. Don t need any 3rd party apps to tether. did it back on ginger and then again on ICS. as mentioned line # is different but search for entitlement and you should be able to fine the line easily.

    Thanks for the details.

Posting Permissions