1. flipteg's Avatar
    i've used Google Voice exclusively on my Nexus One. i just got an Atrix and i noticed that on the recent calls log, all the numbers that i've called is showing the Google Voice that was used to access the calls. i wanted it to show the number of the person instead just like it did on the Nexus One. can some one please help me out.
    02-23-2011 08:53 AM
  2. wvcadle's Avatar
    Have you found an answer to this problem yet? My phone recently updated to GB and it started doing the same thing.
    12-20-2011 06:01 PM
  3. SteveMW's Avatar
    Check the settings on https://voice.google.com. Go to the Calls "tab" and change the Caller ID (Incoming) setting from "Display Google Voice number" to "Display caller's number."
    01-04-2012 08:20 PM
  4. wvcadle's Avatar
    It's already set to show the caller's number. Again, it's not when people call me. It's when I make outgoing calls to numbers -not- in my contacts list... on these occasions, it shows the GV redirect number instead of the number I actually called.
    01-04-2012 08:44 PM
  5. uncledd's Avatar
    Same problem, just upgraded to GB 2.3.5 and my outgoing calls turned into googlevoice numbers on the log instead of who I called as well. It worked perfectly on Froyo. Any ideas?
    03-08-2012 09:00 PM
  6. dancell's Avatar
    I realize this is an old post, but there's an app in the Play store that fixes this problem: https://play.google.com/store/apps/d...undcallhistory
    01-07-2013 10:10 AM
LINK TO POST COPIED TO CLIPBOARD