Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default Power button issues

    For some reason my power button just stopped working. I've had this phone for over a year.

    This has happened before a couple months back. My phone's power button is just unresponsive. I cannot turn on the screen, and must get someone to text me in order to use my phone. In addition when I want to turn off the screen, the power button still doesn't work. The first time this happened, the problem went away after two or three days.

    It has just happened again. Any idea what I can do?
  2. #2  

    Default Re: Power button issues

    Pop the battery out, put it back and see if it works. I would get ATT to replace it,
  3. #3  
    konazxiii's Avatar

    Posts
    254 Posts
    ROM
    Ultimatum 4.0.3

    Default Re: Power button issues

    I had this happen once just recently...with my 1007 (July 2010) build.

    I ended up carefully taking it apart and gently blowing the dust off of the exterior and interior portions of the button/switch and it has worked just fine since then.
  4. #4  

    Default Re: Power button issues

    where did you get the tools small enough to take it apart? even the little flatheads I have for glasses are too big.
  5. #5  

    Default Re: Power button issues

    Any hardware store has precision tools... I found some at walmart. Watch a captivate disassembly video first before you attempt to open it... The captivate has a tricky "latch" at the top that you need to be careful with.

    Sent from my SGH-I897 using Tapatalk 2

Posting Permissions