Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default 3G and Wifi on simultaneously

    Forgive me if this is obvious, but I'm an Android and data plan newbie. This is the behavior I'm seeing with regards to 3G and Wifi and I'm hoping someone can tell me if it's normal:

    • Got my phone on Thursday and set up Wifi. The 3G symbol stays on, but it seems to be doing all data transfer through Wifi. I know that 3G is used to make calls as well, so I figure it's only going to 3G if I use voice.
    • When I check the phone in the morning, either after charging or just sitting unplugged, I unlock it to find that only Wifi is enabled. (Have not tried to make a call with only Wifi on).
    • I read that enabling Wifi will disable 3G and vice versa, so to check my 3G connection, I disable the Wifi and the 3G symbol comes back on. I reenable Wifi, but the 3G symbol stays on.
    • It's definitely using Wifi for data when both are turned on, so I'm not worried that it's using the wrong data connection.
    • I've verified that my 3G is working properly as well when I'm away from Wifi.


    This is the behavior I've observed in the last 3 days/nights since I got the phone. Does Android turn off 3G if the phone sits for without use for a while to conserve power automatically and that's why I'm seeing only Wifi in the morning?

    Let me know if I need to provide any more information. Thanks!
  2. #2  

    Default

    This is my first Android as well... I see this behavior too when I use the GPS, and I heard it is a bug.

    A work-around that I've seen is to switch to flight mode (hold power), wait 5-10 seconds, and switch off flight mode.
  3. Thread Author  Thread Author    #3  

    Default

    Thanks for the suggestion. After turning it back on I still get both the 3G and Wifi icons. I'm not as worried about it using 3G for data, but I worry if battery life is impacted by having them both on...
  4. #4  

    Default

    One of the services running in the background is keeping the 3g on.I use task killer to stop all but messaging(touchdown) and email. With wifi and 3g enabled at the same time, I then see only one icon at a time.
  5. #5  

    Default

    In the Wifi menu, hit the menu button and go to advanced...change the first option to never...

    This will tell the wifi to never switch to 3g for data usage.....the default is for the phone to switch to 3g when the screen turns off
  6. #6  
    rob989_69's Avatar

    Posts
    32 Posts
    Global Posts
    57 Global Posts

    Default

    Quote Originally Posted by Simba501 View Post
    In the Wifi menu, hit the menu button and go to advanced...change the first option to never...

    This will tell the wifi to never switch to 3g for data usage.....the default is for the phone to switch to 3g when the screen turns off
    That just tells wifi not to turn off when the phone locks. It will still use wifi/3g simultaneously sometimes. It's most likely a background task doing it. I've never really been too concerned.

Posting Permissions