1. tnfan's Avatar
    After reading previous threads about Mass Storage setup I still am unable to get this to work.

    I am on Windows 7 using a Toshiba Satellite. I have gone to the Samsung site for USB drivers. However, the drivers are only for XP/Vista. Will not load on my Window 7 system. Cannot find drivers for Windows 7.

    I have gone to Settings/Applications/USB and turned on Mass Storage. I connect the cable to the phone and then to laptop. The phone beeps as if going into the charge mode. I do the pull down on the phone but there is no option to connect. The laptop does not recognize the phones storage.

    I have also tried this on an Windows XP laptop and have the same issue. Not sure what the problem is but I am sure I am just missing something simple.

    Thanks in advance for any assistance.
    08-25-2010 11:34 AM
  2. tnfan's Avatar
    Tried a new cable and now got connected. However I do not have the drivers for Windows 7. Cannot seem to locate via internet search. Can anyone point me to a site where I can get the drivers? Thanks!
    08-25-2010 12:06 PM
  3. dmnall's Avatar
    I am running Windows 7 X64 Ultimate on my laptop and desktop at home, I used the stock Samsung Drivers with no issues!

    Cheers,
    Charlie
    08-25-2010 12:43 PM
  4. tnfan's Avatar
    OK. After now spending several hours yesterday and today I now have it working. I had 2 issues. One I had a bad cable or maybe I should say an incorrect cable! :o My bad on that one!

    Secondly I had installed or tried to install drivers from the Samsung site. After uninstalling and then installing drivers from this site Download Samsung Galaxy S USB Driver for Windows x64 Driver for Windows XP X64 / Windows Vista64 / Windows 7 x64 - Softpedia I finally got connected. Now in the process of syncing my music.

    Here is a link to a site that helped me:
    Captivate USB Drivers Links Here - Android Forums
    08-25-2010 02:23 PM
  5. dmnall's Avatar
    OK. After now spending several hours yesterday and today I now have it working. I had 2 issues. One I had a bad cable or maybe I should say an incorrect cable! :o My bad on that one!

    Secondly I had installed or tried to install drivers from the Samsung site. After uninstalling and then installing drivers from this site Download Samsung Galaxy S USB Driver for Windows x64 Driver for Windows XP X64 / Windows Vista64 / Windows 7 x64 - Softpedia I finally got connected. Now in the process of syncing my music.

    Here is a link to a site that helped me:
    Captivate USB Drivers Links Here - Android Forums
    So which cable were you originally using? I have used regular usb cables with a motorola mini usb to micro-usb adapter with no problems. At home I use OEM samsung microusb but in my car *I use a RIM OEM Charger with a moto adapter and at work I use an OEM RIM cable with the adapter*..

    The drivers worked directly from Samsung with out any issues for my x64 install of win 7 ultimate. I am glad that you did get it working though..

    Cheers,
    Charlie
    08-25-2010 05:43 PM
  6. tnfan's Avatar
    I was originally using cable from extra chargers I purchased from AT&T when I bought the phone. Looks like maybe these are not data cables. They do charge the phone when hooked attached to the PC. But they do not seem to be data capable. The one that actually worked is the original cable that came with the phone. In my research I did notice that several people were reporting issues with the cable. That is why I then made sure I was using the original cable. Now that I have all the music on my external SD I need to find a more robust music application.
    08-25-2010 05:51 PM
LINK TO POST COPIED TO CLIPBOARD