Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  

    Question USB Connection Issues

    I have an issue with my PC not recognizing my Captivate. When I plug in the USB cable to my PC, I can choose to activate USB mode and it prompts me to mount the drive, I say yes but nothing shows up in My Computer. I was able to do all this fine just a few days ago.

    I have uninstalled/reinstalled the drivers. I installed Samsung Kies and it doesn't recognize the phone. I tried my phone on another PC and it won't show up there either. I've factory wiped the phone twice now. I've tried different USB cables as well.

    Is it a problem with the phone or is there something I can do to get this to work?
  2. #2  

    Default

    Where did you get the drivers? I know some people have had problems with the ones listed on the Samsung website. There are confirmed working drivers here.
  3. #3  

    Default

    Try selecting the option for mounting the phone as storage rather than "ask on connect". I suspect that there's a handshake that happens when the USB is initially plugged in, and that is needed by kies to notice the phone.

    Remember also that kies does not officially support captivate (at least it didn't when I installed it).

    If you have debug mode turned on, I'm not sure whether that can cause problems- another thing to try.

    Try a different usb port.

    Are you using the Samsung combined usb / charging cable? Some users have reported issues (can't remember whether that was data or charging) with other brands.

    Regardless, I would not wipe the phone as a solution, drivers / hardware configuration are more likely the problem.

    Hope this helps,

    AoN
  4. Thread Author  Thread Author    #4  

    Default

    Quote Originally Posted by ragnarokx View Post
    Where did you get the drivers? I know some people have had problems with the ones listed on the Samsung website. There are confirmed working drivers here.
    I tried the drivers from the Samsung site and the ones from XDA both aren't working. Thanks for the tip though.
  5. Thread Author  Thread Author    #5  

    Default

    Quote Originally Posted by anneoneamouse View Post

    Regardless, I would not wipe the phone as a solution, drivers / hardware configuration are more likely the problem.

    Hope this helps,

    AoN
    I tried the "ask on connect" option, no dice. I don't have debug mode on. I've tried different USB ports and even a different computer all together. At this point I don't know what else to do because I was able to access my phone through my PC a few days ago.
  6. #6  

    Default

    Try setting it to USB Mass Storage and it should recognize it. You may have to go into your drives on your computer and find the phone.

    I was having an issue with my Mac trying to find my phone but I just set mine to ask when connect and selected mass storage and it worked for me.

    Hope this helps.
  7. #7  

    Default

    What worked for me was to unmount the SD card (the internal one; I don't have an external one yet) and format it and then re-mount it. Then it has connected via usb fine since then. Someone told me that a weirdly named file in a cache for the browser was the problem. This will clear it. I was wondering at the time that I did it about what I might lose like Apps but I lost nothing that I noticed. I am sure that some apps probably use the SD card for history, cache, and maybe even settings but I experienced no problems.
  8. #8  

    Default

    What worked for me finally after trying to connect in mass storage, is to choose kies mode and my PC sees my phone and I can drag & drop etc using windows. With mass storage, the PC sees the device but when clicking on the drive, the PC asks to insert a disk. Really ridiculous
  9. #9  

    Default Re: USB Connection Issues

    Latest Kies update is bad. It won't recognise my Galaxy SIIx or my wife's Galaxy Ace. Both worked fine. A lot of people are having the same issues. There will have to be a new release of Kies
  10. #10  

    Default Re: USB Connection Issues

    Folks, there's nothing wrong with your phones, cables, USB ports or in most cases your drivers either. The problem is entirely the Samsung (Kies) software. After you've tried all of the forums, that is all of the well-intentioned advice from everyone, you'll come to the conclusion that the software does not work. End of story.

    There are people who are using Kies without a problem. I suspect that they're using an older version of Kies or the phones with which they're using it are older

    I have uninstalled (cleaned the Registry) and replaced all of the drivers and software (including updating as well as rolling back .NET Framework 4) repeatedly for the last three-four months. Prior to that, both of my phones connected just fine. Then came the last Kies "update" and it now won't recognize either phone. I have also tried installing nothing but Kies on a "virgin" Windows 7-32, a Windows 7-64 and a Windows XP machine all of which were updated with the latest operating systems and drivers with no anti-virus or firewall active. (I have limitless access to brand new PC's) None of this made any difference. A couple of times I got an initial very slow connect, but Kies hung while trying to read the phones' data or it would connect once and never again. Once connected, it would hang when I tried to back up or sync. The only way that I can transfer files to/from the phones is to tether the phones directly through USB and copy/paste files directly. For that you have to know which files not to touch. But the fact that I could do that proves that there is no USB port, cable or driver issue. If the software (Kies) can't talk through the existing driver(s), it's not the drivers' fault. Besides, I've tried quite a few different drivers...

    My best advice: Wait till the next release of Kies or some other software that will replace Kies

    My conclusion: Samsung makes pretty good electronics, but they (and Bada) completely suck at software

Posting Permissions