Results 1 to 25 of 25
  1. Thread Author  Thread Author    #1  

    Default can not connect to my wireless router

    I just got my note yesterday and today I am trying to get the wifi to connect with my wireless network. I enter in my password and it tries to connect and say its trying to obtain an IP address from the router, but it never does and just disconnects. My other phone connects without any problem, so I dont think its a router issue. Anyone else have this problem?
  2. #2  

    Default Re: can not connect to my wireless router

    Do you need to add your new phone MAC address to the router table? (if you turned that function on)
    Loren
  3. Thread Author  Thread Author    #3  

    Default Re: can not connect to my wireless router

    I dont think so. Never had to do that with my old phone.

    I will have to go somewhere with free wifi and see if I can connect to it there so I can narrow it down between a problem with my phone or a problem with my router.
  4. Thread Author  Thread Author    #4  

    Default Re: can not connect to my wireless router

    looks like I will be taking it back. Went to the mall and they have free wifi, and my phone won't connect there either. Keeps getting stuck on the "obtaining IP address". So tomorrow I will go to AT&T and see if they can fix it, or give me a new one since its just a couple days old.
  5. #5  

    Default Re: can not connect to my wireless router

    I have this problem too..
    If you google it, there's a LOT of threads about it
  6. #6  

    Default Re: can not connect to my wireless router

    i have this issue but ONLY at work. i even put in the right security credentials and nothing. i know its the phone cause my old POS backflip would connect to it with no problem. I seem to think that it might be the phone but it connects to other networks it finds so i'm not sure if its the phone or the network.
  7. #7  

    Default Re: can not connect to my wireless router

    Does the network you are connecting to have spaces or special characters in the ssid.? The reason I ask is I had this problem with my skyrocket when connecting to networks as described above.
  8. #8  

    Default Re: can not connect to my wireless router

    I use:
    Wifi Analyzer


    which requires:

    Wifi Connecter Library


    The apps seem to connect better for some wi-fi hot spots. They seem to wait longer before giving up.

    The links above were generated with:
    App Referrer
  9. #9  

    Default Re: can not connect to my wireless router

    I have the same issue with my skyrocket. But only on some wifi areas. And only some of the time. One day it will work there, one day it wont. Never had a problem with my iPhone 3g or 4. Weird for sure. Would love to know what it is!
  10. Thread Author  Thread Author    #10  

    Default Re: can not connect to my wireless router

    Little update. Still won't connect to my home network, it also wont connect to the free wifi at the local mall. I went to AT&T and they said to call tech support and see if they can do anything, if not they will give me a new phone. Wasn't home all day, so didn't have a chance to call. I did go meet my friend at school, and my phone had no problem connecting to their network. So I have no clue. Tomorrow I will call at&t tech support and see what they say and if they cant fix ti I will get a new phone.
  11. #11  

    Default Re: can not connect to my wireless router

    If your router is set to WPA2 Personal. set phone to use WPA Personal. This worked for me.
  12. #12  

    Default Re: can not connect to my wireless router

    Is the router broadcasting? If not turn broadcasting on and try and connect. Also is the wireless signal good or so-so? That could cause it to never get an IP.
    Lastly, going to your ATT store and them telling you to call tech support is BS on their part, THEY should have gotten on the line with their tech support for you.
  13. #13  

    Default Re: can not connect to my wireless router

    Did you try "wi-fi analyzer"? It will tell you if the signal is weak or if you are sharing a crowded channel with your neighbors. It rates the channels so you can pick the best channel.
  14. Thread Author  Thread Author    #14  

    Default Re: can not connect to my wireless router

    Quote Originally Posted by mandroid21 View Post
    If your router is set to WPA2 Personal. set phone to use WPA Personal. This worked for me.
    How do I change that on my phone? I couldn't find it anywhere


    Quote Originally Posted by pcfred View Post
    Is the router broadcasting? If not turn broadcasting on and try and connect. Also is the wireless signal good or so-so? That could cause it to never get an IP.
    Lastly, going to your ATT store and them telling you to call tech support is BS on their part, THEY should have gotten on the line with their tech support for you.

    My wifi seems to be fine. My old samsung captivate connects with no problem at all. I am within 10ft of my router with nothing blocking it. It shows full strength signal.
    The AT&T store I agree with you, and would have been pissed but he did also say their instore wifi had taking a crap on them and isn't back up and running. So I could see how it could be kind of hard to call tech support to look at a wifi problem when there isnt any wifi to connect to.



    Quote Originally Posted by PaulF View Post
    Did you try "wi-fi analyzer"? It will tell you if the signal is weak or if you are sharing a crowded channel with your neighbors. It rates the channels so you can pick the best channel.

    Yes I tried it. It shows my wifi signal way stronger then anything around me. I even changed the channel to try and get something better, but it still wont connect.



    I was able to get it to connect to the free wifi at mcdonalds and at starbucks today. Both took 2-3 attempts for it to actually connect. So I dont know if my phone just has a crappy wifi receiver or what.
  15. Thread Author  Thread Author    #15  

    Default Re: can not connect to my wireless router

    Ok last update. While I was out and about today I kept trying to connect to any wireless network I could find, and it started working without a problem, except for my home wifi. So I decided to go buy a new router and see if that fixed the problem, and sure enough it did. My phone really was having problems connecting to wifi itself, but I guess with my old router it just couldn't connect. So got a nice new one and its connecting right away. So if anyone else is having wifi problems at home and you got an older router, it may be time to get a new one.

    Thanks to everyone who was giving me ideas and help.
  16. #16  
    Cherwill's Avatar

    Posts
    3 Posts
    Global Posts
    2 Global Posts

    Default Re: can not connect to my wireless router

    I had this same problem with our DLink router. The Netgear one works fine. DLink won't answer my questions, so I won't buy DLink ever again. You also might want to go onto the Samsung website. Those angels are so patient! They walked me through getting my pc and note to sync. Even told me how to do a soft restart. (I had forgotten that it is what they call it.) I used livechat. Amazing service.
  17. #17  

    Default Re: can not connect to my wireless router

    Setting router to multicast is one option as this blog advices:


    I have a samsung note 800 (called samsung note 10.1 in india). It usually doesn't connect to my home wi-fi network. I have a P-660R-T1 modem and a Beetel 450BXI adsl2 router, both of which work fine with laptops. When I set multicast option to IGMP3 my note got connected to internet but next day again it didnt work
    It gets connected to wi-fi router, obtains an ip address (which I can also see in ip pool through 192.168.1.1) but for some reason cannot access internet. Its driving me crazy. If someone knows why please let me know!
  18. #18  

    Default Re: can not connect to my wireless router

    Thanks a lot!!!!!! My ssid had an apostrophe in it and once I got rid of it it works fine and my android tablet connects no problem!!!!
  19. #19  

    Default Re: can not connect to my wireless router

    Try resetting the router. it solved my problem.
  20. #20  

    Default Re: can not connect to my wireless router

    Found this on another post - apparently there are a number of older routers that the new updates are not compatible with.
  21. #21  

    Default Re: can not connect to my wireless router

    PLEASE FOCUS ON 2ND UPDATE AS THIS RESOLVES THE ISSUE AS A WORKAROUNDI see that this problem goes way back. I just got hit with it on my Samsung Galaxy S II. The problem seems to be a corrupted DHCP cache. The problem is, that cache can't be cleared unless the phone is rooted. So using a different router may work, but also, I'll bet, even the old router will work, if you changes it's DHCP IP assignments. Ex. let's say your routers assigns: 192.168.20.xx. If you have change it to say, 192.168.25.xx, I bet it will work. I'm going to try that tomorrow. In my case, the S2 will NOT connect to ANY of my 3 routers. All routers use the same IP segment. Yet, the S2 connects just find to my tethered Samsung Galaxy Note 2, which has a different segment. If changing the segment works, I'll post back here.

    But this has been reported for a very long time. One must ask, WHY has Samsung not gotten a fix out for it. They could have a new version of Android that auto clears the DHCP cache or at least has a manual option to clear it. (I like the auto clear thing as best option).

    UPDATE 1 Ok, I couldn't wait. Here's how my system works. I have 3 routers. The primary router, which is my ADSL router, is the one that assigns IPs via DHCP. I have another router, an N router in the livingroom. It was not assigning IPs. But I enabled it on this 2nd router, but gave it a range of 250 to 255 only.
    The S2 now connects to the router. (discovered that there's no internet access. See Update 2 for resolution)

    So this proves the issue on these devices is a nasty bug in the Android software. The fix would be so simple. Just add code to auto clean out and/or an option to force a clean of DHCP caching (data).

    **********************************************************************
    UPDATE 2 A WORKAROUND IS FOUND THE S2 CONNECTED TO THE ROUTERS, BUT NO INTERENT ACCESS!
    So for those interested in how I did finally gain internet access, here's some info. I only post this in hopes that it may help others get around the problem. BUT, now that I know what's going on with the Android versions below 4.1, I suspect this will only work for a while, until the device's DHCP data (stack?) becomes corrupted again. And until I ROOT the phone, I don't see any other way to clear out the DHCP cache.

    I have 3 routers:
    - Router 1 (main N router hard wire connected to internet)
    - is the Gateway and it's IP is xxx.xxx.xx.2
    - it handles DHCP requests
    - DHCP set to range xx = 10 to 90 (using 192.168.15.xx)
    - most devices in house connect via wire and using static IPs below and above the .xx range.
    - some others using DHCP
    All devices working perfectly and stable.

    - Router 2 (our outdoor on the patio router - PLEASE NOTE, AN OUTSIDE ROUTER IS VERY IMPORTANT IN THE SUMMER. AS IS AN OUTDOOR BEER FRIDGE )
    - uses Static IP xxx.xxx.xx.100 to communicate with Router 1
    - DHCP disabled

    - Router 3 (in our living room, used to connect 3D TV, PS3, computer controlled PVR and other equipemtn, via wire)
    - uses Static IP xxx.xxx.xx.150 to communicate with Router 1
    - DHCP disabled
    THIS IS THE ONE TO WATCH.

    So, last night, when I got it to "connect", what I had done was to Enable DHCP on Router 3 and set its range, 240-255.
    The S2 did pick up an IP adddress, xxx.xxx.xx.253
    This should have worked, but I suspect that because the DHCP was coming from Router 3, it may not have pushed the correct Gateway IP. So it won't see the interent.

    I then Disabled DHCP on Router 3.

    I went into Router 1, the Gateway, and changed the DHCP range from 10-90 to 240-253.
    I rebooted the S2 and right away, it connected to the router, picked up an IP and now is on the internet.

    So I really do not believe anyone NEEDS to buy a new router. Just change the DHCP range.

    What makes me realize this, is when people said that they bought a new router, it worked.

    Different routers have different IP segments.

    i.e. a D-Link may have 192.168.1.xxx or 192.168.15.xxx
    a Linksys may have 192.168.50.xxx and so on.

    So that different address, for some reason, the Android devices will now connect. I suspect that what's happening inside the Android devices with this problem, when using the same IP range, there's corruption and its trying to read what's there and getting confused.

    When changing part of the range, and not sure if going from a 2 digit 4th octect to a 3 digit 4th octet is enough to change the bit , it just works.

    So the person who wrote the app, WiFi Connection Fixer "Root" got it right. It's nothing more than clearing out the DHCP cache (I wonder if clearing DNS cache may also help).
    BUT, the only problem there, is thanks to Samsung, or makers of the Android version for the S2, that's locked out to Super Admin level (which is really stupid if you think about it. This should be at a level where people can clean them out when necessary... and clearly, there's a lot of people with this issue).

    I sure hope this helps anyone with this problem, even though this thread is very old. Which also begs the question, WHY has Samsung (and others??) not provided a firmware update that fixes this easy to fix problem???
    Last edited by Derek JA; 04-06-2013 at 07:07 AM.
  22. #22  

    Default Re: can not connect to my wireless router

    I really need help I can connect to my router and use the browser but apps won't connect to the internet like twitter, facebook and the playstore.i use a galaxy note 10.1
  23. #23  
    tube517's Avatar

    Posts
    748 Posts
    ROM
    Decks Reloaded,RebelROM

    Default Re: can not connect to my wireless router

    Quote Originally Posted by chewey12 View Post
    I really need help I can connect to my router and use the browser but apps won't connect to the internet like twitter, facebook and the playstore.i use a galaxy note 10.1
    Reboot your router.

    Also, this forum is for the Galaxy Note LTE phone not the tablet
    TOSHIBA Thrive Pio's Team Baked BlackBean 4.1.2 ROM
    Samsung Galaxy Note 1 (i717) CM11 4.4.2 kitkat (jamied)
    Samsung GalaxyTab 3 (7 in) Deleterious ROM
    HTC EVO 4G Deck's Reloaded ROM
    Samsung Galaxy Note 2 (i317) unlocked Ditto Note 3.1.1 (4.3) ROM
    B&N Nook Color (Gifted to relative)
    Samsung Galaxy Prevail Half A$$ed ROM
    EVO Shift JellyBelly ROM
    Samsung Galaxy S3 DanKang 4.3.1 ROM

  24. #24  

    Default Re: can not connect to my wireless router

    I was having this issue with my Vivid. It would attempt to obtain an IP address and fail over and over.

    I tried rebooting and resetting everything based on the worthless worthless suggestions here and nothing changed, so I started thinking for myself.

    I knew AT&T would likely figure out a simple way to toggle unsuspecting users to back to their network so they can charge them as much as possible based on the limits they now have on most calling plans.

    So, I approached it from that most calling plans, so I approached it from that angle...

    I'm now connected to my network with no help from this forum.

    What I figured out is that if I go into my phone's main SETTINGS, and disconnect (turn off) my MOBILE NETWORK (that's the AT&T network that I would like to keep from using when I am at home) and then turn ON the Wi-Fi function.

    Once my network has been found by my phone and I enter my password..... *****BAM!!!***** IT WORKS!!!!

    The little Wi-Fi icon then comes to life at the top of my phone's main screen and I'm surfing the web across my network. YAY!!!!

    All people have to remember to do is turn off the WiFi (to conserve battery power) when they leave their house and turn the MOBILE NETWORK back on so they can communicate when they are out and about.

    Now why am I the only one to find this solution and post it here?????

    SERIOUSLY???? LOL
  25. #25  

    Default Re: can not connect to my wireless router

    Quote Originally Posted by 2badberry View Post
    If your router is set to WPA2 Personal. set phone to use WPA Personal. This worked for me.
    That's not good and should be trying to achieve WPA2 especially on a mobile device. But, I can't get mine to connect with a Linksys WRT54GSv6 Router using WPA2 Personal-AES setup.
    Last edited by August59; 10-01-2013 at 01:12 AM. Reason: addition

Posting Permissions

B