Results 1 to 22 of 22
Like Tree1Likes
  • 1 Post By CheeseyChester
  1. Thread Author  Thread Author    #1  

    Default Wifi Automatically Turning On?

    My Galaxy SII automatically turns on the wifi when not requested. I have to have it forget the wifi network otherwise it constantly reenables wifi when I have turned it off. Has anyone had this problem and is there a fix for it?

    Thanks in advance!
    "... The time is fulfilled, and the kingdom of God is at hand: repent ye, and believe the gospel." (Mark 1:15)
  2. #2  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    I use Wi-Fi Manager from the Market. It has a nice little toggle widget that allows me to disable or activate wi-fi. It saves me from having to go into settings. I hope this helps.
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: Wifi Automatically Turning On?

    Thanks tunie! I will give it a try!
    "... The time is fulfilled, and the kingdom of God is at hand: repent ye, and believe the gospel." (Mark 1:15)
  4. #4  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    I hit that widget whenever I leave the house so it won't try to connect to every wi-fi network on the road. I hate that:-) This little widget works well for me and I like that I can see the address of the network I'm connected to, along with the name and strength. It's nice looking too. Let us know if it works for you:-)
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
  5. #5  
    gsrrr's Avatar
    Derp

    Posts
    72 Posts
    Global Posts
    76 Global Posts

    Default Re: Wifi Automatically Turning On?

    Quote Originally Posted by tunie View Post
    I use Wi-Fi Manager from the Market. It has a nice little toggle widget that allows me to disable or activate wi-fi. It saves me from having to go into settings. I hope this helps.
    Do you not have a pull-down menu with the wifi toggle button? I am able to just swipe down from the home menu and turn on/off wifi and other settings.
  6. #6  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    Yes, the pull-down is part of the OS, but I like to see the address I'm connected to and Wi-fi Manager allows me to easily save my most used wi-fi networks and select between them. I can choose the strongest connection that way. The pull-down works fine. I just like the other options available in the widget and find it more convenient, for me anyway:-)
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
  7. #7  
    gsrrr's Avatar
    Derp

    Posts
    72 Posts
    Global Posts
    76 Global Posts

    Default Re: Wifi Automatically Turning On?

    Quote Originally Posted by tunie View Post
    Yes, the pull-down is part of the OS, but I like to see the address I'm connected to and Wi-fi Manager allows me to easily save my most used wi-fi networks and select between them. I can choose the strongest connection that way. The pull-down works fine. I just like the other options available in the widget and find it more convenient, for me anyway:-)
    Ahh I see, I was just curious/ wondering if you had a different ROM or something that did not have the pull down menu.
  8. Thread Author  Thread Author    #8  

    Default Re: Wifi Automatically Turning On?

    Well, after a little while the wifi turned itself back on, so Wifi Manager did not fix the problem.
    "... The time is fulfilled, and the kingdom of God is at hand: repent ye, and believe the gospel." (Mark 1:15)
  9. #9  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    You toggled wifi off on the widget and it turned itself back on anyway? What were you doing when this happened? Were you at home near your own network or travelling?

    In the system settings under Wireless and Network> Wi-Fi settings, make sure Auto connect isn't selected.

    <edit> After you make sure Auto connect isn't selected, do a soft reset of your phone. Turn it off with the power button. After it's off, remove the battery and leave it out for at least 30 seconds. Start the phone again. Toggle wifi off and see if it stays off.
    Last edited by tunie; 12-08-2011 at 02:15 AM.
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
    Thanked by:
  10. #10  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    If wifi is still connecting, then it could be an app you downloaded that's turning it on. Once wifi is disabled and Hotspot auto connect is disabled, there is no way I know of for wifi to connect unless an app is turning it on (There is an app that allows you to schedule when wifi is enabled and disabled. Did you download anything like that?) or, your wifi sleep policy is set to "never" or "never when plugged in".

    If you didn't download an app to schedule when wi-fi is enabled and disabled, Go to settings> Wireless and Network> Wi-Fi settings> hit the setting capacitive button and touch advanced> Wi-Fi sleep policy. Set it to sleep "When screen turns off" if it's not already selected.

    Let us know if that fixes the problem.
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
    Thanked by:
  11. Thread Author  Thread Author    #11  

    Default Re: Wifi Automatically Turning On?

    Thanks Tunie. Unfortunately none of this fixed the problem. Even if I do not have any wifi networks remembered it will turn itself on. It does not matter that I have it turned off. I am always getting a good signal from AT&T, so it is not trying to compensate for that. It is the strangest thing. I am going to try wiping it and starting over from scratch.
    "... The time is fulfilled, and the kingdom of God is at hand: repent ye, and believe the gospel." (Mark 1:15)
  12. #12  
    tunie's Avatar
    Phhhhbbbbtttt

    Posts
    584 Posts
    Global Posts
    600 Global Posts
    ROM
    Stock ROM:Rooted

    Default Re: Wifi Automatically Turning On?

    Did you configure Wi-fi Direct under network settings by any chance?
    Don't breed or buy while shelter animals die. Save a life.
    LA County Adoption List Humane Society ASPCA
  13. Thread Author  Thread Author    #13  

    Default Re: Wifi Automatically Turning On?

    Quote Originally Posted by tunie View Post
    Did you configure Wi-fi Direct under network settings by any chance?
    No, I have not touched that setting yet. It is not setup. Unfortunately it is still doing it.
    "... The time is fulfilled, and the kingdom of God is at hand: repent ye, and believe the gospel." (Mark 1:15)
  14. #14  
    Lori's Avatar

    Posts
    1 Posts
    Global Posts
    5 Global Posts

    Default Re: Wifi Automatically Turning On?

    I strongly believe that Sprint itself is turning WiFi on via 3G to display available updates and pull application use data and browsing history from your phone without using their own network bandwidth. I really hate this. I am hoping that if I root my Galaxy 3 with OS 4.0.4 I will be able to keep WiFi off until I want it. The fact that WiFi also automatically enables when you plug it in to charge is not a feature, but a bug.
  15. #15  

    Default Re: Wifi Automatically Turning On?

    There is an AT&T app that was doing this to me — I believe it is AT&T Smart Wi-Fi. It's set up to sense whether there is a Wi-Fi network available and then attempt to connect the phone to it. It's an optional app, so it can be uninstalled easily.
  16. #16  

    Default Re: Wifi Automatically Turning On?

    This seems to be happening to me for the past several months, first on my Samsung Epic, and now on my new Motorola Photon Q. The trade press indicated a while back that the manufacturers were going to add this as part of the OS as a way to offload some traffic, basically switching over to any hotspot you happen to be near which is in your list. It is a real pain, since it empties your battery. As an example, when I am home I sometimes connect my phone to my own AP, so of course my AP is in my list. When I am not doing data ops with my phone, I don't want the phone connected to WiFi. However, since about February, 2012, every time I get near my home AP, the WiFi turns itself on. It sucks. Does anyone know how to defeat this "feature"?
  17. #17  

    Default Re: Wifi Automatically Turning On?

    I have Sprint and mine just started doing this today and luckily I remembered that this morning i got a popup on my phone and it said something about wifi, i ack without really reading it. Apparently I agreed to turn on Connections optimizer and this allows it to decide which connection is best for your phone at any given time.

    settings>More>Mobile Networks>Connections optimizer>uncheck the box (mine says "Sprint Connections Optimizer"

    hope this helps someone else.
    Thanked by 4:
    Srikanth Katkam likes this.
  18. #18  

    Default Re: Wifi Automatically Turning On?

    Thanks CheeseyChester, Sprint just pushed this on me over the weekend...was driving me nuts.
  19. #19  

    Post Re: Wifi Automatically Turning On?

    THANK YOU SOOOO MUCH!!
    i have the galaxy SII and i got the same message a couple of days ago. i thought that it was a simple update but i did read the wi-fi thing. i did not pay attention to it but it kills soo much batt wehn its trying to connect to everything it sees. its helped a heap thanx!! lol
  20. #20  

    Default Re: Wifi Automatically Turning On?

    Thanks, it helped me!!
  21. #21  

    Default Re: Wifi Automatically Turning On?

    so guys i came here hoping to find how to fix this also, none of the work around worked for me but I did find a way to finally fix it.
    here is how:
    go to settings...under more option... go to mobile network... there is check mark for sprint to select the best network available to optimize your data plan, well turn that off and screw sprint...they want to us as much wifi as posible to use less their network.
    that should do it, i am on a gallasy s2, so any other should be similar...
    hope that helps everyone.
  22. #22  

    Default Re: Wifi Automatically Turning On?

    That's exactly what CheesyChester said above.

    Thank you CC! My wife got a Samsung Galaxy S II and we found that occasionally the battery would get slammed. I found all sorts of fun Samsung BS to disable (e.g. AllShare and Kies media sharing software, no thanks) and that probably helped the power consumption. But the WiFi kept turning itself on, despite the fact that we'd explicitly turned it off. Finally today I noticed that the WiFi was turning itself on whenever the phone got plugged into a charger (USB). Aha! Some googling led me here and to the Sprint Connections solution. Those bastards!
    2003 - 2010: Samsung i500 Palm phone (7 yrs!)
    2010 - 2012: HTC Hero w/ 2.1/Eclair
    2012 - present: Motorola Droid Razr M w/ 4.1/Jellybean

Posting Permissions

B