Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Wi-Fi Problem

    Just recently, my phone has been having some trouble with Wi-Fi. It connects to my home router, but it just doesn't actually connect. It doesn't load anything from any app or website.

    I know it can't be the router because my computer and other Wi-Fi connected devices in the house still work... but I just don't understand how my phone can't connect.

    I've tried restarting the router, forgetting the connection and trying to connect again, a combination of both, a bunch of other things, all the way down to just powering off my phone out of frustration and turning it back on praying that it just magically works once, but obviously to no avail.

    Any help would be appreciated, thanks!
  2. #2  

    Smile Re: Wi-Fi Problem

    Do you have wifi turned on in settings?
  3. #3  

    Default

    Out of curiosity is the phone rooted? If you've changed ROMs/kernels recently this can cause WiFi connectivity issues if you didn't do a clean install. And definitely check your advanced settings in the WiFi menu.

    Sent from my SGH-I777 using Android Central Forums
  4. Thread Author  Thread Author    #4  

    Default Re: Wi-Fi Problem

    Quote Originally Posted by nonie View Post
    Do you have wifi turned on in settings?
    Yes

    Quote Originally Posted by michael3214 View Post
    Out of curiosity is the phone rooted? If you've changed ROMs/kernels recently this can cause WiFi connectivity issues if you didn't do a clean install. And definitely check your advanced settings in the WiFi menu.

    Sent from my SGH-I777 using Android Central Forums
    Nah it's not rooted. Just stock with the Ice Cream sandwich update
  5. #5  

    Default Re: Wi-Fi Problem

    I had a fairly old wireless router when I got my SGS II, and I had problems with the router when I tried to download apps with the phone. The router worked fine with laptops. I replaced the router with a new one and the problems went away.
  6. #6  

    Default

    Quote Originally Posted by SonicTheKevin View Post
    Just recently, my phone has been having some trouble with Wi-Fi. It connects to my home router, but it just doesn't actually connect. It doesn't load anything from any app or website.

    I know it can't be the router because my computer and other Wi-Fi connected devices in the house still work... but I just don't understand how my phone can't connect.

    I've tried restarting the router, forgetting the connection and trying to connect again, a combination of both, a bunch of other things, all the way down to just powering off my phone out of frustration and turning it back on praying that it just magically works once, but obviously to no avail.

    Any help would be appreciated, thanks!
    Maybe the router has MAC filtering security setup to only allow registered MAC ids to connect?
  7. #7  
    Entrical's Avatar

    Posts
    28 Posts
    Global Posts
    388 Global Posts
    ROM
    CM9 Nightlies

    Default

    Have you tried manually configuring your IP and Gateway on your phone?

    Sent from my SGH-I777 using Tapatalk 2

Posting Permissions

B