07-25-2016 10:36 AM
54 123
tools
  1. hypobid's Avatar
    My company uses MS Exchange for it's email. I have added my account to my phone, however, every now and again, the following message appears:

    "Update Security Settings to Use Email"

    I have no idea what security settings I need to update! I have even asked our MS Exchange guys, however, they don't know either... I have Googled this error message and have found conflicting resolutions, and have implemented all the recommendations, yet, I still periodically receive the message...

    Anyone have any ideas?

    Thanks!
    07-12-2012 05:33 AM
  2. eriksahn's Avatar
    My company uses MS Exchange for it's email. I have added my account to my phone, however, every now and again, the following message appears:

    "Update Security Settings to Use Email"

    I have no idea what security settings I need to update! I have even asked our MS Exchange guys, however, they don't know either... I have Googled this error message and have found conflicting resolutions, and have implemented all the recommendations, yet, I still periodically receive the message...

    Anyone have any ideas?

    Thanks!
    Maybe you have too many accounts associated with Exchange? I had to go in and manually delete my old Atrix and BlackBerry.

    Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
    07-12-2012 12:43 PM
  3. Moxer's Avatar
    What that message means is that the server has some policy enabled for mobile devices that you aren't meeting. Usually it is something like a pin lock for the lock screen.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-12-2012 02:40 PM
  4. gravage's Avatar
    My company uses MS Exchange for it's email. I have added my account to my phone, however, every now and again, the following message appears:

    "Update Security Settings to Use Email"

    I have no idea what security settings I need to update! I have even asked our MS Exchange guys, however, they don't know either... I have Googled this error message and have found conflicting resolutions, and have implemented all the recommendations, yet, I still periodically receive the message...

    Anyone have any ideas?

    Thanks!
    That error generally has to do with EAS and remote administration. Your phone should have prompted you to create a pin. Did you try actually tapping the message in your notification shade? You may need to remove the account and add it again.
    07-12-2012 02:56 PM
  5. tpearsall's Avatar
    I'm having the same issue. It was working fine for a week or so, then I did a test drive of CM10. When I restored my stock/rooted ROM I started getting the update message. I'm guessing it's related to registering the device stock, then CM and then restoring stock. Have I confused the Exchange server about what device is registered?

    Tried removing and adding the account again, but still get the security notifications every few minutes.
    07-23-2012 08:37 AM
  6. tpearsall's Avatar
    07-23-2012 08:51 AM
  7. hypobid's Avatar
    I have tried all kinds of things (added pass code for lock screen, turned on auto-lock, deleted all accounts associated with Exchange, etc.), but the error continues to show up. The only way I can avoid the error is by completely removing the account, followed by re-adding the account, however, this is only a temporary (and painful) solution. It works for about 24 hours, and then all of a sudden, it stops working again, with the dreaded "Update security setting..." message. I have also followed-up with our Exchange guys at work. They don't have any idea. Only thing they said is that iPhone users are not experiencing any issues... Such a bummer b/c I really love this phone, however, if the issue cannot be resolved, I will more than likely have to switch back to the iPhone...
    07-24-2012 09:34 AM
  8. casperinmd's Avatar
    What OS are you running? My SPrint Epic 4G Touch started doing this exact thing after upgrading to ICS recently, and another coworker using his Razr Max just updated to ICS and gets it now.

    Maybe ICS is part of the issue?
    07-26-2012 06:24 AM
  9. SlappyMcgee's Avatar
    Did you get prompted and do the encryption? Phone has to be 80% charge and plugged in.

    Also could be an issue on the exchange servers active sync association with your phone.

    I have my company exchange setup, my only issue is when I try to manual refresh outside of my synch sched, I have to refresh a couple Times, b/c it gives me an account security message.. now that I think about it. Maybe the Samsung mail client does need an update. I had similar (to my current bug) issue on my captivate when trying to synch outside of the auto synch schedule.

    Do you have your exchange set to auto push?

    Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
    07-26-2012 08:25 AM
  10. casperinmd's Avatar
    I did not do encryption, we do not enforce that. Our Exchange policy did not change, just updated my phone to ICS.

    I do have push set for all schedules, always have as well.

    I did just remove my account on my phone and add it back, I will see how long it lasts without the pop up and report back my findings.
    07-26-2012 08:35 AM
  11. hypobid's Avatar
    I did not do encryption, we do not enforce that. Our Exchange policy did not change, just updated my phone to ICS.

    I do have push set for all schedules, always have as well.

    I did just remove my account on my phone and add it back, I will see how long it lasts without the pop up and report back my findings.
    Same for me... My company does not enforce encryption, and our Exchange policy did not change. Deleting and adding the account is getting old...
    07-26-2012 05:06 PM
  12. dahncke#CB's Avatar
    Got the same message, pressed the OK (or maybe it was Continue) button... did the cycle 3 times. It seemed to change something each time and shut down the mail application each time too. On the 3rd time, it worked just fine.

    I have no idea what it did, but seemed to be doing something automaticly to resolve the issue.
    07-26-2012 09:08 PM
  13. peruboy63's Avatar
    It's giving your employer permission to wipe if needed. The at least that's what my security update was for.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-27-2012 12:20 AM
  14. casperinmd's Avatar
    Damn, just happened again sometime last night.

    Anyone know if this happens with the Touchdown client? I don't want to pay but if it stops the pop up and allows me to receive mail, then I gotta do what I gotta do.
    07-27-2012 06:51 AM
  15. casperinmd's Avatar
    It's giving your employer permission to wipe if needed. The at least that's what my security update was for.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    Right, but it should happen once, when you setup the account. After that, it should never come back unless the corporate policy is changed.

    THat is how it worked on Gingerbread, right up until I updated the OTA ICS update...then this vicious cycle. I guess I am sorta glad it is not just me.
    07-27-2012 06:53 AM
  16. SlappyMcgee's Avatar
    Well if your exchange server guys are anything like the guys at my company. **Dont get me wrong they are great guys and know there stuff this more of a company wide complaint but have seen them do it on occasion too.**
    They wont really bothter with investigating the problem to see if it is something on the exchange server is causing the Samsung mail app to bug out or if an update is required to make sure they both communicate properly until; the "Right Person" has a problem then it will get fixed. Just saying if this is an issue the requires an update on the exchange server side.
    07-27-2012 07:13 AM
  17. casperinmd's Avatar
    Well if your exchange server guys are anything like the guys at my company. **Dont get me wrong they are great guys and know there stuff this more of a company wide complaint but have seen them do it on occasion too.**
    They wont really bothter with investigating the problem to see if it is something on the exchange server is causing the Samsung mail app to bug out or if an update is required to make sure they both communicate properly until; the "Right Person" has a problem then it will get fixed. Just saying if this is an issue the requires an update on the exchange server side.
    I have to disagree here. I can 100% assure you my company's Exchange ActiveSync policy has not changed in over a year, yet as soon as I upgrade from GB to ICS, it pops up over and over.

    Not saying it is NOT an Exchange issue, but seems pretty clear it is a change in ICS with Samsung. I'll have to look around other forums to see if any other OEM is having the same issue.
    07-27-2012 07:31 AM
  18. hypobid's Avatar
    OK, I think I've finally figured it out! I noticed that each time I removed my Exchange email account from my S3, automatic updates from Google Play Store immediately started to download. I went ahead and disabled automatic updates, and I added a password for downloading via Play Store. So far (for 2 days now), I have not received the dreaded "Update Security Settings..." message. Seems to be working fine now... Just thought I'd post my findings...

    Thanks!
    SlappyMcgee likes this.
    07-28-2012 05:55 AM
  19. SlappyMcgee's Avatar
    Cool thank you for sharing your findings, and glad you got it resolved.

    It might be a security policy on the exchange that has been in place, but wasn't supported until ICS, the sgs3, or a combination of both. My captivate didn't do device encryption, but my sgs3 did when adding my exchange account.

    Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
    07-28-2012 08:13 AM
  20. casperinmd's Avatar
    Thanks for the info! I did not have auto update enabled, so we can rule that out.

    However, I did not have PIN on the Play store, so I just added that...I am praying it works!
    07-28-2012 01:15 PM
  21. hypobid's Avatar
    Thanks for the info! I did not have auto update enabled, so we can rule that out.

    However, I did not have PIN on the Play store, so I just added that...I am praying it works!
    I think I spoke too soon . I woke up this morning, and sure enough, the dreaded security error showed up again... Had to delete and re-add the account again (for the 50th time). Such bummer... Back to the drawing board...
    07-29-2012 06:08 AM
  22. KcGuero's Avatar
    I think I may have figured it out. I re-flashed my rom. During the reset-up of the Exchange server email, after I entered all the server info, the phone accessed the server. A permission page came up, and I took the time to read it!!! You have to give permissions to the server to control some security features on your phone. I clicked ok, and it responded with a confirmation. I have not had the "Update Security Settings to Use Email" error come up. It WAS coming up every time I opened the account, before I did this ....now it does not happen...If this assumption is incorrect, I will post such here...
    08-01-2012 08:51 PM
  23. eskybel's Avatar
    Sprint Epic 4g Touch, just got OTA ICS 4.0.4. I have two exchange accounts setup on my phone.

    I've been dealing with these security pop up messages as well since the ICS update.

    I hope this wasn't already posted and I missed it, but one thing I noticed also was when the "security settings" notification popped up, I could click it, but all it gave me was the "Update security settings" message, then "OK" or "Cancel." Clicking OK didn't do anything except get rid of the message for a minute.

    I just found this, and I guess I will report back in a few days to see if it has worked, but I went into Settings > Security > Device Administrators >

    Then there is a single setting/check box for my Email program, stating "enables server-specified security policies." Mine was already checked, but for grins, I clicked it anyway. It prompted me with another screen, listing all kinds of info about the email app, with an "Activate" and "Cancel" at the bottom. I clicked "Activate," and it did it's thing. The check box for "Email" is still checked, but if I click it again, now I have the option to "Deactivate" instead of "Activate."

    I'm hoping the "security settings" notification is supposed to bring you to this screen, but is bugged and never gets you there. At least, it seems that way for my case.

    Maybe it will fix the problem?
    08-14-2012 08:42 AM
  24. eskybel's Avatar
    Sorry for the double post, but here's an update.

    So, the "Activate" didn't get rid of the notification. But apparently getting rid of one exchange account did. Below is an example of what I mean:

    Phone starts with no email accounts. I add account "A." Activate it with the normal security activation process. Everything works, no notifications after the first one.

    I add account "B," and I am prompted with the "update security settings" though all I can click is "OK" or "Cancel" and "Activate" is not an option, because the phone's administrative accounts menu says it's already activated. Account "B" continuously prompts for "update security settings" and I can't find a way to make it stop. Both accounts "appear" to be functioning though.

    I remove account "B" and security messages stop.

    I remove both accounts, and re-add only account "B." I am prompted with "update security settings" and "Activate" is an option again, so I do it. I do not get any notifications again for "updating security settings."

    I re-add account "A," and I am prompted with the "update security settings" though all I can click is "OK" or "Cancel" and "Activate" is not an option, because the phone's administrative accounts menu says it's already activated. Account "A" now continuously prompts for "update security settings" and I can't find a way to make it stop.

    I remove account "A" and the notifications stop again.

    So, long story short, it appears to stop the security notifications for me means I can only have one exchange account on my phone...?
    08-14-2012 10:55 AM
  25. ralf_thiel's Avatar
    If you use Exchange ActiveSync to connect to your Exchange Server, your Exchange administrator is able to define Exchange ActiveSync Mailbox Policies (Organization configuration - Client Access). In our case the default policy disabled the use of Bluetooth on connected devices. Whenever we tried to switch on Bluetooth we received a message telling us that "Security policy restricts use of bluetooth connections"! Those policies will of course be update from time to time and I assume that the "Update Security Settings ..." message is related to this updating process.
    02-07-2013 01:28 AM
54 123
LINK TO POST COPIED TO CLIPBOARD