Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  
    double923's Avatar

    Posts
    91 Posts
    Global Posts
    92 Global Posts

    Default S3 lost mobile data connection.

    I always left my wifi, mobile data, pretty much everything else on all the times. I noticed when I left wifi range and mobile data should take over. In most case it did. But often time, it didn't. When it didn't, I have to shut off mobile data and re-enable it to establish connection. Did anyone see this problem? I also saw where both wifi and mobile data are on at the same time for good 5, 10 min at time.
  2. #2  
    dervari's Avatar

    Posts
    34 Posts
    Global Posts
    285 Global Posts

    Default Re: S3 lost mobile data connection.

    I had this issue tonight.
  3. Thread Author  Thread Author    #3  
    double923's Avatar

    Posts
    91 Posts
    Global Posts
    92 Global Posts

    Default Re: S3 lost mobile data connection.

    yeah, this might have been issue with the cell tower. My area just have LTE enable literally day before S3 was available. They might be few glitches still...
  4. #4  

    Default Re: S3 lost mobile data connection.

    Quote Originally Posted by double923 View Post
    I always left my wifi, mobile data, pretty much everything else on all the times. I noticed when I left wifi range and mobile data should take over. In most case it did. But often time, it didn't. When it didn't, I have to shut off mobile data and re-enable it to establish connection. Did anyone see this problem? I also saw where both wifi and mobile data are on at the same time for good 5, 10 min at time.
    Been having this same issue, thought it was just my device. It's extremely annoying, almost a deal breaker (I'm still within my return window). I have to often manually disable then re-enable mobile data, just to get it going.

    What good is a smartphone, with a data plan, if it can't even hold a signal?

Posting Permissions