1. nator76's Avatar
    Just updated to JB last night. Everything is solid, but for some reason Widgetlocker now unlocks on the home button press.

    I know the s2 had this issue, and Homehelper is the worst work around ever. Did this change for anyone else? Did i gloss over something in the settings? Thanks


    EDIT: Nevermind, this thread helped me out

    http://forums.androidcentral.com/sam...roblem-jb.html
    12-04-2012 10:30 AM
  2. Noob#AC's Avatar
    Don't know why but following the steps in the thread you referenced doesn't work.

    - Waking the phone with the power button opens WL as expected. All is good.
    - Waking the phone with the home button goes directly to the stock lock screen and sometimes no lock screen at all (just my phone home screen).

    This is driving me bananas. Any help would be greatly appreciated.
    12-07-2012 08:34 AM
  3. nator76's Avatar
    my settings

    Homehelper component - checked
    Homehelpers launcher (apps to be called) - nova luancher for me
    Homehelper blockhome - checked

    when you exit, it will ask which launcher you want, i picked WL helper - always

    hopefully this helps
    12-07-2012 08:54 AM
  4. Noob#AC's Avatar
    my settings

    Homehelper component - checked
    Homehelpers launcher (apps to be called) - nova luancher for me
    Homehelper blockhome - checked

    when you exit, it will ask which launcher you want, i picked WL helper - always

    hopefully this helps
    Thanks for the response but still no go (I use Launcher Pro). Your last sentence regarding asking which launcher I want when exiting, I don't get asked that when I exit. Using Sprint S3 if that matters. Still driving me bananas.
    12-07-2012 09:09 AM
  5. bogdaryl's Avatar
    my widgetlocker hasn't worked properly since the JB update. Same problem with the buttons.
    12-07-2012 09:48 AM
  6. madlaw1071's Avatar
    same here, widget locker blows since the update, as does Swype.
    12-07-2012 10:39 AM
  7. Noob#AC's Avatar
    same here, widget locker blows since the update, as does Swype.
    Yes and Yes.
    12-07-2012 10:48 AM
  8. madlaw1071's Avatar
    I no longer have voice dictation(Nuance) with Swype which I always rated as higher than the Google voice.
    12-07-2012 12:42 PM
  9. anon5485582's Avatar
    The fix provided by using Homehelper worked for me and I have apex launcher. For those not getting the block home prompt, yiu have to reset your application defaults app manager.
    12-18-2012 02:20 AM
  10. Hubertsng's Avatar
    To fix this problem you have to root your device. After that go to the advanced settings in widget locker and choose root helper. Enable that and it should be checked already that the navigation bars will disapear. Literally just found out 5 seconds ago :P
    This forums didn't help at all lol.
    01-17-2013 03:34 PM
  11. Hegemon875's Avatar
    Alright so I have an update for anyone having issues.
    Go to WIL settings-advanced-homehelper
    Check "HomeHelper Component", select "WL HomeHelper", and hit "always".
    Hit "HomeHelper's Launcher" and select your launcher.
    Hit "Select System Home" and set it to WL HomeHelper "always".
    Check "HomeHelper Block Home"
    Finally check "HomeHelper Block Home".

    I tried in the instructions that the OP referenced and it didnt work but the above did without rooting.
    krasher2 likes this.
    06-30-2013 09:23 AM

Similar Threads

  1. T-Mobile Optimus T: Lock screen, search and home button not working
    By chad.jordan93 in forum T-Mobile Optimus T
    Replies: 29
    Last Post: 04-29-2015, 10:50 AM
  2. Miss my silence button and home button from iphone
    By radman202 in forum Samsung Galaxy S II Skyrocket
    Replies: 1
    Last Post: 12-20-2011, 08:50 AM
  3. Lock screen missing, and home button not working
    By Ron_Who in forum Samsung Replenish
    Replies: 0
    Last Post: 09-24-2011, 11:09 PM
  4. Back and Home Button Problems
    By JGamble in forum AT&T Captivate
    Replies: 4
    Last Post: 07-26-2010, 04:20 PM
  5. Stuck at white boot screen and home button not functioning
    By wkj in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 06-18-2010, 07:40 AM
LINK TO POST COPIED TO CLIPBOARD