Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 27
Like Tree1Likes
  1. Thread Author  Thread Author    #1  

    Default AT&T Galaxy S3: 4G does not turn off when WiFi is connected

    When my phone connects to my home WiFi, the 4G Data Icon goes away for a bit, but then comes back and becomes the active IP (even though WiFi icon is still active).

    It had been working flawlessly for almost a year. Just started doing this yesterday. The only thing that I did differently was accidentally launching the AT+T Navigator.

    My work-around for now is to turn off WiFi, turn off 4G, then turn WiFi back on (leaving the 4G off until I leave the house and hopefully remember to turn it back on You can make it easier to do with:

    ~Data Toggle Widget (by Bogdan Lazanu) (Google Play Store)
    used in conjunction with the
    ~Stock Wifi Toggle Widget

    Troubleshooting Notes to Date (revised 11/21/13):
    Phone: SGH-i747
    Upgraded to Android Version 4.3 (was also having problem in 4.1.2)
    We have two Galaxy S3's with AT+T. Only "mine" is behaving this way.
    ~Both are same model/android and have all PlayStore Updates
    ~Checked/compared all settings line/by/line and all are the same
    Phone is not rooted
    Tried battery pull
    Tried pulling power on wifi/router; then restarting phone
    Tried using AT+T SmartWi-Fi to resolve problem (did not work, so I uninstalled it)
    Tried removing my existing WiFi connections, then adding them back in.
    I did note in the Verizon forum that people were able to uninstall a CallerID App to resolve the problem, but I'm not finding that in AT+T.
    Tried Static IP
    Tried WiFi Repair Apps
    Tried Clearing Cache
    Tried Booting in Safe Mode

    Any suggestions would be greatly appreciated ! Not crazy about doing a backup/reset/restore... would rather identify the issue in case it happens again to me or someone else.

    Thanks !
  2. Thread Author  Thread Author    #2  

    Default Re: 4G does not turn off when WiFi is connected

    I tried upgrading to Android 4.3 today in hopes that would take care of this issue, no such luck

    HOWEVER, I now notice the following in the WiFi Screen:

    When 4G is ON, then I enable WiFi, I see the following messages (in this order):
    1) Obtaining IP address
    2) Checking the quality of your internet connection
    3) Turned off

    "Turned Off" remains under the SSID name in my list of "Wi-Fi Networks"

    When 4G is OFF, then I enable WiFi, everything connects just fine.

    See attached screenshots

    I updated my original post to include other troubleshooting to date.

    Any input/suggestions are appreciated !

    AT&T Galaxy S3: 4G does not turn off when WiFi is connected-wifi_4g_turned_on.pngAT&T Galaxy S3: 4G does not turn off when WiFi is connected-wifi_4g_turned_off.png
  3. #3  

    Default Re: 4G does not turn off when WiFi is connected

    I had that same problem with the last update. I backed everything up then did a factory reset. I then let it take the update and last restore apps and data. I haven't had that problem since. That was after talking to Samsung and AT&T.
  4. #4  

    Default Re: 4G does not turn off when WiFi is connected

    I'm having that problem as well. I'm attempting to download the 4.3 update in hopes that it will fix it. This is the only forum I have seen that addresses this issue.
    This has been going on for a month now, my data and battery usage are getting crushed. I have had people tell me that when 4G and wifi icons are on that you are defaulting to wifi and that is not the case. I have used 65% of my data package and I never come that close.
    Hopefully the update corrects this,I don't want to have to do a reset. I have to admit I'm tempted to go back to my iPhone.
    Thanks for posting the wifi workaround,at least I can download this update without going over my data limit!

    Mike
  5. #5  

    Default Re: 4G does not turn off when WiFi is connected

    Factory reset may be your best answer. Outside of that, I use an app called WiFi Matic. It turns off WiFi when not connected, and it can be set to turn off mobile data while on WiFi. It may be worth a try to override your current system problem before doing a reset.
    Eric White5 likes this.
  6. Thread Author  Thread Author    #6  

    Default Re: 4G does not turn off when WiFi is connected

    Just an FYI... I've been following similar issues in other boards and there are a good number of people that have tried the reset with no success. I'm using the work-around (posted in my original post) for now until I see something different. I edited the work around to include a Data Toggle Widget (by Bogdan Lazanu) , used in conjunction with the stock Wifi Toggle Widget to make toggling easier.
  7. #7  

    Default Re: 4G does not turn off when WiFi is connected

    I started getting this problem 2 days back and after installing those 2 widgets it worked for me , do no when this will be fixed.
  8. #8  

    Default Re: 4G does not turn off when WiFi is connected

    Quote Originally Posted by JohnNadeau View Post
    2) Checking the quality of your internet connection
    I thought I saw a mention of a setting related to this in a different forum - there was a screenshot of Settings -> Wi-Fi -> Menu button -> Advanced that showed a bunch of options which are not there on my Verizon phone, and one of them was named something like this. You might take a look at the Advanced options and see what you find.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  9. Thread Author  Thread Author    #9  

    Default Re: 4G does not turn off when WiFi is connected

    The problem turned out to be the AT+T Navigator App!!!!!

    I finally had some time and decided to try a Factory Data Reset. After the reset, WiFi and 4G/Data were behaving perfectly UNTIL I launched the AT+T Navigator Application. At that very moment, this time I could see (because I wasn't driving ) that 4G/Data began overriding WiFi as outlined in my second post above.

    I had been using (and will now continue to use) the GoogleMaps/Navigator for driving directions.

    BEFORE YOU TRY the backup/restore steps outlined below, TRY THIS FIRST:
    1. Settings/More/ApplicationManager
    2. Select the AT+T Navigator App
    3. Select TURN OFF
    4. Restart your phone
    5. See if that corrects the problem.


    HERE'S WHAT I DID TO CORRECT THE PROBLEM:
    1. Enabled Android Backup on the phone: Settings/Accounts/BackupAndReset: Enable BackupMyData and AutomaticRestore
      Note: I have NO idea how long it takes to backup everything to the cloud, so I waited 24 hours
    2. Downloaded Samsung Kies 3.0 and installed on my computer
    3. Using Samsung Kies, backed up the phone, selecting ALL available options/categories (home screen, photos, applications, messages, phone logs, etc.)
      Note: restoring is not as clean as I had hoped. I thought that it would save all of my Home Screens/Customizations, but it did not
    4. Settings/Accounts/BackupAndReset
    5. Factory Data Reset; Phone Reboots when it's done.
    6. I did NOT immediately add any accounts (such as Gmail or Samsung) during the setup.
    7. IMPORTANT STEP: I would strongly recommend that you turn OFF that AT+T Navigator App NOW (see steps outlined earlier)
    8. Loaded Kies 3.0 computer and Restored Data
    9. Then added accounts.
    10. Then updated all PlayStore apps etc.
    11. Last step was to set my Home Screens/Icons back as they were.
      Samsung should really do a better job of creating a backup program.
  10. #10  

    Default Re: 4G does not turn off when WiFi is connected

    Every since an update (to Android version 4.3 with Baseband version I747UCUEMJB) was made available to my Galaxy S3 in mid November from AT&T, I have been encountering the SAME ISSUE as you have reported with access points I have previously NEVER had an issue with. The only change to my phone was the mistake I made in applying the update I was prodded with to install from AT&T.
  11. #11  
    hsk1610's Avatar

    Posts
    13 Posts
    Global Posts
    17 Global Posts

    Default Re: 4G does not turn off when WiFi is connected

    I turned off AT&T Navigator but still no luck. 4G is overridding the wifi. Only way to get wifi to work is to turn mobile data off, then have no issues. Otherwise, get the same checking quality of internet connection and then off.
  12. #12  

    Default Re: 4G does not turn off when WiFi is connected

    What I did, was a factory reset, back it up on KIES. Thats the only thing that worked for me!
  13. #13  

    Default Re: 4G does not turn off when WiFi is connected

    Downloading update as I type this, but I have never relied on the OS (or whatever process controls it) to reliably shut off data when within wifi range and connectivity. My home screen has a data toggle widget that gets a good deal of use.
  14. #14  

    Default Re: 4G does not turn off when WiFi is connected

    I finally figured out how to fix the proublem all you have to do is leave your phone on airplane mode for one whole night. When this proublem first started I would turn on airplane mode for a few minutes and it would do the trick but after A while it dident work anymore and it was running up all my 4g but leaving it in airplane mode all night did the trick hope this helps.
  15. #15  

    Default Re: 4G does not turn off when WiFi is connected

    Galax S4 on VZW.

    Turned off wifi and mobile

    Turned on Airplane mode.

    Rebooted

    Disabled Airplane mode

    Turned on mobile data then wifi.

    Booya! 4G icon is gone.

    Good luck guys!
  16. #16  

    Default Re: 4G does not turn off when WiFi is connected

    Quote Originally Posted by The Critik View Post
    Galax S4 on VZW.

    Turned off wifi and mobile

    Turned on Airplane mode.

    Rebooted

    Disabled Airplane mode

    Turned on mobile data then wifi.

    Booya! 4G icon is gone.

    Good luck guys!
    This also fixed my wife's replacement Galaxy S3 which was using mobile data when WiFi was available.

    THANKS!
  17. #17  

    Default Re: 4G does not turn off when WiFi is connected

    Quote Originally Posted by KCAndroid1 View Post
    Factory reset may be your best answer. Outside of that, I use an app called WiFi Matic. It turns off WiFi when not connected, and it can be set to turn off mobile data while on WiFi. It may be worth a try to override your current system problem before doing a reset.
    Just downloaded this and it's working for me...my data was getting hammered for no reason as I just use WiFi, this has helped heaps I feel...thanx!!
  18. #18  

    Default Re: 4G does not turn off when WiFi is connected

    Just a heads up I recently learned - if you turn off mobile data while on WiFi, your text messages might say they cannot download, because they go through the cell network, not wifi.
  19. #19  

    Default Re: 4G does not turn off when WiFi is connected

    Wi-Fi Matic - Auto WiFi On Off (Carlos Prados) OR
    Wifi matic (Khad Mobile App)
  20. #20  

    Default Re: 4G does not turn off when WiFi is connected

    Quote Originally Posted by Eric White5 View Post
    Just downloaded this and it's working for me...my data was getting hammered for no reason as I just use WiFi, this has helped heaps I feel...thanx!!
    I see on Google Play there's these 2 apps > Wi-Fi Matic - Auto WiFi On Off (Carlos Prados) and Wifi matic (Khad Mobile App)
    which one are you using?...thanks
  21. #21  

    Default Re: 4G does not turn off when WiFi is connected

    Quote Originally Posted by KCAndroid1 View Post
    Just a heads up I recently learned - if you turn off mobile data while on WiFi, your text messages might say they cannot download, because they go through the cell network, not wifi.
    I see on Google Play there's these 2 apps > Wi-Fi Matic - Auto WiFi On Off (Carlos Prados) and Wifi matic (Khad Mobile App)
    which one are you using?...thanks
  22. #22  

    Default Re: 4G does not turn off when WiFi is connected

    I'm using WiFi Matic by Carlos Prados. It's been effective and trouble-free.
  23. #23  

    Default Re: 4G does not turn off when WiFi is connected

    Just edit de Default XML file located in /system/customize/ACC/default.xml

    To change region and SKU_ID use a root explorer (Root explorer, ES File Explore etc.)

    Open: "/system/customize/ACC/default.xml"

    Scroll to the end:

    AT&T Galaxy S3: 4G does not turn off when WiFi is connected-default.png



    Edit "<item type="integer" name="region">X</item>" and "<item type="integer" name="sku_id">X</item>" according to the list below

    When done, REBOOT your device.


    HTC_DUTCH = 115
    HTC_EUROPE = 42
    HTC_FRA = 117
    HTC_GENERIC = 0
    HTC_GER = 118
    HTC_ISR = 2
    HTC_ITA = 119
    HTC_LA_AMX_SPA = 18
    HTC_LA_ENTEL_SPA = 19
    HTC_LA_ESN_TELCEL = 21
    HTC_LA_IUSACELL_MX_SPA = 22
    HTC_LA_SPA = 23
    HTC_LA_TELEFONICA_SPA = 24
    HTC_NORDIC = 120
    HTC_RUS = 43
    HTC_RUS_UKR = 106
    HTC_SPA = 121
    HTC_WWE_EASTEUROPE = 99
    HTC_WWE_FOR_US_BRIGHTPOINT = 3
    HTC_WWE_MMR = 4
    HTC_WWE_MMR_UT = 78
    HTC_WWE_S_AFRICA = 109
    KDDI_JP = 31
    KDDI_ODM_JP = 79
    KT_KR = 80
    METROPCS_US = 81
    O2_DE = 44
    O2_UK = 45
    OPENMOBILE_US = 82
    OPTUS_AU = 36
    ORANGE_CH_GENERIC = 46
    ORANGE_ES = 47
    ORANGE_ES_CAT_CATALONIAN = 83
    ORANGE_FR = 48
    ORANGE_FR_B2B_TLS = 84
    ORANGE_PL = 49
    ORANGE_UK = 50
    ROGERS_WWE = 9
    SPRINT_WWE = 10
    SPRINT_WWE_BOOST = 85
    SPRINT_WWE_VM = 98
    TELECOM_NZ_WWE = 51
    TELEFONICA = 97
    TELSTRA_WWE = 37
    TELUS_WWE = 38
    TIM_IT_TELECOM_ITALIAN = 52
    TMOUS = 11
    TMO_AT = 53
    TMO_AT_TELERING = 54
    TMO_CZ = 55
    TMO_DE = 56
    TMO_GR = 86
    TMO_NL = 57
    TMO_PL = 58
    TMO_UK = 59
    TSMC_TW = 96
    TWM_TW = 74
    US_CELLULAR_WWE = 87
    UTSTARCOM_WWE_GENERIC = 12
    VERIZON_WWE = 13
    VIRGIN_MOBILE = 88
    VODAFONE_AT = 61
    VODAFONE_AU = 89
    VODAFONE_CH_GER = 62
    VODAFONE_FRA_FR = 63
    VODAFONE_GER_DE = 64
    VODAFONE_GR = 90
    VODAFONE_ITA_IT = 91
    VODAFONE_NL = 65
    VODAFONE_PTG = 66
    VODAFONE_SPA_ES = 67
    VODAFONE_UK = 68
    VODAFONE_UK_NFC = 92
    VODAFONE_ZA_WWE_VODACOM = 93
    VODA_HUTCH_AU = 60

    Try to choose a different carrier than ATT for instance I used HTC_LA_ESN_TELCEL = 21 on my ATT HTC ONE M8 and it worked no more wifi and 4GLTE icons at the same time.

    I should work for SG3 and SG4 or SG5 you just need to find the carrier .xml and edit it.
  24. #24  

    Default Re: AT&T Galaxy S3: 4G does not turn off when WiFi is connected

    I thought I saw a mention of a setting related to this in a different forum - there was a screenshot of Settings -> Wi-Fi -> Menu button -> Advanced that showed a bunch of options which are not there on my Verizon phone, and one of them was named something like this. You might take a look at the Advanced options and see what you find.

    It's this. Go to Settings / WiFi / Menu Button / Advanced and uncheck "Auto Network Switch." This is what causes the phone to switch from 4G to wifi and back to 4G if it thinks your wifi network is unstable.
  25. #25  

    Default Re: AT&T Galaxy S3: 4G does not turn off when WiFi is connected

    It was AT&T Navigator for me! I uninstalled updates and then turned it off and now my wifi is working again (without having to turn off mobile data). Yay! This has been driving me crazy! I did not do a factory reset or anything else. Just turned off AT&T Navigator (which I've never even used) and that was it. Hope this helps someone else.
    GSDer likes this.
Page 1 of 2 12 LastLast

Similar Threads

  1. Sprinters Is your G2 coming yet?
    By BioMed007 in forum LG G2
    Replies: 3
    Last Post: 11-12-2013, 06:13 PM
  2. Replies: 3
    Last Post: 11-06-2013, 10:19 PM
  3. HTC One won't turn on!! Please help!!
    By alizonmi in forum HTC One M7
    Replies: 2
    Last Post: 11-05-2013, 03:28 PM
  4. Play store and google chrome not working
    By cowboys703 in forum Samsung Galaxy Note 8.0
    Replies: 1
    Last Post: 11-05-2013, 02:31 PM
  5. How to set the length of alarm going off?
    By Ares125 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 11-05-2013, 11:43 AM

Posting Permissions