I know how to hide the contacts. .I thought it would be good enough, but even though I hid them, they still show up on my dialer. Like if I put 9 as the first number. It will show all contacts that starts with that number including skype contacts. ..How do I fix this?. My skype setting has it set to don't sync and so does my accounts in my phone settings.

Posted via Android Central App